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ERS186L – Environmental Remote Sensing Lab 

Spring 2011 

 
Location: 1137 PES 

Hours: 10:00-11:50, T, Th 

Door code and computer access information will be provided to registered students on the first 

day of lab. 

 

Base Directory: My Documents\ERS_186\Lab_Data 

Your Directory: My Documents\ERS_186\[your name] 

 

Schedule 

Date Lab* Topic 

March 29 L1 Introduction to ENVI 

March 31 L1, A1 Fieldwork Exercise, Introduction to ENVI, Image Exploration 

Assignment 

April 5 A1 Fieldwork Exercise, Image Exploration Assignment 

April 7 L2 Georegistration & Mosaicking 

April 12 L3, A2 Vector Data, Georegistration Assignment 

April 14 A2 Georegistration Assignment, cont. 

April 19 L4 Data Reduction I: Indexes 

April 21 L5 Data Reduction II: Principal Components  

April 26 L6 Unsupervised and Supervised Classification 

April 28 A3 Classification & Data Reduction Assignment 

May 3 A3 Classification & Data Reduction Assignment, cont. 

May 5 A3 Classification & Data Reduction Assignment, cont. 

May 10 L7, A4 Change Detection Lab, Change Detection Assignment 

May 12 L8, A4 Map Composition Lab, Change Detection Assignment, cont. 

May 17 A4 Change Detection Assignment, cont. 

May 19 A4 Change Detection Assignment, cont. 

May 24 L9 Wildfire Exercise Lab  

May 26 L10,A5 Spectral Mapping and Unmixing Lab & Assignment 

May 31 L11,A5 LIDAR Lab Exercise, Spectral Mapping and Unmixing 

Assignment, cont. 

June 2 A6 LIDAR Assignment 

* LX = Lab exercise #X; AX = Lab Assignment #X. 

 

Lab Exercises 

You will complete 11 lab exercise tutorials in ERS186L.  These tutorials have been designed to 

familiarize you with common image processing tools and will provide you with the background 

and skills necessary to complete your assignments.  In addition, there will be two days of 

fieldwork exercises to introduce you the data collection techniques corresponding to remote 

sensing research. 
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Assignments 

There will be 5 lab assignments in ERS186L and each of these assignments will be worth 20% of 

your grade for the quarter.  If you are unable to complete an assignment during the time provided 

in the lab sessions, check the computer lab‘s schedule and return to work on it when no classes 

are meeting.  All assignments should be submitted by 8am on the day it is due to the ERS186L 

Smartsite page at smartsite.ucdavis.edu.  Late work will be penalized.  

  

All assignments must be submitted electronically in Microsoft word format. Please remember that 

your homework assignments must be clear, well-written, and of professional quality (include your 

name, titles/numbering, etc).  You will be required to include screen shots of your work in your 

lab write-ups. These MUST be inserted into your Word document as JPEGs.   

 

When submitting your assignments, please use the following file naming convention:  

Last name, First name, Lab#, and the date submitted (i.e. Doe_John_Lab4_05242011). 

 

Date Lecture # Lecture homework  assigned or due Lab homework assigned or due 

29-Mar Lecture 1 Homework 1 assigned   

31-Mar Lecture 2   Homework 1 assigned 

5-Apr Lecture 3     

7-Apr Lecture 4 Homework 1 due; HW 2 assigned   

12-Apr Lecture 5   Homework 1 due; HW 2 assigned 

14-Apr Lecture 6     

19-Apr Lecture 7 Homework 2 due   

21-Apr 1st midterm     

26-Apr Lecture 9 Homework 3 assigned  Homework 2 due; HW 3 assigned 

28-Apr Lecture 10     

3-May Lecture 11     

5-May Lecture 12 Homework 3 due; HW 4 assigned   

10-May Lecture 13   Homework 3 due; HW 4 assigned 

12-May Lecture 14     

17-May Lecture 15  Homework 4 due   

19-May 2nd  midterm     

24-May Lecture 17  Homework 5 assigned Homework 4 due 

26-May Lecture 18    HW 5 assigned 

31-May Lecture 19     

2-Jun Lecture 20 Homework 5 due  Lab 6 - in class exercise 

3-Jun     Homework 5 due 

8-Jun 

Final: 

1:00pm     
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Tutorial 1: Getting Started with ENVI 
The following topics are covered in this tutorial: 

Overview of This Tutorial 

Getting Started with ENVI 

Overview of This Tutorial 
This tutorial provides basic information about ENVI and some suggestions for your initial investigations of 

the software. It is designed to introduce you to the basic concepts of the software and to explore some of 
its key features. If you are new to ENVI, this quick-start tutorial is designed to provide a quick 

demonstration of the product. The following exercises briefly introduce you to the graphical user interface 

and basic capabilities of ENVI. 

Files Used in This Tutorial 

Path: My Documents\ERS_186\Lab_Data\Multispectral\Landsat 

File Description 

Delta_LandsatTM_2008.img SF Bay-Delta, CA, TM Data 

Delta_LandsatTM_2008.hdr ENVI Header for Above 

Delta_classes_vector.evf ENVI Vector File 

Working with ENVI 
ENVI uses a graphical user interface (GUI) to provide point-and-click access to image processing 

functions. Menu choices and functions are selected using a three-button mouse. 

Note: In Windows, using a two-button mouse, you can simulate a middle mouse button click by holding 

down the Ctrl key and pressing the left mouse button. On a Macintosh with a one-button mouse, hold 
down the Option key while pressing the mouse button to simulate a right mouse button click. To simulate a 

middle mouse button click, hold down the Command key while pressing the mouse button.  

When you start ENVI, the ENVI main menu appears as a menu bar. Clicking with the left mouse button on 

any of the ENVI main menu topics brings up a menu of options, which may in turn contain submenus with 
further options. The choices selected from these submenus will often bring up dialog boxes that allow you 

to enter information or set parameters relating to the ENVI function you have selected. 

ENVI File Formats 

ENVI uses a generalized raster data format consisting of a simple flat binary file and a small 
associated ASCII (text) header file. This file format permits ENVI to use nearly any image file, 

including those that contain their own embedded header information. Generalized raster data is stored 

as a binary stream of bytes in either Band Sequential (BSQ), Band Interleaved by Pixel (BIP), or Band 
Interleaved by Line (BIL) format. 

 BSQ is the simplest format, with each line of data followed immediately by the next line of the 

same spectral band. BSQ format is optimal for spatial (x, y) access to any part of a single spectral 

band. 

 BIP format provides optimal spectral processing performance. Images stored in BIP format have 

the first pixel for all bands in sequential order, followed by the second pixel for all bands, followed 
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by the third pixel for all bands, etc., interleaved up to the number of pixels. This format provides 

optimum performance for spectral (Z) access of the image data. 

 BIL format provides a compromise in performance between spatial and spectral processing and is 

the recommended file format for most ENVI processing tasks. Images stored in BIL format have 

the first line of the first band followed by the first line of the second band, followed by the first 

line of the third band, interleaved up to the number of bands. Subsequent lines for each band are 

interleaved in similar fashion.  

ENVI also supports a variety of data types: byte, integer, unsigned integer, long integer, unsigned long 

integer, floating-point, double-precision floating-point, complex, double-precision complex, 64-bit 

integer, and unsigned 64-bit integer.  

The separate text header file provides information to ENVI about the dimensions of the image, any 

embedded header that may be present, the data format, and other pertinent information. The header file 

is normally created (sometimes with your input) the first time a particular data file is read by ENVI. 
You can view and edit it at a later time by selecting File → Edit ENVI Header from the ENVI main 

menu bar, or by right-clicking on a file in the Available Bands List and selecting Edit Header. You 

can also generate ENVI header files outside ENVI, using a text editor. 

Getting Started with ENVI 

Starting ENVI 

Select Start → All Programs → ENVI 4.7 → ENVI. 

Loading a Grayscale Image 

Open the multispectral Landsat Thematic Mapper (TM) data file of the San Francisco Bay and 

Sacramento-San Joaquin Delta, California, USA. 

Open an Image File 

To open an image file: 

1. Select File → Open Image File. 

The Enter Data Filenames file selection dialog appears. 

2. Navigate to C:\My Documents\Lab_Data\Multispectral\Landsat and select the file 

Delta_LandsatTM_2008.img from the input directory and click Open. The Available 

Bands List dialog that appears on your screen will allow you to select spectral bands for display 

and processing (Figure 1-1). 

 The Available Bands List 

ENVI provides access to both image files and to the individual spectral bands in these files. The 

Available Bands List is a special ENVI dialog containing a list of all the available image bands in all open 
files, as well as any associated map information. 

You can use the Available Bands List to load both color and grayscale images into a display by 

starting a new display or selecting the display number from the Display #N button menu at the bottom of 

the dialog, clicking on the Gray Scale or RGB radio button, then selecting the desired bands from the list 
by clicking on the band names. 
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Figure 1-1: The Available Bands List 

Tip: To load a single-band image, simply double-click on the band. 

 

The File menu at the top of the Available Bands List dialog provides access 

to file opening and closing, file information, and canceling the Available 
Bands List. The Options menu provides a function to find the band closest to 

a specific wavelength, shows the currently displayed bands, allows toggling 

between full and shortened band names in the list, and provides the 
capability to fold all of the bands in a single open image into just the image 

name. Folding and unfolding the bands into single image names or lists of 

bands can also be accomplished by clicking on the + (plus) or – (minus) 

symbols to the left of the file name in the Available Bands List dialog. 

Using the Available Bands List Shortcut Menus 

Right-clicking in the Available Bands List displays a shortcut menu with 

access to different functions. The shortcut menu selections will differ 

depending on what item is currently selected (highlighted) in the Available 

Bands List. For example, right-clicking on the Map Info icon under a 
filename displays a shortcut menu for accessing map information in that 

file‘s header, whereas right-clicking on the filename displays a shortcut 

menu with selections to load the image or close the file. 

 

1. Select Band 4 in the dialog by clicking on the band name in the Available Bands List with 

the left mouse button. The band you have chosen is displayed in the field marked Selected 
Band: 

2. Click on the Gray Scale toggle button and then Load Band in the Available Bands List to 

load the image into a new display.  

Band 4 will be loaded as a gray scale image. 

Familiarizing Yourself with the Displays 

When the image loads, an ENVI image display appears on your screen. The display group consists of a 

Main Image window, a Scroll window, and a Zoom window. These three windows are intimately linked; 
changes to one window are mirrored in the others. 

Tip: You can choose which combination of windows appear on the screen by right-clicking in any 

image window to display the shortcut menu and selecting a style from the Display Window Style 

submenu.  

All windows can be resized by grabbing and dragging a window corner with the left mouse button. 

1. Resize the Main Image window.  Note how the size of the Image window affects the outlining 
box in the Scroll window. 

2. Next, try resizing the Zoom window to see how the outlining box changes in the Image window. 

The basic characteristics of the ENVI display group windows are described in the following sections. 
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The Scroll Window 

The Scroll window displays the entire image at reduced resolution (subsampled). The subsampling factor 

is listed in parentheses in the window Title Bar at the top of the image. The highlighted scroll control box 

(red by default) indicates the area shown at full resolution in the Main Image window.  

 To reposition the portion of the image shown in the Main Image window, position the mouse 

cursor inside the scroll control box, hold down the left mouse button, drag to the desired 

location, and release. The Main Image window is updated automatically when the mouse 

button is released. 

 You can also reposition the cursor anywhere within the Scroll window and click the left mouse 

button to instantly move the selected Main Image window area. If you click, hold, and drag the 

left mouse button in this fashion, the Image window will be updated as you drag (the speed 

depends on your computer resources). 

 Finally, you can reposition the image by clicking in the Scroll window and pressing the arrow 

keys on your keyboard. To move the image in larger increments, hold down the Shift key 
while using the arrow keys. 

The Main Image Window 

The Main Image window shows a portion of the image at full resolution. The zoom control box (the 

colored box in the Main Image window) indicates the region that is displayed in the Zoom window. 

 To reposition the portion of the image magnified in the Zoom window, position the mouse 

cursor in the zoom control box, hold down the left mouse button, and move the mouse. The 
Zoom window is updated automatically when the mouse button is released. 

 Alternately, you can reposition the cursor anywhere in the Main Image window and click the 

left mouse button to move the magnified area instantly. If you click, hold, and drag the left 

mouse button in this fashion, the Zoom window is updated as you drag. 

 Finally, you can move the Zoom indicator by clicking in the box and using the arrow keys on 

your keyboard. To move several pixels at a time, hold down the Shift key while using the 

arrow keys. 

 The Main Image window can also have optional scroll bars, which provide an alternate 

method for moving through the Scroll window image, allowing you to select which portion of 
the image appears in the Image window. To add scroll bars to the Main Image window, right-

click in the image to display the shortcut menu and select Toggle → Display Scroll Bars. 

Tip: To have scroll bars always appear in the Main Image window by default, select File → 

Preferences from the ENVI main menu. Select the Display Defaults tab in the System 

Preferences dialog, and set the Image Window Scroll Bars toggle to Yes. 

The Zoom Window 

The Zoom window shows a portion of the image, magnified the number of times indicated by the 
number shown in parentheses in the Title Bar of the window. The zoom area is indicated by a 

highlighted box (the zoom control box) in the Main Image window. 

There is a small control graphic (red by default) in the lower left corner of the Zoom window. This 
graphic controls the zoom factor and also the crosshair cursor in both the Zoom and Main Image 

windows. 

 Move the mouse cursor in the Zoom window and click the left mouse button to reposition the 

magnified area by centering the zoomed area on the selected pixel. 
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Figure 1-2: Image Display Shortcut Menu 

 Move the Zoom window by clicking in it and using the arrow keys on your keyboard. To 

move several pixels at a time, hold down the Shift key while using the arrow keys. 

 Clicking and holding the left mouse button in the Zoom window while dragging causes the 

Zoom window to pan within the Main Image display.  

 Clicking the left mouse button on the – (minus) graphic in the lower left corner of the Zoom 

window zooms out by a factor of 1. Clicking the middle mouse button on this graphic zooms 

out to half the current magnification. Clicking the right mouse button on the graphic returns 

the zoom window to the default zoom factor. 

 Clicking the left mouse button on the + (plus) graphic in the lower left corner of the Zoom 
window zooms in by a factor of 1. Clicking the middle mouse button doubles the current 

magnification. Clicking the right mouse button on the graphic returns the Zoom window to the 

default zoom factor. 

 Click the left mouse button on the right (third) graphics box in the lower left corner of the 

Zoom window to toggle the Zoom window crosshair cursor. Click the middle mouse button on 
this graphic to toggle the Main Image crosshair cursor. Click the right mouse button on this 

graphic to toggle the Zoom control box in the Main Image window on or off.  

Note: On Microsoft Windows systems with a two button mouse, click the Ctrl key and the left 

mouse button simultaneously to emulate the middle mouse button. 

 The Zoom window can also have optional scroll bars, which provide an alternate method for 

moving through the Zoom window. To add scroll bars to the Zoom window, right-click in the 
Zoom window to display the shortcut menu and select Toggle → Zoom Scroll Bars. 

Tip: To have scroll bars appear on the Zoom window by default, select File → Preferences from 

the ENVI main menu. Select the Display Defaults tab, and set the Zoom Window Scroll 

Bars toggle to Yes. 

The Display Group Menu Bar 

The menu bar at the top of the Main Image window gives you access to many ENVI features that 

relate directly to the images in the display group. If you have chosen to display only the Scroll and 

Zoom windows or simply the Zoom window, the menu bar 

will appear at the top of the Zoom window. 

Image Display Shortcut Menus 

Each of the three display windows has a shortcut menu for 

accessing general display settings and some interactive 

functions.  

To access the shortcut menu in any display window, right-
click in the window (Figure 1-2). 

Displaying the Cursor Location and Value 

The cursor location and value can be obtained simply by 

passing the cursor over the Main Image, Scroll, or Zoom 

windows (Figure 1-3). The Cursor Location/Value dialog 
displays the location of the cursor in pixels starting from an 

origin in the upper-left corner of the Main Image window; 

and it also shows the RGB color values associated with that 
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Figure 1-4: Pixel Locator Window 

Figure 1-3: the Cursor Location/Value Dialog 

location. When the Cursor Location/Value dialog display is open, it shows the Main Image display 

number, cursor position, screen value (RGB color), and the actual data value of the pixel underneath 
the crosshair cursor. If your image has map information associated with it, the geographic position of 

your cursor location is also displayed.  When several Main Image displays are open, the dialog 

specifies which display‘s location and value are being reported. 

 To display the cursor location and value, select 

Window → Cursor Location/Value from the ENVI main 
menu or the Main Image window menu bar, or right-click in 

the image window to display the shortcut menu and select 

Cursor Location/Value (Figure 1-3). 

 

 To 

dismiss the dialog, select File → Cancel 
from the menu at the top of the Cursor 
Location /Value dialog. 

 To hide/unhide the Cursor Location/Value dialog once it has been displayed, double-click using 

the left mouse button in the Main Image window. 

Using the Pixel Locator 

The Pixel Locator allows exact positioning of the cursor. You can 

manually enter a sample and line location to position the cursor 
in the center of the Zoom window. If an image contains 

georeferenced data, you can optionally locate pixels using map 

coordinates. If the image contains an associated DEM, elevation 

information displays. The Pixel Locator pertains to the display 
group from which it was opened. You can open a Pixel Locator 

for each display group shown on your screen. 

1. From the Image window menu bar, select Tools → Pixel 

Locator to open the Pixel Locator dialog (Figure 1-4). 

2. Place the cursor in any of the three windows of the image 
display group and click the left mouse button. Notice that 

the Pixel Locator provides the pixel location for the 

selected pixel. 

3. Skip around in the image by entering the X (sample) and Y (line) coordinates you wish to visit and 
click Apply. 

4. Click the toggle button next to the projection field to toggle between true map coordinates and 

latitude/longitude geographic coordinates. You can also choose to change the selected projection 
by clicking the Change Proj button. 

5. From the Pixel Locator dialog menu bar, select File → Cancel to close the Pixel Locator dialog. 

Display Image Profiles 

X (horizontal), Y (vertical), and Z (spectral) profile plots can be selected and displayed interactively. 

These profiles show the data values across an image line (X), column (Y), or spectral bands (Z). 

To display these profiles, perform the following steps. 
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Figure 1-6: The Spectral Profile Window 

6. Select Tools → Profiles → X Profile from the Main Image display menu bar to display a window 

plotting data values versus sample number for a selected line in the image (Figure 1-5). 

7. Repeat the process, selecting Y Profile to display a plot of data value versus line number, and 

selecting Z Profile to display a spectral plot (Figure 1-5). 

Tip: You can also open a Z profile from the shortcut menu in any image window. 

8. Select Window → Mouse Button Descriptions to view the descriptions of the mouse button 

actions in the Profile displays. 

9. Position the Profile plot windows so you can see all three at once. A red crosshair extends to the 

top and bottom and to the sides of the Main Image window. The red lines indicate the line or 

sample locations for the vertical or horizontal profiles. 

10. Move the crosshair around the image (just as you move the zoom indicator box) to see how the 
three image profile plots are updated to display data on the new location. 

11. Close the profile plots by selecting File → Cancel from within each plot window. 

 

Figure 1-5: The Horizontal (X) Profile (left) and Spectral (Z) Profile (right) Plots 

Collecting Spectra 

When collecting spectral profiles in your image, you 

can ―drag and drop‖ spectra from the z profile window 

into a new ENVI plot window. 

1. In the Spectral Profile window, select 

Options → Plot Key. Or you can right click 

on the window and select plot key from the 

shortcut menu. The plot key default name is 
the x,y coordinates of the pixel you selected 

(Figure 1-6). 

2. To collect spectra in the Spectral Profile 
window, select Options → Collect Spectra.  

Now navigate through your image. Each pixel 

you select will be plotted in the Spectral profile Window.   

3. To edit plot parameters, select Edit→ Plot Parameters… You can edit the x- and y-axis scale, 

names, and appearance of the plot. 

4. To open a new ENVI plot window, select Options → New Window: Blank… to open a new 

window without plots, or Options → New Window: With Plots…  
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5. Drag the plot key of a spectrum from the Spectral Profile window to the new blank ENVI Plot 

Window. 

6. To rename a spectrum, select Edit→ Data Parameters. You can change the name, and 

appearance of the line in this dialog. 

7. To save a spectral plot as a spectral library (or an image file), select File→ Save Plot As → 

Spectral library → Select All Items → OK → Check Output Result to Memory.  The spectral 
library will show up in your Available Bands List, and will be refered to later in this exercise. 

Applying a Contrast Stretch 

By default, ENVI displays images with a 2% linear contrast stretch.  

1. To apply a different contrast stretch to the image, select Enhance from the Main Image display 

menu bar to display a list of six default stretching options for each of the windows (Image, Zoom, 
Scroll) in the display group. 

2. Select an item from the list (for example, Enhance → [Image] Equalization to apply a histogram 

equalization contrast stretch to the Image display). This action also updates the Scroll and Zoom 
windows of the display group. Try applying several of the different available stretches. 

Alternatively, you can define your contrast stretch interactively by selecting Enhance → Interactive 

Stretching from the Main Image display menu bar. 

Loading an RGB Image 

ENVI allows you to simultaneously display multiple grayscale and/or RGB color composite images. 

1. To load a color composite (RGB) image of the delta area, click on the Available Bands List. 

Note: If you dismissed the Available Bands List during the previous exercises, you can recall it by 

selecting Window → Available Bands List from the ENVI main menu bar. 

2. Click on the RGB Color radio button in the Available Bands List. Red, Green, and Blue fields 
appear in the middle of the dialog. 

3. Select Band 4, Band 3, and Band 2 sequentially from the list of bands at the top of the dialog by 

left-clicking on the band names. The band names are automatically entered in the Red, Green, and 
Blue fields. 

4. Click on the Display # button at the bottom of the Available Bands List to open a New Display in 

which to load the RGB image. 

5. Click Load RGB to load the image into a Main Image window. 

Link Two Displays 

Link the two displays together for comparison. When you link two displays, any action you perform 

on one display (scrolling, zooming, etc.) is echoed in the linked display. To link the two displays you 
have on screen now do the following.  

1. From the Main Image Display menu, select Tools → Link → Link Displays, or right-click in the 

image to display the shortcut menu and select Link Displays. The Link Displays dialog opens. 

2. Click OK in the Link Displays dialog to establish the link.  

3. Now try scrolling or zooming in one display group and observe as your changes are mirrored in 

the second display. 
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Dynamic Overlays 

ENVI‘s multiple Dynamic Overlay feature allows you to dynamically superimpose parts of one or 

more linked images onto the other image. Dynamic overlays are turned on automatically when you 

link two displays, and may appear in either the Main Image window or the Zoom window. 

1. To start, click the left mouse button to see both displays completely overlaid on one another. 

2. To create a smaller overlay area, position the mouse cursor anywhere in either Main Image 

window (or either Zoom window) and hold down and drag with the middle mouse button. 
Upon button release, the smaller overlay area is set and a small portion of the linked image 

will be superimposed on the current image window. 

3. Now click the left mouse button and drag the small overlay window around the image to see 

the overlay effects. 

4. You can resize the overlay area at any time by clicking and dragging the middle mouse button 

until the overlay area is the desired size. 

You can turn off the dynamic overlay by right clicking in the image window and choosing 
Dynamic Overlay Off. 

Mouse Button Functions with Dynamic Overlays Off  

The following table specifies the mouse button functions for linked images when dynamic overlay is off.  
 

Table 1-1: Mouse Button Functions – Linked Images without Dynamic Overlays  

Mouse Button Function  

Left  

 

Clicking and dragging inside the Zoom box causes repositioning of the selected 

Zoom window. The portion of the image displayed in the Zoom window is updated 

when released.  

Middle  
 

Position the current pixel at the center of the Zoom window.  

Right  Click to display the right-click menu. 

Linking Multi-Resolution Georeferenced Images  

Use Geographic Link to link display groups and Vector windows containing georeferenced data. When 
linked, all displayed georeferenced images and Vector windows update to the current cursor map location 

when you move the cursor. This function works regardless of the projection, pixel size, and rotation factor 

of each data set. Geographic Link does not provide any on-the-fly reprojection, resampling, or dynamic 

overlay. To reproject and resample data sets to the same projection and resolution, see Layer Stacking.  

To create a geographic link:  

1. From the Display group menu bar, select Tools →Link →Geographic Link. The Geographic 

Link dialog displays.  

2. Select the displays to link and click the associated toggle buttons to On to link the displays. Click 

OK.  
3. When you move the cursor in one georeferenced Image or Vector window, the cursor in all other 

georeferenced images and vector windows will move to the same map location. 

To turn a geographic link off:  

1. From the Display group menu bar, select Tools →Link →Geographic Link. The Geographic 

Link dialog displays.  
2. Click the toggle buttons beside the display names to select Off for the displays to unlink. 

3. Click OK. 
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Editing ENVI Headers  

Use Edit ENVI Header to edit existing header files. See Editing Header Files in ENVI Online Help for 
steps to open the Header Info dialog and edit required header information. See the next section for details 

about editing optional header information.  

Entering Optional Header Information  

ENVI headers may have associated ancillary information (band names, spectral library names, 

wavelengths, bad bands list, FWHM) depending on the image data type.  In the Header Info dialog, click 

Edit Attributes and select the desired option to edit optional header information.  

Editing Band Names or Spectral Library Names  

You can edit the default names of bands or spectral libraries. The dialog to perform either of these 

functions is similar, so both are described here.   

1. In the Header Info dialog, click Edit Attributes and select either:  

a. Band Names — The Edit Band Name values dialog appears. 

OR 
b. Spectral Library Names — The Edit Spectral Library Names values dialog appears.  

2. Select the band name or spectral library name to change in the list. The name appears in the Edit 
Selected Item field. 

3. Type the new name and press Enter. Click OK 

Setting Default Bands to Load  

You can identify bands to automatically load into the a new display group when you open the file. You can 

select either a gray scale image or a color image.  
1. In the Header Info dialog, click Edit Attributes and select Default Bands to Load. The Default 

Bands to Load dialog appears with a list of all the bands in the file. 

2. Select the band names to load in the red (R), green (G), and blue (B) options. If you select only 
one band, it is loaded as a gray scale image. 

3. Click Reset to clear the bands. Click OK.  

The Header Info dialog appears. When you open the file, ENVI automatically loads the bands into a new 

display group. 

Editing Wavelengths or FWHM  

1. In the Header Info dialog, click Edit Attributes and select either:  

a. Wavelengths — The Edit Wavelength values dialog appears. 

OR 

b. FWHM — The Edit FWHM values dialog appears. 
2. Select the value to change in the list. The value appears in the Edit Selected Item field. Type the 

new value and press Enter. 

In the Wavelength/FWHM Units drop-down list, select the units to use with your wavelength and 
FWHM values. The wavelength units are used to scale correctly between different wavelength units in 

ENVI's Endmember Collection dialog. For more information, see Collecting Endmember Spectra. 

      3. Click OK. 

Selecting Bad Bands  

Use Bad Bands List to select bands to exclude from plotting or optionally omit during processing. The Bad 
Bands list is often used to omit the water vapor bands in hyperspectral data sets.  
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1. In the Header Info dialog, click Edit Attributes and select Bad Bands List. The Edit Bad Bands 

List values dialog appears. 
2. All bands in the list are highlighted by default as good. Deselect any desired bands in order to 

designate them as bad bands. 

3. To designate a range of bands, enter the beginning and ending band numbers in the fields next to 

the Add Range button. Click Add Range. 
4. Click OK. 

Changing Z Plot Information  

Use Z Plot Information to change Z profiles, set axes titles, set a Z Plot box size, or specify an additional Z 

profile filename.  

 
1. In the Header Info dialog, click Edit Attributes and select Z Plot Information. The Edit Z Plot 

Information dialog appears. 

2. Enter the minimum range value in the left and maximum value in the Z Plot Range fields.  
3. Enter the desired axes titles in the X Axis Title and Y Axis Title fields.  

4. To specify the size (in pixels) of the box used to calculate an average spectrum, enter the 

parameters into the Z Plot Average Box fields. 
5. To specify an additional filename from which to extract Z profiles, click Default Additional Z 

Profiles. The Default Additional Z Profiles dialog appears. 

6. Click Add New File. 

7. Select the desired filename and click OK. The filename appears in the list. 
8. To remove a filename from the list, select the filename and click Remove Selected File. 

9. Click OK, then click OK again. 

Entering a Reflectance Scale Factor  

Use Reflectance Scale Factor to enter a reflectance scale factor that is used in ENVI's Endmember 

Collection to correctly scale library data or other reflectance data to match the image data. If one of the 
files used in the Endmember Collection does not have a reflectance scale factor defined, then no scaling is 

done.  

1. In the Header Info dialog, click Edit Attributes and select Reflectance Scale Factor. 
2. Enter the value that, when divided into your data, would scale it from 0 to 1. For example, if the 

value of 10,000 in your data represents a reflectance value of 1.0, enter a reflectance scale factor of 

10,000. 

3. Click OK. The Header Info dialog appears. 

Entering Sensor Types  

1. In the Header Info dialog, click Edit Attributes and select Sensor Type.  

2. From the list, select a sensor type. 

Setting the Default Stretch  

Use Default Stretch to set the default stretch to use when displaying a band from the file.  

1. In the Header Info dialog, click Edit Attributes and select Default Stretch.  
2. From the Default Stretch menu, select the stretch type. Your choices include: linear, linear range, 

gaussian, equalize, square root, or none. 

3. Some of the stretches require you to enter additional information: For the % Linear stretch, enter 

the percentage of the data to clip (for example. 5%).  
4. For Linear Range stretching, enter the minimum and maximum DN values to use in the stretch.  

5. For Gaussian stretching, enter the number of standard deviations to use in the stretch.  
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Figure 1-7: 2-d scatter plot of Landsat 

TM bands 1(x-axis) and band 4 (y-axis) 

6. Click OK. ENVI saves the stretch setting in the .hdr file. Whenever you display this image, this 

stretch setting overrides the global default stretch given in the envi.cfg file. 
  

Note: If the Default Stretch is set to None, ENVI uses the Default Stretch set in your ENVI preferences. 

Applying a Color Map 

By default, ENVI displays images using a gray scale color table. 

1. To apply a pre-defined color table to the image, from the Main Image window menu select Tools 

→ Color Mapping → ENVI Color Tables to display the ENVI Color Tables dialog. 

2. Select a color table from the list at the bottom of the dialog to change the color mapping for the 
three windows in the display group. 

Note: In the ENVI Color Tables dialog, Options → Auto Apply On is selected by default, so the 

color table will automatically be applied. You can turn this off by selecting Options → Auto 

Apply to uncheck this feature. If the auto apply is off, you must select Options → Apply each 
time you wish to apply the color table and observe the results.  

3. In the ENVI Color Tables dialog, select Options → Reset Color Table to return the display group 

to the default gray scale color mapping. 

4. Select File → Cancel to dismiss the dialog. 

Animating Your Image 

You can animate a multiband image by cycling through the bands of the image sequentially. 

1. From the Main Image window menu, select Tools → Animation and click OK in the Animation 

Input Parameters dialog. Each of the six bands from the TM scene is loaded into an Animation 
window. Once all the bands are loaded, the images are displayed sequentially creating a movie 

effect. 

2. You can control the animation using the player controls (loop backward, loop forward, change 

direction, and pause buttons) at the bottom of the Animation window, or by adjusting the value 
shown in the Speed spin box to change the speed at which the bands are displayed. 

3. Select File → Cancel from the Animation window menu bar to end the animation. 

Using Scatter Plots and Regions of Interest 

Scatter plots allow you to quickly compare the values in two spectral 

bands simultaneously. ENVI scatter plots enable a quick 2-band 

classification.  

1. To display the distribution of pixel values between Band 1 and 
Band 4 of the image as a scatter plot, select Tools→ 2D Scatter Plots 

from the Main Image window. The Scatter Plot Band Choice dialog 

appears. 

2. Under Choose Band X:, select Band 1. Under Choose Band Y:, 

select Band 4. Click OK to create the scatter plot (Figure 1-7). 

3. Place the cursor in the Main Image window, then click and drag 
the left mouse button, moving the cursor around in the window. Be sure 

not to click and drag the mouse cursor inside the zoom box in the 
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window. As you move the cursor, you will notice different pixels are highlighted in the scatter 

plot, making the pixels appear to ―dance.‖ The dancing pixels in the display are the highlighted 2-
band pixel values found in a 10-pixel by 10-pixel region centered on the cursor. 

4. Define a region of interest (ROI) in the Scatter Plot window. To do this, click the left mouse 

button several times in different areas in the Scatter Plot window. Doing this selects points to be 

the vertices of a polygon. Click the right mouse button when you are done selecting vertices. This 
closes the polygon. Pixels in the Main Image and Zoom windows whose values match the values 

contained in the selected region of the scatter plot are highlighted. 

5. To define a second ROI class, do one of the following: 

 Select Class → New from the Scatter Plot menu and repeat the actions described in the step 4.  

By default, the new ROI class is assigned the next unused color sequentially in the Items 1:20 

color list. 

OR 

 Select Class → Items #:# from the Scatter Plot menu. Choose the color for your next class 

and repeat the actions described in the step 4. 

6. Select Options → Export All from the Scatter Plot window menu to export the regions of interest. 

The ROI Tool dialog appears. The ROI Tool dialog can also be started from the Main Image 

window by selecting Overlay → Region of Interest from the menu bar. By default, ENVI assigns 
Scatter Plot Export in the ROI Tool dialog, followed by the color of the region and number of 

points contained in the region as the name for the region of interest. 

7. In the ROI Tool menu bar, select File → Cancel to dismiss the dialog. The region definition is 
saved in memory for the duration of the ENVI session.  

8. In the Scatter Plot window, close the scatter plot by selecting File → Cancel. 

Classifying an Image 

ENVI provides two types of unsupervised classification and several types of supervised classification. 
The following example demonstrates one of the supervised classification methods. 

1. From the ENVI main menu bar, select Classification → Supervised → Parallelepiped. 

2. In the Classification Input File dialog, select Delta_LandsatTM_2008.img and click OK. 

3. When the Parallelepiped Parameters dialog appears, select the regions of interest (ROIs) you just 

created above, by clicking on the region name in the Select Classes from Regions list at the left of 

the dialog. 

4. Select Memory in the upper right corner of the dialog to output the result to memory. 

5. Click on the small arrow button in the right-center of the Parallelepiped Parameters dialog to 

toggle off Rule Image generation, and then click OK. The classification function then calculates 
statistics and a progress window appears during the classification. A new entry titled, 

Parallel(Delta_LandsatTM_2008.img) is added to the Available Bands List. 

6. Select New Display from the Display #1 menu button in the Available Bands List. 

7. In the Available Bands List, select the Gray Scale radio button, click on Parallel 

(Delta_LandsatTM_2008.img), and select Load Band. A new display group is created, 

containing the classified image. 
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Figure 1-8: ROI Tool 

Select Regions Of Interest 

ENVI lets you define regions of interest (ROIs) in your images. ROIs are typically used to extract 
statistics for classification, masking, and other operations.  

1. From the Main Image Display menu, select Overlay → Region of Interest, or right-click in the 

image to display the shortcut menu and select ROI Tool.  

The ROI Tool dialog for that display will appear (Figure 1-
8). 

2. To draw a polygon that represents the region of interest:  

 Click the left mouse button in the Main Image window to 

establish the first point of the ROI polygon. 

 Select further border points in sequence by clicking the 

left button again, and close the polygon by clicking the 

right mouse button. The middle mouse button deletes the 

most recent point, or (if you have closed the polygon) the 

entire polygon. Click the right mouse button a second 
time to fix the polygon. 

 ROIs can also be defined in the Zoom and Scroll 

windows by selecting the appropriate window radio                                                                     

button in the ROI Tool dialog. 

When you have finished defining an ROI, it is shown in the dialog table, with the name, region 

color, number of pixels enclosed, and other ROI properties (Figure 1-8). 

3. To define a new ROI, click the New Region button. 

 You can enter a name for the region and select the color and fill patterns for the region by 

editing the values in the cells of the table. 

Other types of ROIs 

ROIs can also be defined as polylines or as a collection of individual pixels by selecting the 

desired ROI type from the ROI_Type pull-down menu. See the ENVI User‘s Guide or the 

hypertext online help for further discussion of these types of ROIs. 

Working with ROIs 

You can define as many ROIs as you wish in any image.  

Once you have created the ROIs, their definitions are listed in the ROI Tool table. The table allows 

you to perform the following tasks. 

 Select an ROI by clicking in a cell of the far left column (also known as the Current Selection 

column) of the table. An ROI is selected when its entire row is highlighted. An asterisk in this 
column also signifies the currently active ROI. Multiple ROIs can be selected by using a Shift-

click or Ctrl-click. All the ROIs can be selected by clicking the Select All button. 

 Hide ROIs by selecting them in the table and then clicking the Hide ROIs button. Use the 

Show ROIs button to re-display these hidden ROIs. 

 Go to an ROI in the ENVI display by selecting it and then clicking the Goto button. 

 View the statistics for one or more ROIs by selecting them in the table and then clicking the 

Stats button. 
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 Grow an ROI to its neighboring pixels within a specified threshold by selecting it and then 

clicking the Grow button. 

 Pixelate polygon and polyline ROIs by selecting them in the table and then clicking the Pixel 

button. Pixelated objects become a collection of editable points. 

 Delete ROIs by selecting them in the table and then clicking the Delete button.  

The table also allows you to view and edit various ROI properties, such as name, color, and fill 

pattern. The other options under the pull-down menus at the top of the ROI Tool dialog let you 

perform various other tasks, such as calculate ROI means, save your ROI definitions, and load 

saved definitions. 

ROI definitions are retained in memory after the ROI Tool dialog is closed, unless you explicitly 

delete them. ROIs are available to other ENVI functions even if they are not displayed. 

Overlaying and Working with Vectors 

ENVI provides a full suite of vector viewing and analysis tools, including input of ArcMap shapefiles, 

vector editing, and vector querying. 

1. Re-display the grayscale image by clicking on Band 4 in the Available Bands List, clicking on the 

Gray Scale radio button, and then on Load Band. 

2. Open a vector file by selecting File → Open Vector File from the menu bar of the ENVI main 

menu. In the Select Vector Filenames dialog, navigate to the My 

Documents\ERS_186\Lab_Data\Multispectral directory and open 

Delta_classes_vector.evf file. The Available Vectors List dialog appears listing the file 

you selected. 

3. Click on the vector layer name and examine the information about the layer at the bottom of the 
Available Vectors List. 

4. Click on Select All Layers near the bottom of the dialog to select all of the listed vectors to plot. 

Click on the Load Selected button to load all the layers to the image display. 

5. When the Load Vector Layer dialog appears, click on Display #1 to load the vectors into the first 

display. The vector layers are listed in the #1 Vector Parameters dialog. 

6. In the Display #1 Vector Parameters dialog, click Apply to load the vectors onto the image, then 

choose Options → Vector Information in the Vector Parameters dialog to start an information 
dialog about the vectors. 

7. To display the currently selected vector layer and list basic information about the vectors, click 

and drag using the left mouse button in the Main Image window. 

 When other layers are present, you can click on another layer name in the Vector Parameters 

dialog and then click and drag in the Main Image display to track a different layer. 

8. Edit the layer display characteristics by clicking on the Edit → Edit Layer Properties button in 

the Vector Parameters dialog. 

 Change vector layer parameters as desired and click OK. 

Note: You may right click on the color option boxes to select your color preference from a 

drop down menu. 

 In the #1 Vector Parameters dialog, click Apply to display the changes. 
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Save and Output an Image 

ENVI gives you several options for saving and outputting your filtered, annotated, gridded images. You 

can save your work in ENVI‘s image file format, or in several popular graphics formats (including 

Postscript) for printing or importing into other software packages. You can also output directly to a printer.  

Saving your Image in ENVI Image Format 

To save your work in ENVI‘s native format (as an RGB file): 

1. From the Main Image window menu bar, select File → Save Image As → Image File. The 

Output Display to Image File dialog appears. 

2. Select 24-Bit color or 8-Bit grayscale output, graphics options (including annotation and 

gridlines), and borders. If you have left your annotated and gridded color image on the display, 

both the annotation and grid lines will be automatically listed in the graphics options. You can 
also select other annotation files to be applied to the output image. 

3. Select output to Memory or File using the desired radio button. 

 If output to File is selected, enter an output filename. 

Note: If you select other graphics file formats from the Output File Type button which, by 

default is set to ENVI, your choices will be slightly different. 

4. Click OK to save the image.  

Note: This process saves the current display values for the image, not the actual data values. 

 

Keeping track of your data products 
When performing remote sensing analyses, you often create multiple  

data products from a single (or multiple) input. Being able to keep track  

of your work, and link inputs to outputs can help further your understanding  
of the flow of the analysis, as well as inform your interpretation of remote  

sensing results. And, of course, this will help you find your products again for  

later use (as you will be required to do in this course). Therefore, it is important  
to have a file-structure that is well organized, and easy for you to navigate, as  

well as to carefully document your inputs and outputs.  

 

For the remainder of this course, we strongly recomend that you  fill out the excel  
spreadsheets located in MyDocuments\ERS_186\Lab_Data\Documents titled 
 

 Data_products_record_example.xls and  

 Georeg_tracking_info_example.xls  
 

These spreadsheets have been partially filled out as examples of  how you may  
record your input and output files during or after completing each lab/tutorial.  

 

End the ENVI Session
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Tutorial 2.1: Mosaicking Using ENVI 
The following topics are covered in this tutorial: 

Mosaicking in ENVI 

Pixel-Based Mosaicking Example 

Map Based Mosaicking Example 

Color Balancing During Mosaicking 

Overview of This Tutorial 
This tutorial is designed to give you a working knowledge of ENVI's image mosaicking capabilities. For 

additional details, please see the ENVI User‘s Guide or the ENVI Online Help. 

Files Used in this Tutorial 

Input Path: My Documents\ERS_186\Lab_Data\Multispectral\Orthophotos 

Output Path: My Documents\ERS_186\your_folder\lab_2 

Input Files Description 

Delta_orthophoto01.tif 

Delta, CA, Digital Ortho Photos 

Delta_orthophoto02.tif 

Delta_orthophoto03.tif 

Delta_orthophoto04.tif 

Delta_orthophoto05.tif 

Delta_orthophoto06.tif 

Delta_orthophoto07.tif 

Delta_orthophoto08.tif 

Delta_orthophoto09.tif 

Delta_orthophoto10.tif 

Delta_orthophoto11.tif 

Delta_orthophoto12.tif 

Delta_orthophoto13.tif 

Delta_orthophoto14.tif 

Output Files Description 

Delta_ortho_mos Georeferenced virtual mosaic  

Mosaicking in ENVI 
Use mosaicking to overlay two or more images that have overlapping areas (typically georeferenced) or to 
put together a variety of non-overlapping images and/or plots for presentation output (typically pixel-

based). For more information on pixel-based mosaicking, see ENVI Online help. You can mosaic 

individual bands, entire files, and multi-resolution georeferenced images. You can use your mouse or 

pixel- or map-based coordinates to place images in mosaics and you can apply a feathering technique to 
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Figure 2-1: The Mosaic Widget 

blend image boundaries. You can save the mosaicked images as a virtual mosaic to avoid having to save 

an additional copy of the data to a disk file. Mosaic templates can also be saved and restored for other 
input files.               

Virtual Mosaics 
ENVI allows the use of the mosaic template file as a means of constructing a ―Virtual Mosaic‖ (a 
mosaic that can be displayed and used by ENVI without actually creating the mosaic output file). 

Note: Feathering cannot be performed when creating a virtual mosaic in ENVI. 

 

1. To create a virtual mosaic, create the mosaic 

and save the template file using File → Save Template in the 
Image Mosaicking dialog. This creates a small text file 

describing the mosaic layout. 

2. To use the virtual mosaic, select File → Open 

Image File from the ENVI main menu and open the mosaic 
template file. All of the images used in the mosaic are opened 

and their bands are listed in the Available Bands List. Display 

or process any of the bands in the virtual mosaic, and ENVI 
treats the individual images as if they were an actual mosaic 

output file. The new processed file has the specified size of the 

mosaic and the input files are in their specified positions within 
the mosaic. 

Map Based Mosaicking Example 
Putting together a mosaic of georeferenced images can take a 
lot of computing time. This section leads you through creation 

of georeferenced virtual mosaic of some orthophotos which can 

later be used as a base image to georeference your HyMap 

data. 

Create the Map Based Mosaic Image 

1. Open the orthophotos for this lab section in ENVI →File →Open Image File →                                                          

My Documents\ERS_186\Lab_Data\Multispectral\Orthophotos. Note: You can open all of the 

orthophotos (Delta_orthophoto01-14) at once by holding down the shift key and selecting 

all of the files. Click Open. 

2. Start the ENVI Georeferenced Mosaic function by selecting Map → Mosaicking → 

Georeferenced from the ENVI main menu. The Map Based Mosaic dialog appears. 

3. Input and Position Images:  To manually input the georeferenced images and set the background, 
import the images individually.  Import -> Import Files and Edit Properties select input files, 

specifying the background value to ignore
1
 (0) and the feathering distance (0). Images will 

automatically be placed in their correct geographic locations. The location and size of the 
georeferenced images will determine the size of the output mosaic (Figure 2-1). 

                                                
1 Use the Cursor Location/Value indicator in an image display to determine what the background value is. 
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Create the Output Virtual Mosiac 

1. In the Mosaic widget, select File → Save Template. In the Output Mosaic Template dialog, select 

the appropriate output folder, and enter the output filename Delta_ortho_mos. Make sure the 

―Open Template as Virtual Mosaic?‖ is turned to ―yes‖. Click OK to create the virtual mosaic. 

2. Explore your mosaic and check for errors  

 

Complete Your Data Products Spreadsheet 

You have created one data product, Delta_ortho_mos, from the input files 

Delta_orthophoto01-14. Record this information, including file pathways, in your 

your_name_data_products.xls spreadsheet.  
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Tutorial 2.2.: Image Georeferencing and Registration 
The following topics are covered in this tutorial: 

Georeferenced Images in ENVI  

Georeferenced Data  

Image-to-Image Registration  

Overview of This Tutorial 

This tutorial provides basic information about georeferenced images in ENVI and Image-to-

Image Registration using ENVI. It covers step-by-step procedures for successful registration. It is 

designed to provide a starting point to users trying to conduct image registration. It assumes that 

you are already familiar with general image-registration and resampling concepts. 

Files Used in this Tutorial 

Input Path: My Documents\ERS_186\Lab_Data\Hyperspectral\ 

Output Path: My Documents\ERS_186\your_folder\lab_2 

Input Files Description 

Delta_HyMap_2008.img Delta, CA, HyMap Data for 2008 

Delta_ortho_mos.mos The virtual mosaic you created above 

Output Files Description 

Delta_HyMap_2008_geo.img Georeferenced Hymap File for 2008 

Delta_HyMap_2008_gcp.pts GCP file for Hymap File for 2008 

Georeferenced Images in ENVI 

ENVI provides full support for georeferenced images in numerous predefined map projections 

including UTM and State Plane. In addition, ENVI‘s user-configurable map projections allow construction 

of custom map projections utilizing 6 basic projection types, over 35 different ellipsoids and more than 

100 datums to suit most map requirements. ENVI map projection parameters are stored in an ASCII text 
file map_proj.txt that can be modified by ENVI map projection utilities or edited directly by the user. The 

information in this file is used in the ENVI Header files associated with each image and allows simple 

association of a Magic Pixel location with known map projection coordinates. Selected ENVI functions 
can then use this information to work with the image in georeferenced data space.  

ENVI‘s image registration and geometric correction utilities allow you to reference pixel-

based images to geographic coordinates and/or correct them to match base image geometry. 

Ground control points (GCPs) are selected using the full resolution (Main Image) and Zoom 

windows for both image-to-image and image-to-map registration. Coordinates are displayed for 

both base and uncorrected image GCPs, along with error terms for specific warping algorithms. 

Next GCP point prediction allows simplified selection of GCPs. Warping is performed using 

resampling, scaling and translation (RST), polynomial functions (of order 1 through n), or 

Delaunay triangulation. Resampling methods supported include nearest-neighbor, bilinear 

interpolation, and cubic convolution. Comparison of the base and warped images using ENVI‘s 

multiple Dynamic Overlay capabilities allows quick assessment of registration accuracy. The 
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Figure 2-2: The Cursor Location Dialog Displaying 

Pixel and Georeferenced Coordinates 

following sections provide examples of some of the map-based capabilities built into ENVI. 

Consult the ENVI User‘s Guide for additional information. 

Georeferenced Data  

Open and Display HyMap and Reference Data 

1. Open the orthophoto virtual mosaic file that will be used as the base or reference image, 

Delta_ortho_mos and load it into display 1. 

2. Open the Hymap file: Delta_HyMap_2008.img from                                                    

My Documents\ERS_186\Lab_Data\Hyperspectral\ and load a true color image into display 2.  

 

 

 

Edit Map Info in ENVI Header 

1. In the Available Bands List, right click on the Map Info icon under the 

Delta_Hymap_2008.img filename and select Edit Map Information from the shortcut menu. 

The Edit Map Information dialog appears. This dialog lists the basic map information used by 
ENVI in georeferencing. The image coordinates correspond to the Magic Pixel used by ENVI as 

the starting point for the map coordinate system. Because ENVI knows the map projection, pixel 

size, and map projection parameters based on this header information and the map projection text 

file, it is able to calculate the geographic coordinates of any pixel in the image. Coordinates can be 
entered in either map coordinates or geographic (latitude/longitude) coordinates. 

2. Click on the arrow next to the Projection/Datum field to display the latitude/longitude 

coordinates for the UTM Zone 10 North map projection. ENVI makes this conversion on-the-fly. 

3. Click on the active DMS or DDEG button to toggle between Degrees- Minutes- Seconds, and 

Decimal Degrees, respectively. 

4. Click Cancel to exit the Edit Map Information dialog. 

Cursor Location/Value 

To open a dialog box that displays the location of the cursor 

in the Main Image, Scroll, or Zoom windows, do the 

following. 

1. From the Main Image window menu bar, 
select Tools → Cursor Location/Value. 

You can also open this dialog from both the 

Main Image window menu bar, by selecting 
Window → Cursor Location/Value, or by right clicking the image itself and choosing Cursor 

Location/Value from the drop down menu. Note that the coordinates are given in both pixels and 

georeferenced coordinates for this georeferenced image. 

2. Move the cursor around the image and examine the coordinates for specific locations and note the 

relation between map coordinates and latitude/longitude (Figure 2-2). 

3. Select File → Cancel to dismiss the dialog when finished. 

Reminder: To load this image in true color:  In the available bands list → click on the 

RGB Color radial button, then select bands 3, 2 and 1 consecuatively (so R is band 3, G 

is band 2, and B is band 1). 
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Figure 2-3: The Ground Control 
Points Selection Dialog for Image 
to Image Registration 

 

Image to Image Registration 

This section of the tutorial takes you step-by-step through an Image to Image registration. The 

georeferenced virtual mosaic of the orthophotos, Delta_ortho_mos, will be used as the Base image, 

and the coarsely georeferenced Hymap Delta images will be warped to match the orthophoto mosaic. 

Registration of multiple images can take several days. Often you will need to re-use gcps to register later 
image products. Therefore, in order to keep your work organized, create a spreadsheet that records your 

work. 

Create Registration Spreadsheet 

1. In My Documents\ERS_186\Lab_Data\Documents\ there is a file titled 

Georeg_tracking_info_example.xls. Open it and save it in My 

Documents\ERS_186\your_folder. Name it your_name_georegistration.xls and begin 

modifying it as you work. 

Open and Display the Base and Warp Image Files 

1. Open the base image, Delta_ortho_mos as a RGB into display 1. 

2. If not already loaded, open the warp image, Delta_Hymap_2008.img as a True Color image 

in display 2 (by right clicking it in the Availible Bands List). 

Start Image Registration and Load GCPs 

1. From the ENVI main menu bar, select Map → Registration→ Select GCPs: Image to Image. 

2. The Image to Image Registration dialog appears. For the Base Image, click on the Display containing 

the orthophoto virtual mosaic to select it. For the Warp Image select the Display containing the Hymap 
image. 

3. Click OK to start the registration. This opens the Ground Control Points Selection dialog (Figure 2-3). 

Individual ground control points (GCPs) are added by positioning the cursor position in the two zoom 
images to the same ground location. 

4. Navigate to a point in the base image and the warp image that show the exact same location (e.g. the 

end of a bridge) –Hint: You can right click on any of your images to use a Geographic Link for 

navigating to roughly the same location in your images, then unlink before fine-scale navigation. You 

must UNLINK before you begin your fine scale navigation! 

5. Examine the locations in the two Zoom windows and adjust the locations if necessary by clicking the 

left mouse button in each Zoom window at the desired locations. Note that sub-pixel positioning is 
supported in the Zoom windows. The larger the zoom factor, the finer the positioning capabilities. 

 

6. In the Ground Control Points Selection dialog, click Add Point 

to add the GCP to the list. Click Show List to view the GCP list 
(Figure 2-4). Try this for a few points to get the feel of selecting 

GCPs. Note the list of actual and predicted points in the dialog. 

Once you have at least 5 points, the RMS error is reported.  

7. Choose 20 pairs of points in your warp image subset (Hymap 

image) and the base image (orthophoto virtual mosaic) in the 

same manner that you chose the first pair. In order to achieve 

a good registration, it is extremely important to place your 
GCPs evenly throughout the image. 
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8. After you are done selecting the 20 pairs, click on individual GCPs in the Image to Image GCP List 

dialog and examine the locations of the points in the two images, the actual and predicted coordinates, 
and the RMS error. Resize the dialog to observe the total RMS Error listed in the Ground Control 

Points Selection dialog.  In the GCP list you can order points by error (Options→Order Points by 

Error) to see which GCPs are contributing the most to your RMSE. 

 

 

 

 

 
 

 

 

 

 

  

Figure 2-4: Image to Image GCP List Dialog 

Working with GCPs 

 The position of individual GCPs can be edited by selecting the appropriate GCP in the Image to 

Image GCP List dialog and editing in the Ground Control Points Selection dialog. Either enter a 
new pixel location, or move the position pixel-by-pixel using the direction arrows in the dialog. 

 Clicking on the On/Off button in the Image to Image GCP List dialog removes selected GCPs 

from consideration in the Warp model and RMS calculations. These GCPs aren‘t actually deleted, 

just disregarded, and can be toggled back on using the On/Off button. 

 In the Image to Image GCP List dialog, clicking on the Delete button removes a GCP from the list. 

 Positioning the cursor location in the two Zoom windows and clicking the Update button in the 

Image to Image GCP List dialog updates the selected GCP to the current cursor locations. 

 The Predict button in the Image to Image GCP List dialog allows prediction of new GCPs based 

on the current warp model. 

1. Try positioning the cursor at a new location in the base image (orthophoto). Click on the Predict 
button and the cursor position in the warp image (Hymap image) will be moved to match its 

predicted location based on the warp model. 

2. The exact position can then be interactively refined by moving the pixel location slightly in the 

warp image window. 

3. In the Ground Control Points Selection dialog, click Add Point to add the new GCP to the list. 

4. In the Image to Image GCP list dialog, select Options → Order points by error. Click on the 

pairs with maximum RMS error and try to refine their positions reducing the overall RMS error. 

5. Once 20 pairs are selected, save your GCP points by selecting, File → Save GCPs to 

ASCII. Choose your output folder and give the name Delta_Hymap_2008_gcp.pts 

to the points file. Record the name of this file, where it is saved, how many points there 

are, and what the RMSE is in your georeg_tracking_info.xls spreadsheet. 
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Warp Images 

Images can be warped from the displayed band, or all bands of multiband images can be warped at 
once. We will warp only 3 bands to reduce computing demand. 

1. In the Ground Control Points Selection dialog, select Options → Warp File (as image to 

map…). Select warp image as Delta_Hymap_2008. Select a spectral subset with bands, 14, 8 

and 2. 

2. The Registration Parameters dialog appears (Figure 2-5). Use the Warp Method pulldown menu to 

select RST, and the Resampling button menu to select Nearest Neighbor resampling. 

3. Change the X and Y pixel size to 3 m.  Press enter after changing each pixel size to make sure 
that the output X and Y sizes are adjusted. 

4. Choose your output folder, enter the filename Delta_Hymap_2008_geo and click OK. The 

warped image will be listed in the Available Bands List when the warp is completed. 

 

Figure 2-5: The Registration Parameters Dialog 

Load the warped file to a new image window.  Connect the orthophoto, original image, and warped image 
using the geographic link (Right-click in the Main Image Window and select Geographic Link).  Toggle 

on the cursor crosshairs in each zoom window and click around the images.  With the geographic link, 

pixels with the same geographic coordinates should be centered in each zoom window.  Do the different 
images all line up?  Has your georegistration improved the correspondence of the Hymap image to the 

orthophoto? 

Complete Your Data Products Spreadsheet 

You have created two data products, Delta_Hymap_2008_gcp.pts and 

Delta_HyMap_2008_geo, from the input files Delta_orthophoto01-14, and 

Delta_HyMap_2008. Record this information, including file pathways, in your 

your_name_data_products.xls spreadsheet.  
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Tutorial 3.1: Vector Overlay & GIS Analysis 
The following topics are covered in this tutorial: 

Stand alone vector GIS analysis, including input of shapefiles and associated DBF attribute files 

Display in vector windows 

Viewing and editing attribute data 

Point and click spatial query 

Overview of This Tutorial 

This tutorial introduces ENVI‘s vector overlay and GIS analysis capabilities using vector 

data.  

Part 1 of this tutorial demonstrates the following:  

Stand-alone vector GIS analysis, including input of shapefiles and associated DBF attribute files  

Display in vector windows  
Viewing and editing attribute data  

Point-and-click spatial query  

Math and logical query operations  

Part 2 of this tutorial demonstrates the following:  

ENVI‘s combined image display/vector overlay and analysis capabilities  

 Cursor tracking with attribute information  

 Point-and-click spatial query  

 Heads-up digitizing and vector layer editing  

Generation of new vector layers using math and logical query operations  
Raster-to-vector conversion of ENVI regions of interest (ROIs) and classification images  

ENVI‘s vector-to-raster conversion, using vector query results to generate ROIs for 

extraction of image statistics and area calculation. 

 

Files Used in This Tutorial 

Path: MyDocuments\ERS_186\Lab_Data\vector, 

MyDocuments\ERS_186\Lab_Data\Multispectral 

File Description 

Bay_Delta_Preserves.shp 
Delta, CA, Vector data-polygons of Natural preserve 

boundaries 

2008_field_points.shp 
Delta, CA, Vector data-points of field data collected 

June 2006 

Delta_LandsatTM_2008.img Delta, CA, TM Data 

Delta_LandsatTM_2008.hdr ENVI Header for Above 
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Vector Overlay and GIS Concepts  

Capabilities  

ENVI provides extensive vector overlay and GIS analysis capabilities. These include the 

following:  

Import support for industry-standard GIS file formats, including shapefiles and associated DBF 

attribute files, ArcInfo interchange files (.e00, uncompressed), MapInfo vector files (.mif) and 

attributes from associated .mid files, Microstation DGN vector files, DXF, and USGS DLG and 
SDTS formats. ENVI uses an internal ENVI Vector Format (EVF) to maximize performance.  

 

Vector and image/vector display groups provide a stand-alone vector plot window for displaying 
vector data and composing vector maps. More importantly, ENVI provides vector overlays in 

display groups (Image windows, Scroll windows, and Zoom windows).  

 

You can generate world boundary vector layers, including low- and high-resolution political 
boundaries, coastlines, and rivers, and USA state boundaries. You can display all of these in 

vector windows or overlay them in image display groups.  

 
You can perform heads-up (on-screen) digitizing in a vector or raster display group. Heads-up 

digitizing provides an easy means of creating new vector layers by adding polygons, lines, or 

points.  

 
Image- and vector window-based vector editing allows you to modify individual polygons, 

polylines, and points in vector layers using standard editing tools, taking full advantage of the 

image backdrop provided by raster images in ENVI.  
 

ROIs, specific image contour values, classification images, and other raster processing results can 

be converted to vector format for use in GIS analysis.  
 

Latitude/longitude and map coordinate information can be displayed and exported for image-to-

map registration. Attribute information can be displayed in real-time as each vector is selected.  

 
ENVI supports linked vectors and attribute tables with point-and-click query for both vector and 

raster displays. Click on a vector in the display group, and the corresponding vector and its 

associated information is highlighted in the attribute table. Click on an attribute in the table, and 
the display scrolls to and highlights the corresponding vector.  

 

Scroll and pan through rows and columns of vector attribute data. Edit existing information or 
replace attributes with constant values, or with data imported from ASCII files. Add or delete 

attribute columns. Sort column information in either forward or reverse order. Export attribute 

records as ASCII text.  

 
Query vector database attributes directly to extract information that meets specific search criteria. 

You can perform GIS analysis using simple mathematical functions and logical operators to 

produce new information and layers. Results can either be output to memory or to a file for later 
access.  

 

You can set vector layer display characteristics and modify line types, fill types, colors, and 

symbols. Use attributes to control labels and symbol sizes. Add custom vector symbols.  
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Figure 3-1: The Available Vectors List 

 

You can reproject vector data from any map projection to another.  
  

 You can convert vector data to raster ROIs for extraction of statistics, calculation of areas, and 

use in ENVI‘s many raster analysis functions.  

 
Generate maps using ENVI annotation in either vector or image windows. Set border widths and 

background colors, and configure graphics colors. Automatically generate vector layer map keys. 

Insert objects such as rectangles, ellipses, lines, arrows, symbols, text, and image insets. Select 
and modify existing annotation objects. Save and restore annotation templates for specific map 

compositions.  

 
Create shapefiles and associated DBF attribute files and indices, or DXF files, from the internal 

ENVI Vector Format (EVF). New vector layers generated using ENVI‘s robust image processing 

capabilities, and changes made to vector layers in ENVI are exported to industry-standard GIS 

formats.  

Concepts  

ENVI‘s vector overlay and GIS analysis functions generally follow the same paradigms as 

ENVI‘s raster processing routines, including the same procedures for opening files and the use of 
standard dialogs for output to memory or file. The following sections describe some of the basic 

concepts. 

ENVI Vector Files (.evf)  

External vector files imported into ENVI are 

automatically converted into EVF, with the default file 
extension .evf. The EVF format speeds processing and 

optimizes data storage. When you select output to 

memory (instead of to a file), ENVI retains the 
external vector format without creating an EVF file. 

The Available Vectors List  

Much like the Available Bands List used to list and 

load image bands, the Available Vectors List provides 

access to all vector files open in ENVI. It appears 
when needed, or you can invoke it by selecting 

Window → Available Vectors List from the ENVI 

main menu bar (Figure 3-1). Vectors are loaded to 

either vector or image display groups when you select 
them from the Available Vectors List and click Load 

Selected. If you have an image display group open, 

you can load the vectors to that display group, or to a 
new vector window. In addition to listing and loading 

vector layers, the Available Vectors List provides 

utilities to open vector files, to start new vector windows, to create world boundaries and new 
vector layers, and to export analysis results to ROIs (through raster-to-vector conversion), 

shapefiles, and ancillary files. 
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Create World Boundaries  

ENVI uses IDL map sets to generate low- and high-resolution world boundaries in EVF. Select 

Options → Create World Boundaries from the Available Vectors List, or Vector → Create 

World Boundaries from the ENVI main menu bar. You can also generate political boundaries, 
coastlines, rivers, and USA state boundaries.  

 

High-resolution format is available only if the IDL high-resolution maps are installed. If these are 
not currently installed on your system, you can install them using the ENVI Installation CD, 

modifying your installation to include the high-resolution maps.  

The Vector Parameters Dialog and Vector Window Menu  

When vectors are overlaid on an image, the Vector Parameters dialog appears to let you control 

the way vectors are displayed and the functions that are available for vector processing and 
analysis.  
 

When vectors are loaded into a vector window (not in an image display group), the vector  

window has the same menu functions available in the Vector Parameters dialog.  

The Vector Parameters dialog and the vector window menu bar allow you to open vector files, 

import vector layers from the Available Vectors List, arrange vector layer precedence, set plot 
parameters, and annotate plots. They also control the mode of operation in the vector window or 

image display group, toggling between cursor query and heads-up digitizing and editing. The 

Vector Parameters dialog or the vector window menu initiate ENVI‘s GIS analysis functions, 
including real-time vector information, attribute viewing and editing, and vector query operations. 

Finally, the Vector Parameters dialog and the vector window menu bar provide utilities for 

exporting analysis results to shapefiles and ancillary attribute files, or to ROIs (through vector-to-

raster conversion). You can also save the current configuration of vector overlays to a template, 
so you can later restore them.  
 

 
Figure 3-2: The Vector Parameters Window and New Vector Window 

ENVI Attributes  

ENVI provides access to fully attributed GIS data in a shapefile DBF format. Attributes are listed 

in an editable table, allowing point-and-click selection and editing.  
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Double-clicking in a particular cell selects that cell for editing. The table also supports full 

column substitution using a uniform value and replacement with values from an ASCII file. 
Options include adding and deleting individual columns and sorting data forward and backward 

based on information within a column. You can save attributes to an ASCII file or to a DBF file.  

Point-and-click spatial query is supported in ENVI attribute tables to help you locate key features 

in images or in a vector window. Select specific records by clicking the label at the left edge of 
the table for a specific row in the table. The corresponding vector is highlighted in a contrasting 

color in the image display group or vector window. You can select multiple records, including 

non-adjacent records, by holding down the <Ctrl> key as you click the additional row labels. 
 

 
Figure 3-3: ENVI Vector Attribute Table 

Part 1: Stand-Alone Vector GIS  
This part of the tutorial demonstrates how to use ENVI as a simple stand-alone vector processing 
and analysis system for GIS data.  

Open a Shapefile  

1. From the ENVI main menu bar, select File → Open Vector File. A Select Vector Filenames 

dialog appears.  
2. Navigate to Lab_Data\vector. Click the Files of type drop-down list in the Select Vector 

Filenames dialog, and select Shapefile (at the bottom right hand corner).  

3. Select Bay_Delta_Preserves.shp. Click Open. The Import Vector Files Parameters 

dialog appears. This dialog allows you to select file or memory output, enter an output 

filename for the ENVI .evf file, and enter projection information if ENVI is unable to find the 

projection information automatically.  
4. Click the Output Results to file button. Accept the default values by clicking OK. A status 

window indicates the number of vector vertices being read, and the Available Vectors List 

appears when the data have been converted.  
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5. Select Bay_Delta_Preserves in the Available Vectors List and click Load Selected. 

The Vector Window #1 dialog appears with regional Bay Delta preserves plotted. The default 
mode (shown in the title bar or in the lower-right corner of the dialog) is Cursor Query.  

Work with Vector Polygon Data  

1. Click and drag the cursor around in Vector Window #1. Latitudes and longitudes are 
displayed in the lower-left corner of the dialog.  

2. Zoom into the file by positioning the cursor at the bottom corner of one of the polygons 

delineating the boundaries of a preserve and clicking and dragging the middle mouse button 

to define a box covering the desired region. Release the middle mouse button.  
3. Multiple levels of zoom are possible. Click the middle mouse button while holding the 

<Shift> key to zoom into the display centered on the cursor. Right click in the Vector 

Window #1 dialog and select Previous Range to step backward through the previous zoom 
levels. Right-click and select Reset Range, or click the middle mouse button in the Vector 

Window #1 dialog to reset the zoom level and to set the vector display back to the original 

range.  
4. Change the symbol used to mark the cities. From the Vector Window #1 menu bar, select 

Edit → Edit Layer Properties. An Edit Vector Layers dialog appears. Click the Line 

attributes drop-down list and select Dotted. Click OK. You can add your own symbols by 

defining them in the file usersym.txt in the menu directory of your ENVI installation. E 
5. Experiment with changing the color, fill, and size. Click Preview to view your changes as you 

go. 

Retrieve Vector Information and Attributes  

1. Right-click in the Vector Window #1 dialog and select Select Active Layer → Layer: 

Bay_Delta_Preserves.shp. From the Vector Window #1 dialog menu bar, select Options → 

Vector Information to open the Vector Information dialog.  

2. Click and drag over the Vector Window #1 dialog to see the basic attribute information at the 
bottom of the Vector Information dialog.  

View Attributes and Use Point-and-Click Query 

1. While Bay_Delta_Preserve.shp is still the active layer and Cursor Query is the 

active mode, select Edit → View/Edit/Query Attributes from the Vector Window #1 dialog 

menu bar. A Layer Attributes table appears. This is a fully editable table of the attributes for 

the selected layer.  
2. Click in the Site column (on the record number) to do a spatial query on a selected preserve. 

The corresponding preserve polygon is highlighted in the Vector Window #1 dialog. If 

desired, zoom to the selected city by clicking and dragging a box around it with the middle 

mouse button. Zoom back out by clicking the middle mouse button in the Vector Window #1 
dialog.  

3. Verify that you have selected the correct preserve by clicking the highlighted polygon in the 

Vector Window #1 dialog and observing the attributes in the Vector Information window.  

Query Attributes  

1. Ensure that Bay_Delta_Preserves.shp is still the active layer. From the Vector 

Window #1 dialog menu bar, select Options → Select Active Layer → Layer: 

Bay_Delta_Preserves.  

2. From the Vector Window #1 dialog menu bar, select Edit → Query Attributes. A Layer 

Attribute Query dialog appears.  
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3. Click Start. A Query Expression section appears at the top of the Layer Attribute Query 

dialog.  
4. Click the SITE drop-down list and select Site.  

5. Click the > drop-down list and select = =.  

6. In the String field, enter ―Jasper Ridge Biological Preserve‖ (be sure to match this case).  

7. Click the Memory radio button and click OK. ENVI creates a new vector layer and associated 
DBF file based on the results of the query. The new layer appears in the Available Vectors 

List and is loaded into Vector Window #1. Zoom to the selected vectors using the middle 

mouse button to draw a box around Jasper Ridge Biological Preserve. 

Part 2: Raster and Vector Processing  
This section of the tutorial demonstrates how to use vector overlays and GIS data and attributes in 

combination with raster images from the Landsat TM scene of the Bay Delta.  

Load Image Data to Combined Image/Vector Display  

Open an image file to use as a backdrop for vector layers.  

1. From the ENVI main menu bar, select File → Open Image File. A file selection dialog 

appears.  
2. Navigate to MyDocuments\ERS_186\ Lab_Data\Multispectral and select 

Delta_LandsatTM_2008.img. Click Open.  

The Available Bands List appears with four spectral bands listed. Right click the file and load a 

true-color image into a new display group.  

 

1. From the Display group menu bar, select Overlay → Vectors. A Vector Parameters dialog 
appears.  

2. From the Vector Parameters dialog menu bar, select File → Open Vector File. This menu 

option is also accessible from the ENVI main menu bar. A Select Vector Filenames dialog 
appears. 

3. Click the Files of type: drop-down list and select Shapefile (at the bottom right corner). 

Navigate to Lab_Data/vector and select both Bay_Delta_Preserves.shp and 

2008_field_points.shp by holding down the shift key and selecting the files.  Click 

Open. An Import Vector Files Parameters dialog appears.  

4. Select File or Memory output, and enter an output filename for the ENVI .evf file if you 
selected File. 

5. In the Native Projection list, select UTM (or ensure that it is already selected). Click Datum.  

6. A Select Geographic Datum dialog appears.  Select North America 1983 and click OK. Do 
the same for the next vector file. 

7. Select Memory output and click OK. A status window reports the number of vector vertices 

being read. When the data have been converted, they are automatically loaded into the Vector 

Parameters dialog and displayed in white on the image. The vectors.shp layer should be 
highlighted in the Vector Parameters dialog.  

8. Right click the Current Layer colored box to select a more visible color for the vector layer or 

right-click on the box and select from the menu. Click Apply to update the vector color.  

Track Attributes with the Cursor  

1. In the Vector Parameters dialog, select Options → Vector Information. A Vector 
Information dialog appears.  

2. Click and drag inside the image to view the attribute information for the vectors. Also 

observe the latitude and longitude listed in the Vector Parameters dialog. Select the Scroll 
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or Zoom radio button in the Vector Parameters dialog to allow vector tracking in the 

corresponding window. Select the “Off” radio button to allow normal scrolling in the 
Scroll and Main windows and zooming in the Zoom window. Try different zoom factors 

in the Zoom window to assess the accuracy of the vectors.  You can only view attribute 

information for the vector file highlighted in the Vector Parameters dialog. 

3. Ensure that you are in Cursor Query mode by selecting Mode from the Vector Parameter 
dialog menu bar.  

4. From the Vector Parameters dialog menu bar, select Edit → View/Edit/Query 

Attributes. A Layer Attributes table appears. Select random records by clicking the 
numbered columns to highlight specific polygons on the image. You may want to change 

the Current Highlight color in the Vector Parameters dialog to something that is more 

visible in your display group.  

Heads-up (On-screen) Digitizing  

ENVI provides vector editing routines for adding your own vectors to an existing vector layer or 
for creating new vector layers. These vector editing routines are similar in function to ENVI‘s 

annotation polygons, polylines, and points. ENVI heads-up vector digitizing allows you to create 

new polygons, polylines, points, rectangles, and ellipses.  
1. Create a new vector layer by selecting File → Create New Layer from the Vector 

Parameters dialog. A New Vector Layer Parameters dialog appears.  

2. Enter a Layer Name. Click the Memory radio button, and click OK.  

3. In the Vector Parameters dialog, click the new layer name to initialize a new DBF file.  
4. From the Vector Parameters dialog menu bar, select Mode → Add New Vectors.  

5. For this exercise, you will create a polygon vector. From the Vector Parameters dialog 

menu bar, select Mode → Polygon.  
6. Since the Image radio button is selected by default in the Vector Parameters dialog, you 

will define the new polygon in the Image window. You can specify which display group 

window you want to edit your vectors in, by selecting the appropriate radio button in the 

Vector Parameters dialog.  
You may want to change the new vector layer color from white to something more visible 

before drawing new polygons.  

7. Draw a few polygons using field outlines on the image as guides. In the Image window, 
use the mouse to define the new polygon area as follows:  

 Click the left mouse button to draw polygon segments.  

 Click the middle mouse button to erase polygon segments.  

 Click the right mouse button to fix the polygon. Right-click again and select Accept 

New Polygon to accept the polygon.  

8. To move the Image box in the Scroll window to a new location, you must click the Off 
radio button in the Vector Parameters dialog. When you are finished moving around the 

image, click the Image radio button to resume adding new vectors.  

9. To add attributes to the new polygons, select Edit → Add Attributes from the Vector 

Parameters dialog menu bar. An Add Attributes Choice dialog appears.  
10. Select Define new attributes interactively. Click OK. An Attribute Initialization dialog 

appears. In the Name field, type Field_ID. Click the Type drop-down list and select 

Character. Click Add Field.  
11. For the second attribute, type Field_Area in the Name field.  Click the Type drop-down 

list and select Numeric. Click OK to create the attribute table. A Layer Attributes table 

appears.  
12. Double-click in a field, enter the value, and press the <Enter> key. To see which rows 

are associated with which fields, select Mode → Cursor Query from the Vector 
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Parameters dialog, and click the row labels in the Layer Attributes table. The 

corresponding polygon is highlighted in the Image window.  
13. From the Layer Attributes dialog menu bar, select File → Cancel. When you are 

prompted to save the attribute table, click No.  

Edit Vector Layers  

1. In the Vector Parameters dialog, select the new vector layer and select Mode → Edit 

Existing Vectors.  
2. In the Image window, click one of the polygons you created in the last section. The 

polygon is highlighted and its nodes are marked with diamonds. When the vector is 

selected, you can make the following changes:  

a. Delete the entire polygon by right-clicking it and selecting Delete Selected 
Vector.  

b. To move a node, click and drag it to a new location.  

c. After making changes to a polygon, right-click it and select Accept Changes  
d. Exit the editing function without making any changes by clicking the middle 

mouse button, or right-click and select Clear Selection.  

e. To add or remove nodes from a polygon, right-click to display the shortcut 
menu and select from the following options:  

 To add a node, right-click and select Add Node, then drag the node 

to a new location.  

 To remove a node, right-click it and select Delete Node from the 

shortcut menu.  

 To change the number of nodes added at one time, right-click and 

select Number of Nodes to Add. Enter the number of nodes in the 
dialog that appears.  

 To remove a range of nodes, right-click on the first node and select 

Mark Node. Right-click on the last node and select Mark Node 

again. Right-click again and select Delete Marked Nodes.  
 

To finish this section, select Window → Available Vectors List from the ENVI main menu bar 

to display the Available Vectors List. Delete any new layers you have created by selecting them 
in the Available Vectors List and clicking Remove Selected. Do not remove the 

Bay_Delta_Preserves.shp or 2008_field_points.shp layer.  

Query Operations  

1. From the Vector Parameters dialog menu bar, select Mode → Cursor Query.  

2. In the Vector Parameters dialog, highlight 2008_field_points.shp. Select 

Edit → View/Edit/Query Attributes. A Layer Attributes table appears.  

3. Examine the land_cover column and note the different land cover classes, including 

several types of vegetation, soil, water, and non-photosynthetic vegetation (npv). 
Close the attribute table by selecting File → Cancel.  

4. From the Vector Parameters dialog menu bar, select Edit → Query Attributes. A 

Layer Attribute Query dialog appears.  
5. In the Query Layer Name field check that field_points is entered in the field. Click 

Start.  

6. In the Query Expression section that appears at the top of the Vector Parameters 

dialog, click the drop-down list and select land_cover.  
7. Click the ID drop down list and select land_cover. Then click the > drop-down list 

and select = =.  
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8. In the String field, type ―water‖. (Be sure to match the case in the attribute table).  

9. Select the Memory radio button and click OK. The selected layer (called a subset) 
generated by the query appears in the Vector Parameters dialog.  

10. In the Vector Parameters dialog, select the new subset[Layer: 2008_field_points.shp] 

layer and select Edit → Edit Layer Properties from the menu bar to change layer 

parameters. An Edit Vector Layers dialog appears.  
11. Click the Point Symbol drop-down list and select Flag. Click OK. The water field 

points as flags are highlighted as a new layer.  

12. To examine the attributes for this layer, select subset[Layer: Delta_field_points.shp]in 
the Vector Parameters dialog, and select Edit → View/Edit/Query Attributes from 

the menu bar. A Layer Attributes table appears. Examine the query results.  

13. Close the Layer Attributes table and repeat the query for the "levee_herbaceous" land 
cover, highlighting it in a different color or symbol.  

14. Try other queries on combinations of attributes by choosing one of the logical 

operators in the Layer Attribute Query dialog.  

Convert Vectors to ROIs  

1. ENVI provides several important links between vector analysis and raster image 
processing. This portion of the exercise describes how to create ROIs from vector 

processing results and extract ROI statistics.  

2. From the Display group menu bar, select Overlay → Region of Interest. The ROI 

Tool dialog appears.  
3. In the Vector Parameters dialog, highlight the Bay_Delta_Preserves.shp layer and 

select File → Export Active Layer to ROIs. An Export EVF Layers to ROI dialog 

appears.  
4. Select Convert all records of an EVF layer to one ROI, and click OK.  

5. Repeat Steps 2-3 for each layer you created earlier from the query operations. The 

layers appear in the ROI Tool dialog.  

6. In the ROI Tool dialog, select the Bay_Delta_Preserves ROI by clicking in the 

far left column of its row. Click Stats. An ROI Statistics Results dialog appears with 

image statistics for the Preserves and multispectral data.  
7. Save ROI in File → Save ROI. 

8. Now that you have converted these vector polygons to ROIs, you can use ENVI‘s 

raster processing capabilities to analyze the image data, with respect to the ROIs. This 

includes masking, statistics, contrast stretching, and supervised classification.  

Export ROI to Vector Layer  

ENVI can convert raster processing results (such as ROIs) for use in ENVI vector processing and 

analysis and for export to external GIS software such as ArcGIS. The following exercises 
illustrate the export of raster information to vector GIS.  

Open and Display an Image  

Re-Open the Landsat TM 2008 image of the Bay Delta to use as background for ROI definition 

and export to vector:  

1. From the ENVI main menu bar, select File → Open Image File. A file selection 
dialog appears.  

2. In the Available Bands List, select Band 4, select the Gray Scale radio button, and 

click Load Band.  
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Load Predefined ROIs  

1. From the Display group menu bar, select Overlay → Region of Interest. An ROI 

Tool dialog appears.  

2. Your ROIs from the above exercise should reload.  If not, from the ROI Tool dialog 
menu bar, select File → Restore ROIs.  

3. Navigate to your saved ROI file. Click Open. An ENVI Message dialog reports what 

regions have been restored. Click OK. The predefined ROI is loaded into the ROI 
Tool dialog and plotted on the image.  

Convert ROIs to Vectors  

1. To convert these ROIs to vector polygons, select File → Export ROIs to EVF from 

the ROI Tool dialog menu bar. An Export Region to EVF dialog appears.  

2. Select a region from the Select ROIs to Export field.  
3. Select All points as one record.  

4. Enter an Output Layer Name, click Memory, and click OK to convert the first ROI.  

5. In the Available Vectors List, click to select your new layer, followed by Load 

Selected. A Load Vector dialog appears.  
6. Select New Vector Window and click OK. The vectors are loaded as polygons into the 

Vector Window #1 dialog.  

7. From the Vector Window #1 dialog menu bar, select Edit → View/Edit/Query 

Attributes.  

8. Practice editing and/or adding to your attributes as you desire (the paragraph at the 

beginning of page 34 may be a useful reference). 
9. Repeat Steps 1-8 for the second ROI. The layers appear in the Available Vectors List.  

 

You can now use these polygons with query operations and GIS analysis with other vector data, 

or you can export them to shapefiles by selecting File → Export Active Layer to Shapefile from 
the Vector Window Parameters dialog.  

Close All Windows and Files  

 1. In the Available Vectors List, click Select All Layers, followed by Remove Selected.  
 2. From the Available Vectors List menu bar, select File → Cancel.  

 3. From the Vector Window #1 dialog menu bar, select File → Cancel.  

 4. From the ENVI main menu bar, select File → Close All Files. 
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Tutorial 4.1: The n-D Visualizer  
The following topics are covered in this tutorial: 

Exploration of feature space and land cover classes 

Multispectral data 

Overview of This Tutorial 
Remote sensing data is comprised of data layers (bands) that complete the data set. Each of these 

layers can be considered a feature or a dimension of the data. It is helpful to sometimes think of 
spectra in your image as points in an n-D scatter plot, where n is the number of bands. The 

coordinates of the points in n-D space consist of n spectral reflectance values in each band for a 

given pixel. The n-D visualizer can help you visualize the shape of a data cloud that results from 
plotting image data in feature space (sometimes called spectral space), with the image bands as 

plot axes. The n-D visualizer is commonly used to examine the distribution of points in n-D space 

in order to select spectral endmembers in your image (pixels that are pure, containing a unique 
type of material). It can also be used to examine the separability of your classes when you use 

ROIs as input into supervised classifications. When using the n-D visualize, you can actively 

rotate data in n-D space. 

Files Used in this Tutorial 

Input Path:   My Documents\ERS_186\Lab_Data\Multispectral\Landsat\ 

Output Path:  My Documents\ERS_186\your_folder\lab4 

Input Files Description 

Delta_LandsatTM_2008.img 

Delta_classes_2008.roi 

Delta, CA TM Data 

ENVI regions of interest file 

  

Launching & using the n-D Visualizer 

 
1. Start ENVI and open the image file Delta_LandsatTM_2008.img. Load the image 

file to a true-color RGB display. 

2. Overlay the Delta_classes_2008.roi regions of interest file on the image.  

3. In the ROI Tool dialog, select File → Export ROIs to n-D visualizer Select 
Delta_LandsatTM_2008.img.  

4. In the n-D Visualizer Input ROIs, Select All Items and click OK. The n-D visualizer and n-D 
controls dialogs appear (Figure 4-1). 

 Clicking on an individual band number in the n-D Controls dialog turns the band 

number white and displays the corresponding band pixel data in the n-D scatter plot. 

You must select at least two bands to view a scatter plot. 

 Clicking the same band number again turns it black and turns off the band pixel data 

in the n-D scatter plot. 

 Selecting two bands in the n-D Controls dialog produces a 2-D scatter plot; selecting 

three bands produces a 3-D scatter plot, and so on. You can select any combination of 

bands at once. 
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Selecting Dimensions and Rotating Data 

Rotate data points by stepping between random projection views. You can control the speed and 
stop the rotation at any time. You can move forward and backward step-by step through the 

projection views, which allows you to step back to a desired projection view after passing it. 

1. In the n-D Controls dialog, click the band numbers (thus the number of dimensions) you want 

to project in the n-D Visualizer. If you select only two dimensions, rotation is not possible. If 
you select 3-D, you have the option of driving the axes, or initiating automatic rotation. If you 

select more than 3-D, only automatic random rotation is available.  

2. Select from the following options: 

2. To drive the axes, select Options → 3D: Drive Axes from the n-D Controls 

menu bar. Click and drag in the n-D Visualizer to manually spin the axes of the 

3D scatter plot. 

3. To display the axes themselves, select Options → Show Axes from the n-D 
Controls menu bar.  

4. To start or stop rotation, click Start or Stop in the n-D Controls dialog. 

5. To control the rotation speed, enter a Speed value in the n-D Controls dialog. 
Higher values cause faster rotation with fewer steps between views.  

6. To move step-by-step through the projection views, click < to go backward and > 

to go forward.  

7. To display a new random projection view, click New in the n-D Controls dialog. 

Interacting with Classes 

Use the n-D Class Controls dialog to interact with individual classes. The dialog lists the number 
of points in each defined class and the class color. You can change the symbol, turn individual 

classes on and off, and select classes to collapse. You can also plot the minimum, maximum, 

mean, and standard deviation spectra for a class, plot the mean for a single class, and plot all the 

spectra within a class. Also, you can clear a class and export a class to an ROI.  

Figure 4-1: n-D Visualizer (left) and n-D Controls dialog (right)  
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From the n-D Controls menu bar, select Options → Class Controls.  

All of the defined classes appear in the dialog. The white class contains all of the unclustered or 

unassigned points. The number of points in each class is shown in the fields next to the colored 

squares.  

Turning Classes On/Off  

To turn a class off in the n-D Visualizer, de-select the On check box for that class in the n-D 

Class Controls dialog. Click again to turn it back on.  

To turn all but one of the classes off in the n-D Visualizer, double-click the colored box at the 

bottom of the n-D Class Controls dialog representing the class that you want to remain displayed. 

Double-click again to turn the other classes back on.  

Selecting the Active Class  

To designate a class as the active class, click once on the colored square (at the bottom of the n-D 

Class Controls dialog) corresponding to that class.  

The color appears next to the Active Class label in the n-D Class Controls dialog, and any 

functions you execute from the n-D Class Controls dialog affect only that class.  

You may designate a class as the active class even though it is not enabled in the n-D Visualizer.  

Producing Spectral Plots  

To produce spectral plots for the active class:  

1. Click the Stats, Mean, or Plot button on the n-D Class Controls dialog. The Input File 

Associated with n-D Data dialog appears. 

o Stats: Display the mean, minimum, maximum, and standard deviation spectra of 

the current class in one plot. These should be derived from the original 

reflectance or radiance data file. 

o Mean: Display the mean spectrum of the current class alone. This should be 

derived from the original reflectance or radiance data file. 

o Plot: Display the spectrum of each pixel in the class together in one plot. This 
should be derived from the original reflectance or radiance data file. 

2. Select the input file that you want to calculate the spectra from. 

If you select a file with different spatial dimensions than the file you used as input into 

the n-D visualizer, enter the x and y offset values for the n-D subset when prompted. 

Note: If you select Plot for a class that contains hundreds of points, the spectra for all the points 

will be plotted and the plot may be unreadable. 
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Clearing Classes  

To remove all points from a class, click Clear on the n-D Class Controls Options dialog, or right-

click in the n-D Visualizer and select Clear Class or Clear All.  

Designating Classes to Collapse  

To include the statistics from a class when calculating the projection used to collapse the data, 

select the Clp check box next to that class name in the n-D Class Controls dialog.  

If the data are in a collapsed state, they will be recollapsed using the selected classes when you 

select any of the Clp check boxes. 

Collapsing Classes  

You can collapse the classes by means or by variance to make class definition easier when the 
dimensionality of a dataset is higher than four or five. With more than four or five dimensions, 

interactively identifying and defining many classes becomes difficult. Both methods iteratively 

collapse the data cloud based on the defined classes.  

To collapse the data, calculate a projection (based either on class means or covariance) to 

minimize or hide the space spanned by the pre-defined classes and to maximize or enhance the 

remaining variation in the dataset. The data are subjected to this special projection and replace the 

original data in the n-D Visualizer.  

Additionally, an eigenvalue plot displays the residual spectral dimension of the collapsed data. 
The collapsed classes should form a tight cluster so you can more readily examine the remaining 

pixels. The dimensionality of the data, shown by the eigenvalue plot, should decrease with each 

collapse.  

1. From the n-D Controls menu bar, select Options → Collapse Classes by Means or 
Collapse Classes by Variance (see the descriptions in the following sections). 

An eigenvalue plot displays, showing the remaining dimensionality of the data and 
suggesting the number of remaining classes to define. The n-D Selected Bands widget 

changes color to red to indicate that collapsed data are displayed in the n-D Visualizer. 

2. Use the low-numbered bands to rotate and to select additional classes. 

3. From the n-D Controls menu bar, select Options → Collapse Classes by Means or 

Collapse Classes by Variance again to collapse all of the defined classes. 

4. Repeat these steps until you select all of the desired classes. 

Collapsing Classes by Means  

You must define at least two classes before using this collapsing method. The space spanned by 

the spectral mean of each class is derived through a modified Gram-Schmidt process. The 
complementary, or null, space is also calculated. The dataset is projected onto the null space, and 

the means of all classes are forced to have the same location in the scatter plot. For example, if 
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you have identified two classes in the data cloud and you collapse the classes by their mean 

values, ENVI arranges the data cloud so that the two means of the identified classes appear on top 
of each other in one place. As the scatter plot rotates, ENVI only uses the orientations where 

these two corners appear to be on top of each other.  

Collapsing Classes by Variance  

With this method, ENVI calculates the band-by-band covariance matrix of the classified pixels 

(lumped together regardless of class), along with eigenvectors and eigenvalues. A standard 

principal components transformation is performed, packing the remaining unexplained variance 
into the low-numbered bands of the collapsed data. At each iterative collapsing, this process is 

repeated using all of the defined classes. The eigenvalue plot shows the dimensionality of the 

transformed data, suggesting the number of remaining classes to define.  

The full dataset is projected onto the eigenvectors of the classified pixels. Each of these projected 
bands is divided by the square root of the associated eigenvalue. This transforms the classified 

data into a space where they have no covariance and one standard deviation.  

You should have at least nb * nb/2 pixels (where nb is the number of bands in the dataset) 

classified so that ENVI can calculate the nb*nb covariance matrix.  

ENVI calculates a whitening transform from the covariance matrix of the classified pixels, and it 

applies the transform to all of the pixels. Whitening collapses the colored pixels into a fuzzy ball 
in the center of the scatter plot, thereby hiding any corners they may form. If any of the 

unclassified pixels contain mixtures of the endmembers included among the classified pixels, 

those unclassified pixels also collapse to the center of the data cloud. Any unclassified pixels that 
do not contain mixtures of endmembers defined so far will stick out of the data cloud much better 

after class collapsing, making them easier to distinguish.  

Collapsing by variance is often used for partial unmixing work. For example, if you are trying to 

distinguish very similar (but distinct) endmembers, you can put all of the other pixels of the data 

cloud into one class and collapse this class by variance. The subtle distinctions between the 

unclassified pixels are greatly enhanced in the resulting scatter plot.  

UnCollapsing Classes  

To uncollapse the data and return to the original dataset, select Options → UnCollapse from the 

n-D Controls menu bar.  

All defined classes are shown in the n-D Visualizer, and the band numbers return to a white color 

in the n-D Controls menu bar.  

n-D Visualizer/Controls Options  

Select Options from the n-D Controls menu bar to access the n-D Class Controls dialog, to 

annotate the n-D Visualizer, to start a Z Profile window, to import, delete, and edit library 
spectra, to collapse classes, to clear classes, to export classes to ROIs, to calculate mean spectra, 

and to turn the axes graphics on or off.  
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Opening the Class Controls Dialog  

To access the n-D Class Controls dialog, select Options → Class Controls from the n-D 

Controls menu bar. For details, see Interacting with Classes.  

Adding Annotation  

To add an annotation to the n-D Visualizer window, select Options → Annotate Plot from the n-

D Controls menu bar. See Annotating Images and Plots for further details. You cannot add 

borders to the n-D Visualizer.  

Plotting Z Profiles  

To open a plot window containing the spectrum of a point selected in the n-D Visualizer:  

1. Select Options → Z Profile from the n-D Controls menu bar. The Input File Associated 

with n-D Data dialog appears. 

2. Select the data file associated with the n-D data. Typically, this file is the reflectance or 

original data. If you select an input file with different spatial dimensions than the file 

used for input into the n-D Visualizer, you will be prompted to enter the x and y offsets 
that point to the n-D subset. 

The Z Profile plot window appears. 

3. Select from the following options: 

o To plot the Z Profile for the point nearest the cursor, middle-click in the n-D 
Visualizer plot window. 

o To add plots to the Z Profile plot window, right-click in the n-D Visualizer plot 
window. The Z Profile corresponding to the point you selected is added to the Z 

Profile plot window. 

When the Z Profile plot window is open, the selected file is automatically used to 

calculate the mean spectra when you select Options → Mean Class or Mean All from 

the n-D Controls menu bar. 

Managing n-D Visualizer States  

Select File from the n-D Controls menu bar to save and restore the state of the n-D Visualizer, 

including the highlighted groups of pixels.  

Exporting the n-D Visualizer  

Select File → Save Plot As → PostScript or Image from the n-D Controls menu bar.  

To print the n-D Visualizer window, select File → Print (see Printing in ENVI for details).  
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Saving States  

To save the n-D Visualizer state, select File → Save State from the n-D Controls menu bar and 

enter an output filename with the extension .ndv for consistency.  

Restoring Saved States  

To restore a previously saved state, select File → Restore State and select the appropriate file.  

You can also restore a previously saved state by selecting Spectral → n-Dimensional 

Visualizer → Visualize with Previously Saved Data from the ENVI main menu bar.  
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Tutorial 4.2: Data Reduction 1 - Indexes 
 
The following topics are covered in this tutorial: 

Band-Math for Calculating Narrow-band Indexes 

Continuum Removal 

Overview of This Tutorial 
A disadvantage of the statistical data reduction tools (that you will practice in Lab 5) is that they 

are not readily interpretable.  An MNF composite image might highlight that two materials are 

spectrally different, but do not easily allow you to determine the spectral or physical basis for that 
difference.  This effectively ignores the amazing capability of hyperspectral data to provide 

physiological measurements by detecting specific narrow-band absorptions.  Since specific 

materials absorb at specific wavelengths, the relative depth of an absorption feature can quantify 

how much of that material is present.  Spectral physiological indexes and continuum removal are 
two methods for quantifying absorption features.  These products can then be used for further 

analyses in the place of the original reflectance data, thereby reducing data dimensionality.  This 

tutorial is designed to give you a working knowledge of ENVI's data reduction capabilities. For 
additional details, please see the ENVI User‘s Guide or the ENVI Online Help. 

Files Used in this Tutorial 

Input Path:  My Documents\ERS_186\Lab_Data\Hyperspectral\ 

Output Path:  My Documents\ERS_186\your_folder\lab4 

Input Files Description 

Delta_Hymap_2008 Delta, CA, HyMap Data 

Output Files Description 

Delta_Hymap_2008_cr_carb 
Continuum Removal of soil 
carbonate 

Delta_Hymap_2008_cr_water 
Continuum Removal of vegetation 

water 

Delta_Hymap_2008_XXXX.img 
Image file of the index XXXX (12 

total) 

Delta_Hymap_2008_index_mask.img Mask file 

Delta_Hymap_2008_indexstack.img Band stacked file 

 

Data Reduction 
Because of the enormous volume of data contained in a hyperspectral data set, data reduction 
techniques are an important aspect of hyperspectral data analysis.  Reducing the volume of 

data, while maintaining the information content, is the goal of the data reduction techniques 

covered in this section. The images created by the data reduction techniques can be used as 

inputs to classification. 
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Figure 4-1:  Grey-scale image of PRI  

Narrow Band Indexes 

Band Math  

Here you will calculate vegetation indexes, covariance 

statistics, and correlation matrices with ENVI‘s Band Math 
function.  

The first vegetation index we will calculate, shown to the 

left, the Photochemical Reflectance Index (PRI), is a 
measure of photosynthetic efficiency.   The formula for PRI  

 

               is 
 

where R531 and R570 are the reflectance values at 531nm and 
570nm, respectively.  Since Hymap does not sample at 

exactly these wavelengths, we will calculate PRI using the 

bands closest to 531 and 570nm. 

 

Calculate PRI following these steps: 

1. In ENVI‘s main menu, select File  Open Image File  Delta_Hymap_2008.img 

from My Documents\ERS_186\Lab_Data\Hyperspectral\and load a true color display. 

2. Select Basic Tools  Band Math.   

3. In the Band Math Expression dialog, enter float(b1-b2)/float(b1+b2). 
In case you wonder about the ―float‖ term, this is because the raw image is saved as an 

integer data type.  Unless told otherwise, the computer will set the type of the output band 

math image to integer as well.  This results in the truncation of decimal places.  An index that 
ranges between -1 and 1, which many of them are normalized to do, will therefore be saved 

as 0.  When entering your band math expressions, you must convert the input bands to 

decimals (or floating point values, in computer speak) by calling the ―float()‖ function.  

4. Click OK. 

5. In the Variables to Bands Pairing dialog, click on B1 (undefined).  

6. Select Band 6 (526nm) for B1. 

7. Click on B2 (undefined). 

8. Select Band 9 (570.4 nm).   

9. Choose your output file path as: My Documents\ERS_186\Lab_Data\Lab_Products. 

10. Name the output file Delta_Hymap_2008_PRI.img and click Open 

11. Click OK 

12. Display your newly calculated index and inspect it with the Cursor Location/Value Tool.   

13. Repeat steps 3 - 12 using the 11 remaining vegetation indexes listed in Table 4-1.   For 
example, band math expressions you will need include: 

 NDWI, Normalized Difference Water Index:  float(b1-b2)/float(b1+b2).  Here you can also 

click on the previous Band Math expression and assign different band pairings. 
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 SR, Simple Ratio, float(b1)/float(b2). 

 CAI, Cellulose Absorption Index:  0.5*float((b1+b2) – b3) 

 NDNI, Normalized Difference Nitrogen Index:  

(alog10(float(b1)/float(b2)))/(alog10(1/(float(b1)*float(b2)))) 

 To take the sum of a set of bands, a shortcut is to go to Basic Tools  Statistics  Sum 

Data Bands, and choose the bands you wish to sum as a spectral subset. 

 
This is just a sample of the many physiological indexes that have been developed to estimate 

a wide variety of properties including, pigment contents and ratios between pigments, foliar 

water content, and foliar dry matter content. 

 

 

Table 4-1: Physiological indexes used in vegetation mapping 

Index formula details citation 

Pigment indexes    

SR, Simple Ratio 
R

NIR

R

R

 

Index of green vegetation cover.  

Various wavelengths used, depending on 

sensor.(eg: NIR=845nm, R=665nm) 

Tucker (1979) 

NDVI, Normalized 

Difference Vegetation 

Index RNIR

RNIR

RR

RR

 

Index of green vegetation cover.  

Various wavelengths used, depending on 

sensor.(eg: NIR=845nm, R=665nm) 

Tucker (1979) 

mNDVI, modified NDVI 
705750

705750

RR

RR

 

leaf chlorophyll content 
Fuentes et al. 

(2001) 

Summed green 

reflectance 

599

500

iR

 

Index of green vegetation cover. 
Fuentes et al. 

(2001) 

PRI, Photochemical 

Reflectance Index 
570531

570531

RR

RR

 

Xanthophyll response to light ~ 

photosynthetic efficiency. 

Also sensitive to carotenoid/chlorophyll 
ratio 

Rahman et al. 

(2001) 

Red/Green ratio 

599

500

699

600

ii RR

 

anthocyanins/chlorophyll 
Fuentes et al. 

(2001) 
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Table 4-1:  Physiological indexes used in vegetation mapping (continued) 

 

 

Checking for Independence of Calculated Indexes 

Calculating a correlation matrix is a fairly simple method for verifying the additional 

information content of each index.  Not all indexes are independent of each other.  For 

example, many are designed to estimate chlorophyll content; so these will necessarily be 
correlated.  Additionally, many variables are correlated with overall plant vigor.  For 

example, more robust vegetation will tend to have higher chlorophyll, water, and nitrogen 

contents and thus have higher NDVI, NDWI, and NDNI values than stressed vegetation, and 
these indexes will thus be correlated.  When calculating the correlation matrix, mask out zero, 

NaN, and infinite values to ensure that useful values are generated. 

Combine Bands into a Single Image 

Combine all bands into a single image to calculate covariance statistics and a correlation 

matrix.  

1. In ENVI‘s main menu, select File   Save File As   ENVI Standard. 

2. Click Import and, holding down the Ctrl button, select all 12 of the 

Delta_Hymap_2008_XXXX.img index files that you calculated.  Click OK. 

Note:  Write down the order of the bands as you import them, you will need to enter 

this information in Step 9. 

PI2, Pigment Index 2 
760

695

R

R

 

plant stress status 
Zarco-Tejada 

(1998) 

Water indexes    

NDWI, Normalized 
Difference Water Index 1240860

1240860

RR

RR

 

leaf water content Gao (1996) 

WBI, Water Band Index 
970

900

R

R

 

leaf water content 
Peñuelas et al. 

(1997) 

Foliar chemistry indexes    

NDNI, Normalized 

Difference Nitrogen 
Index 15101680

1510

1680

1log

log

RR

R
R

 

foliar nitrogen concentration 
Serrano et al. 

(2002) 

NDLI, Normalized 

Difference Lignin Index 
17541680

1754

1680

1log

log

RR

R
R

 

foliar lignin concentration 
Serrano et al. 

(2002) 

CAI, Cellulose 
Absorption Index 

0.5 * 

(R2020+R2220)

-R2100 

based upon cellulose & lignin absorption 

features, used to discriminate plant litter 

from soils 

Nagler et al. 
(2000) 
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3. Choose a file path to My Documents\ERS_186\Lab_Data\Lab_Products. 

4. Name the file Delta_Hymap_2008_indexstack.img and click Open. 

5. Click OK. 

6. In ENVI‘s main menu, select File   Edit ENVI Header.   

7. Select Delta_Hymap_2008_indexstack.img.   

8. Click Edit Attributes and select Band Names.  Change the band names to the appropriate 
index names you just wrote down. 

9. Click the Display button and select New Display.  Click Load RGB and select three 

indexes from the New Stacked Layer into a new display. 

Masking 

 Masking reduces the spatial extent of the analysis by masking out areas of the image 

which do not contain data of interest.  Masking reduces processing times by reducing the 

number of pixels an analysis must consider.  Masking may also improve results by 

removing extraneous, confounding variation from the analysis.  It is common for analysts 
to mask out hydrologic features (streams, rivers, lakes), roads, or nonvegetated pixels, for 

example, depending on the project goals. 

 During the masking process, the user compares the mask carefully to the original image 

to verify that only non-essential data is removed.  If there is any doubt whether data is 
important, it is left in the data set. 

Build the Mask 

1. Select Basic Tools   Masking  Build Mask.  

2. Select the display corresponding to your index stack image.   

3. In the Mask Definition dialog, select Options  

Selected Areas Off.  

4. Select Options  Mask NaN values.  These are 
the pixels with nonreal index values that resulted from 

having a zero in the denominator. 

5. Select the file 

Delta_Hymap_2008_indexstack.img and click 

OK. 

6. Choose the option ―Mask pixel if ANY band 
matches NaN‖. 

7. Name the file 

Delta_Hymap_2008_index_mask.img, click 

Apply. 

8. Close the Mask Definition dialog. 

 

Figure 4-2:  NaN Mask  
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Calculate Statistics and Covariance Image 

1. In ENVI‘s main window, select Basic Tools   Statistics   Compute Statistics. 

2. Select Delta_Hymap_2008_indexstack.img as the input file, click ―Select Mask 

Band‖, choose Delta_Hymap_2008_index_mask.img, and click OK. 

3. Check Covariance in the Compute Statistics Parameters dialog and click OK. 

4. Maximize the Statistics Results and scroll (if necessary) to the correlation matrix.  A high 

absolute value (close to 1 or negative 1) indicates that the two indexes are highly 

correlated.  What clusters of highly correlated indexes fall out?  Which indexes are not 
correlated to any others?  If your correlation matrix contains many nonsensical values, 

you did not successfully mask the image.  See the troubleshooting guide on page 6. 

You may use physiological indexes (instead of reflectance data) as the input to any classification 
algorithm.  Choose indexes to include as classification inputs using the following rules of thumb: 

 Inspect each of your index images.  Indexes that are very noisy (i.e., those with a lot of 

speckle and low spatial coherence) should be excluded from further analyses. 

 Use only one index from a set of highly correlated indexes (i.e., |r| > 0.9).   

Continuum Removal 
Many hyperspectral mapping and classification methods require that data be reduced to 

reflectance and that a continuum be removed from the reflectance data prior to analysis. A 

continuum is a mathematical function used to isolate a particular absorption feature for analysis 
(Clark and Roush, 1984; Kruse et al, 1985; Green and Craig, 1985). It corresponds to a 

background signal unrelated to specific absorption features of interest. Spectra are normalized to 

a common reference using a continuum formed by defining high points of the spectrum (local 

maxima) and fitting straight line segments between these points. The continuum is removed by 
dividing the original spectrum by the continuum.  In this way, the spectrum is normalized for 

albedo in order to quantify the absorption feature. 

 

 

Figure 4-3: Fitted Continuum and a Continuum-Removed Spectrum for the Mineral 
Kaolinite 
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Create Continuum-Removed Data 

Continuum Removal in ENVI Plot Windows 

1. Open the file Delta_Hymap_2008.img and display it as a color infrared by right 

clicking it in the Availible Bands List and selecting Load CIR…. 

2. Right-click in the Image window and select Z Profile (Spectrum…) 

3. Make sure that Options → Auto-scale Y Axis is checked in the Spectral Profile 

window. 

4. Select Edit → Plot parameters…  

5. Edit Range to display wavelengths from 2.0 µm to 2.41 µm and close the Plot 
Parameter dialog. 

6. Select Plot Function → Continuum Removed. The spectrum will be displayed after 

continuum removal. 

Navigate to soil pixels in your image and observe the spectra. Note the absorption at 2.2 

µm for clay, 2.3 µm for carbonates and if the pixel has dry vegetation, the spectra will 

also show a cellulose absorption at 2.1 µm.  Click back and forth between Normal and 
Continuum Removed in the Plot_Function menu so that you can see how the shape of the 

reflectance spectrum corresponds to the shape of the continuum removed spectrum.  Can 

you see the absorption features in both? 

To Map the Continuum Removal for all pixels 

1. Open the file Delta_Hymap_2008.img and select Spectral → Mapping 

Methods → Continuum Removal. 

2. In the Continuum Removal Input File dialog, select the file Delta_Hymap_2008, 

perform spectral subsetting by clicking Spectral Subset and choosing bands from 2.0 
µm to 2.41 µm to limit the spectral range for continuum removal, and click OK. 

3. Choose the Lab_Products output folder, enter the continuum-removed output file 

name, Delta_Hymap_2008_cr_carb.img in the Continuum Removal 

Parameters dialog and click OK to create the continuum-removed image. 

This image will have the same number of spectral bands as the number of bands 

chosen in the spectral subset. 

4. Load the central band of this file (band 110) as a gray scale and link it to your CIR 

display. Observe the Z profile from both displays for soil and dry vegetation pixels.  

(You will probably need to check Options → Autoscale Y axis for your continuum 

removed profile.) 

Repeat the above steps choosing as your spectral subset, bands from 0.87 µm to 1.08 µm. 

This range contains the liquid water absorption bands for vegetation. Output the file as 

Delta_Hymap_2008_cr_water.img. Once the process is complete, the file will 

show up in the Available Bands List dialog. Load the central band as a gray scale. 

Navigate to vegetation pixels, display the Z profile and observe the spectra. 

Look at full spectra of soil, litter, and green vegetation pixels in your Hymap image.  
Inspect the regions used for the continuum removals.  Can you see the cellulose and 

water absorptions?  Can you tell soil and litter pixels apart?  Look at band pairs that were 
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used in the physiological indexes you calculated earlier.  Can you see what spectral 

features they‘re taking advantage of? 

Complete Your Data Products Spreadsheet 

You have created several data products from the input file Delta_HyMap_2008.img. 

Record this information, including file pathways, in your your_name_data_products.xls 

spreadsheet.   

 Note:  You may wish to organize your Lab_Products folder using subfolders to appropriately 
group your files together (i.e. index files vs continuum removal images), or transfer your files 

to your appropriate personal lab folder(s). 
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Tutorial 5: Data Reduction 2 - Principal Components 
 
The following topics are covered in this tutorial: 

Masking 

Principal Components Analysis 

Minimum Noise Fraction Transform 

Overview of This Tutorial 

The large number of spectral bands and high dimensionality of hyperspectral data overwhelm 

classical multispectral processing techniques.  Moreover, contiguous bands tend to be highly 
correlated.  Since not all bands provide new information, they may be unnecessary for subsequent 

analyses.  Researchers have devised many strategies to reduce the dimensionality and remove the 

redundant information in hyperspectral data, including statistical transforms, feature selection, 

and the calculation of narrowband indexes.  This tutorial goes through the process of creating and 
interpreting PCA and MNF transforms on Hyperspectral Images.  Both of these transforms are 

statistical tools that use the variance-covariance structure of a hyperspectral dataset.   

Files Used in This Tutorial 

Input Path: C:\My Documents\ERS_186\Lab_Data\Hyperspectral\ 

Output Path: C:\My Documents\ERS_186\your_folder\lab5 

Input Files Description 

Delta_HyMap_2008.img Delta, CA, HyMap Data 

Output Files Description 

Delta_Hymap_2008_pca.img Principal Components Analysis file 

Delta_Hymap_2008_mnf.img 
Minimum Noise Transform file 

 

Principal Component Analysis  

Principal Components produces uncorrelated output bands, segregates noise components, and 

can be used to reduce the dimensionality of data sets. Because hyperspectral data bands are 
often highly correlated, the Principal Component (PC) Transformation is used to produce 

uncorrelated output bands. This is done by finding a new set of orthogonal axes that have 

their origin at the data mean and that are rotated so the data variance explained by each axis is 

maximized.  As a result, the first PC band contains the largest percentage of data variance and 
the second PC band contains the second largest data variance, and so on.  The last PC bands 

appear noisy because they contain very little variance, much of which is due to noise in the 

original spectral data. 
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Figure 5-1:  Schematic representation of 
the first two eigenvectors (U1 and U2) 
from a PCA decomposition of a 
hypothetical data set  
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Since PCA is a simple rotation and translation of the coordinate axes, PC bands are linear 

combinations of the original spectral bands. You can calculate the same number of output PC 
bands as input spectral bands. To reduce dimensionality using PCA, simply exclude those last 

PC bands that contain very little variance and appear noisy. Unlike the original bands, PC 

bands are uncorrelated to each other. 

Principal Component bands produce more 
colorful color composite images than 

spectral color composite images because 

the data is uncorrelated. ENVI can 
complete forward and inverse PC 

rotations.  

Richards, J.A., 1999. Remote Sensing 
Digital Image Analysis: An Introduction, 

Springer-Verlag, Berlin, Germany, p. 

240.  

Start ENVI and Load Hymap Data 

Start ENVI by double-clicking on the 
ENVI icon. The ENVI main menu 

appears when the program has 

successfully loaded and executed. Open 

the file, Delta_Hymap_2008.img 

and load it into a display as a CIR. 

 

 

 

Calculating Forward PC Rotations  

The forward PC rotation uses a linear transform to maximize the variance of the data 

contained by each successive axis. When you use forward PC rotation, ENVI allows you to 

calculate new statistics or to rotate from existing statistics. The output of either can be saved 
as byte, floating point, integer, long integer, or double precision values. You also have the 

option to subset the output of the PC rotation based on eigenvalues, and to generate output of 

only the PC bands that you need.  

Computing New Statistics and Rotating  

1. We will use Compute New Statistics and Rotate to calculate the eigenvalue and 
covariance or correlation statistics for your data and to calculate the forward PC rotation 

transform.  

2. Select Transforms  Principal Components  Forward PC Rotation  Compute 

New Statistics and Rotate.  

3. When the Principal Components Input File dialog appears, select and subset your input 
file using standard ENVI file selection procedures (choose a spectral subset of the first 93 

bands) and click OK.  You can perform a PCA on any subset of bands or all bands within 

an image.  We are limiting our analysis here to the first 93 bands to reduce processing 
times.  The Forward PC Rotation Parameters dialog appears. 
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Note: You can click Stats Subset to calculate the variance-covariance statistics based on a 

spatial subset such as an area under an ROI. However, the default is for the statistics to be 

calculated from the entire image. 

4. Enter resize factors less than 1 in the Stats X/Y Resize Factor text boxes to sub-sample 
the data when calculating the statistics. For example, using a resize factor of 0.1 will use 

every 10th pixel in the statistics calculations.  This will increase the speed of the statistics 

calculations.  

5. Output your statistics file to your Lab_Products folder using the filename: 

Delta_Hymap_2008_pcastats.sta. 

6. Select to calculate the PCs based on the Covariance Matrix using the arrow toggle button. 

Note: Typically, use the covariance matrix when calculating the principal components. 

Use the correlation matrix when the data range differs greatly between bands and 

normalization is needed. 

7. Save your PCA file to the Lab_Products folder, using the file name 

Delta_Hymap_2008_pca.img. 

8. From the Output Data Type menu, select the desired data type of the output file (we‘ll 

stick with Floating Point). 

9. Select the number of output PC bands as 30. You can limit the number of output PC 
bands, by entering the desired number of output bands in the text box or by using the 

arrow increment button next to the Number of Output PC Bands label. The default 

number of output bands is equal to the number of input bands.  Reducing the number of 
output bands will increase processing speed and also reduce disk space requirements.  It 

is unlikely that PC bands past 30 will contain much variance. 

10. Alternatively, you can choose to select the number of output PC bands using the 

eigenvalues to ensure that you don‘t omit useful information. To do this, perform the 
following steps. 

 Click the arrow toggle button next to the Select Subset from Eigenvalues label to 

select Yes. Once the statistics are calculated the Select Output PC Bands dialog 

appears with each band listed with its corresponding eigenvalue. Also listed is the 
cumulative percentage of data variance contained in each PC band for all PC bands.  

 Select the number of bands to output by entering the desired number into the 

Number of Output PC Bands box or by clicking on the arrow buttons. PC Bands 

with large eigenvalues contain the largest amounts of data variance. Bands with 

lower eigenvalues contain less data information and more noise. Sometimes, it is best 
to output only those bands with large eigenvalues to save disk space.  

 Click OK in the Select Output PC Bands dialog. The output PC rotation will contain 

only the number of bands that you selected. For example, if you chose "30" as the 

number of output bands, only the first 30 PC bands will appear in your output file. 

11. In the Forward PC Rotation Parameters dialog, click OK. 

12. The PCA will take a few minutes.  When ENVI has finished processing, the PC 

Eigenvalues plot window appears and the PC bands are loaded into the Available Bands 
List where you may access them for display. For information on editing and other options 

in the eigenvalue plot window, see Using Interactive Plot Functions in ENVI Help. 
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Figure 5-2: PC Eigenvalues Plot Window 

13. Load an RGB image of the top 3 PCA bands.  Inspect the z-profile of the PCA image.  
Link the PCA image to your CIR reflectance image.  Are any features more readily 

apparent in the PCA-transformed data?  Are different land cover classes more distinctly 

colored than in the CIR? 

14. Load band 30 as a gray scale.  How does it differ from the reflectance image and the top 

3 PCA bands? 

15. Inspect the variance structure of the image.  Open the statistics file: Basic Tools  

Statistics  View Statistics File.  In the Enter Statistics Filename dialog, find your file 

Delta_Hymap_2008_pcastats.sta and click OK.  Output the statistics to a text 

file by selecting File  Save results to text file in the Stats File window.  Use the 

filename Delta_Hymap_2008_pcastats.txt.   

 

You can now open this text file in Microsoft Excel.  Specify that the file type is delimited 

and that Excel should start import at line 4.  Click Next and then Finish.  Excel should 
open a spreadsheet with the PC bands as the rows.  For each PC band it includes the 

minimum, maximum, and mean values, the standard deviation, and the eigenvalue.  If 

you scroll down further, you will see the variance-covariance matrix and the 

eigenvectors. 
 

Calculate the sum of all the eigenvalues.  This is the total amount of variance in your 

image.  Now, next to your eigenvalue column make a new column entitled ―% variation‖.  
Calculate this as 100 * the eigenvalue of each band divided by the sum of all the 

eigenvalues you just calculated.  How well distributed is the variation in your PCA 

bands? 

 
You may close your PCA files. 

Minimum Noise Fraction Transformation 

The minimum noise fraction (MNF) transformation is used to determine the inherent 
dimensionality of image data, to segregate noise in the data, and to reduce the computational 
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requirements for subsequent processing (See Boardman and Kruse, 1994). The MNF 

transform, as modified from Green et al. (1988) and implemented in ENVI, is essentially two 
cascaded Principal Components transformations. The first transformation, based on an 

estimated noise covariance matrix, decorrelates and rescales the noise in the data. This first 

step results in transformed data in which the noise has variance equal to one and no band-to-

band correlations. The second step is a standard Principal Components transformation of the 
noise-whitened data. For the purposes of further spectral processing, the inherent 

dimensionality of the data is determined by examination of the final eigenvalues and the 

associated images. The data space can be divided into two parts: one part associated with 
large eigenvalues and coherent eigenimages, and a complementary part with near-unity 

eigenvalues and noise-dominated images. By using only the coherent portions, the noise is 

separated from the data, thus improving spectral processing results. 

Figure 5-3 summarizes the MNF procedure in ENVI. The noise estimate can come from one 

of three sources; from the dark current image acquired with the data (for example AVIRIS), 

from noise statistics calculated from the data themselves, or from statistics saved from a 

previous transform. Both the eigenvalues and the MNF images (eigenimages) are used to 
evaluate the dimensionality of the data. Eigenvalues for bands that contain information will 

be an order of magnitude larger than those that contain only noise. The corresponding images 

will be spatially coherent, while the noise images will not contain any spatial information. 

 

 

Figure 5-3: MNF Procedures in ENVI 

Calculating Forward MNF Transforms  

Perform your MNF transform using the Estimate Noise Statistics From Data option when you 

have no dark current image for your data, which is usually the case. ENVI assumes that each 

pixel contains both signal and noise, and that adjacent pixels contain the same signal but 

different noise. A shift difference is performed on the data by differencing adjacent pixels to 
the right and above each pixel and averaging the results to obtain the "noise" value to assign 

to the pixel being processed. The best noise estimate is gathered using the shift-difference 

statistics from a homogeneous area rather than from the whole image. ENVI allows you to 
select the subset for statistics extraction.  
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1. Select Transforms  MNF Rotation   Forward MNF   Estimate Noise Statistics 

From Data or Spectral   MNF Rotation   Forward MNF  Estimate Noise 

Statistics From Data.  

2. When the MNF Transform Input File dialog appears, select and subset your input file 

using the standard ENVI file selection procedures (choose a spectral subset of the first 93 
bands) and click OK.  

You can perform an MNF on any subset of bands or all bands within an image.  We are 

limiting our analysis here to the first 93 bands to reduce processing times.  The Forward 

MNF Transform Parameters dialog appears. 

Note: Click Shift Diff Subset if you wish to select a spatial subset or an area under an 

ROI on which to calculate the statistics. You can then apply the calculated results to the 

entire file (or to the file subset if you selected one when you selected the input file). For 

instructions, see Using Statistics Subsetting.  The default is for the statistics to be 
calculated from the entire image. 

 Saving your MNF files to the Lab_Products folder: 

3. In the Enter Output Noise Stats Filename [.sta] text box, enter a filename for the noise 

statistics (e.g., Delta_Hymap_2008_mnf_noisestats.sta). 

4. In the Enter Output MNF Stats Filename [.sta] text box, enter an output file for the MNF 

statistics (e.g., Delta_Hymap_2008_mnf_stats.sta). 

Note: Be sure that the MNF and noise statistics files have different names. 

5. Select File output and give it the filename Delta_Hymap_2008_mnf.img.  

6. Select the number of output MNF bands by using one of the following options: 

A.  Enter ―40‖ in the Number of Output MNF Bands box, or 

B. To select the number of output MNF bands by examining the eigenvalues, click the 
arrow toggle button next to the Select Subset from Eigenvalues label to select Yes. 

Click OK to calculate the noise statistics and perform the first rotation. Once the statistics 

are calculated the Select Output MNF Bands dialog appears, with each band listed with 
its corresponding eigenvalue. Also listed is the cumulative percentage of data variance 

contained in each MNF band for all bands.  

Click the arrow buttons next to the Number of Output MNF Bands label to set number of 

output bands to the desired number, or enter the number into the box.  Choose to include 
only bands with large eigenvalues that contain nontrivial proportions of variation.  As 

you can see, by band 30, most of the variation is explained and the addition of each 

successive band only adds additional information in very small increments. 
Click OK in the Select Output MNF Bands dialog to complete the rotation. 

Note: For the best results, and to save disk space, output only those bands with high 

eigenvalues-bands with eigenvalues close to 1 are mostly noise.  
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7. The MNF transform will take a few minutes.  When ENVI has finished processing, it 

loads the MNF bands into the Available Bands List and displays the MNF Eigenvalues 
Plot Window. The output only contains the number of bands you selected for output. For 

example, if your input data contained 224 bands, but you selected only 50 bands for 

output, your output will only contain the first 50 calculated MNF bands from your input. 

Figure 5-4: MNF Eigenvalues Plot Window 

8. Load an RGB image of the top 3 MNF bands.  Inspect the z-profile of the MNF image.  

Link the MNF image to your CIR reflectance image (by right clicking an image and 
selecting Geographic Link).  Are any features more readily apparent in the MNF-

transformed data?  Are different land cover classes more distinctly colored than in the 

CIR? 

9. Load band 30 as a gray scale.  How does it differ from the reflectance image and the top 
3 MNF bands? 

10. Inspect the variance structure of the image.  Open the statistics file: Basic Tools  

Statistics  View Statistics File.  In the Enter Statistics Filename dialog, find your file 

Delta_Hymap_2008_mnf_stats.sta and click OK.  Output the statistics to a text 

file in the Lab_Products folder by selecting File  Save results to text file in the Stats 

File window.  Use the filename Delta_Hymap_2008_mnf_stats.txt.   

 

You can now open this text file in Microsoft Excel.  Specify that the file type is delimited and 

that Excel should start import at line 4.  Click Next and then Finish.  Excel should open a 

spreadsheet with the PC bands as the rows.  For each MNF band it includes the minimum, 
maximum, and mean values, the standard deviation, and the eigenvalue.  If you scroll down 

further, you will see the variance-covariance matrix and the eigenvectors. 

 
Calculate the sum of all the eigenvalues.  This is the total amount of variance in your image.  

Now, next to your eigenvalue column make a new column entitled ―% variation‖.  Calculate 

this as 100 * the eigenvalue of each band divided by the sum of all the eigenvalues you just 

calculated.  How well distributed is the variation in your MNF bands?   

Now create another new column entitled ―cumulative variation‖ and calculate the values.  (A 

quick way to do this is to set the cumulative variation for the first band equal to its % 
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variation.  For the second band, enter the formula ―= the cell with the % variation for that 

band + the cell with the cumulative variation for the preceding band‖.  Now copy that 
formula and paste it into the remaining rows.) 

11. To perform dimensionality reduction of MNF (or PCA) bands, common rules of thumb 

are to: 

a. Exclude all bands occurring after a threshold of 80% cumulative variation. 

b. Exclude all bands whose eigenvalue is less than the average eigenvalue. 

c. Plot the eigenvalues vs. band number.  This is called a ―Scree plot‖.  Identify the 

band at which a kink occurs and the scree plot flattens out and exlude all bands 
occurring after this one. 

d. View the individual MNF bands and exclude those that are dominated by noise 

and are not spatially coherent. 

e. If you performed the MNF transform on a mosaic of several images, you should 

inspect each MNF output band and discard those that show dramatic differences 

between the individual images that make up the mosaic. 

Examine MNF Scatter Plots 

1. Use Tools → 2D Scatter Plots in the Main Image window to understand the MNF 
images. 

2. Choose MNF band 1 as your X and MNF band 2 as your Y. 

3. Now plot 2 reflectance bands against each other (e.g., bands 18 and 28).  Can you see 

from the plots that the 2 reflectance bands are much more tightly correlated to each 
other than the 2 MNF bands are? 

4. Now plot a reflectance band (e.g., band 28) against a high variance (low band 

number) MNF band (e.g., band 1).  Remember that MNF bands are linear 
combinations of the original reflectance bands.  The degree to which these bands are 

correlated depends on the contribution of that reflectance band to that MNF band. 

5. Plot a reflectance band (e.g., band 28) against a low variance (high band number) 

MNF band (e.g., band 30).  Can you see from the nebulous point cloud that the 
reflectance band makes a much lower contribution to this MNF band, which is 

dominated by noise. 

6. Notice the corners (pointed edges) on some MNF scatter plots (Figure 5-5).  Pixels 
occurring in these regions are generally interpreted as being spectrally pure, 

composed of a single land cover while pixels that fall within these corners on the 

scatter plots are expected to be mixtures of the materials at the corners.  Pixels that 
fall in the pointed edges may be good choices as training data for classifications or 

other analyses.  We will discuss the idea of pure and mixed pixels in more depth in 

the unmixing labs. 
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Figure 5-5: MNF Scatter Plot 

7. Use linked windows, overlays, ―dancing pixels‖, and Z-profiles to understand the 
reflectance spectra of the MNF corner pixels. Look for areas where the MNF data 

stops being ―pointy‖ and begins being ―fuzzy‖. Also notice the relationship between 

scatter plot pixel location and spectral mixing as determined from image color and 

individual reflectance spectra. 

Complete Your Data Products Spreadsheet 

You have created several data products from the input file Delta_HyMap_2008.img, 

including Delta_HyMap_2008_pca.img, and Delta_HyMap_2008_mnf. Record this 

information, including file pathways, in your your_name_data_products.xls 

spreadsheet.   

You may wish to reorganize your Lab_Products folder using subfolders to appropriately group 
your files together (i.e. index files vs continuum removal images), or transfer your files to your 

appropriate personal lab folder(s). 
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Tutorial 6: Unsupervised and Supervised Classification 
The following topics are covered in this tutorial: 

Unsupervised and Supervised Classification Techniques 

K-Means 

IsoData 

Parallelepiped 

Minimum distance 

Mahalanobis distance 

Maximum likelihood 

Rule classifier 

Post-classification Processing 

Class statistics 

Accuracy assessment 

Classification generalization 

Creating a class GIS  

Overview of This Tutorial 
Classification is the process of assigning class membership to a set of samples.  In the case of 
remote sensing, the samples are the pixels of an image.  Pixels are classified on the basis of 

spectral similarity, using a variety of statistical techniques.  Classes may be defined a priori, using 

ground reference data and knowledge of the site, or may be specified from the natural spectral 
groupings within an image.  This tutorial leads you through a typical multispectral classification 

procedure using Landsat TM data from the Delta, California. Results of both unsupervised and 

supervised classifications are examined and post classification processing including clump, sieve, 
combine classes, and accuracy assessment are discussed. 

Files Used in This Tutorial 

Input Path: My Documents\ERS_186\Lab_Data\Multispectral\Landsat\ 

Output Path: My Documents\ERS_186\your_folder\lab6 

Input Files Description 

Delta_LandsatTM_2008.img Delta, CA, TM Data 

Delta_classes_2008.roi ENVI regions of interest file 

Output Files Description 

Delta_2008_class_km.img K-means classification file 

Delta_2008_class_id.img Isodata classification file 

Delta_2008_class_pp.img Parallelepiped classification file 

Delta_2008_class_mahd.img Mahalanobis Distance classification file 



 66 

Delta_2008_class_mahdr.img Mahalanobis Distance rules file 

Delta_2008_class_mahd2.img 
Optimized Mahalanobis Distance 

classification file. 

Delta_2008_class_mind.img Minimum Distance classification file 

Delta_2008_class_ml.img Maximum Likelihood classification file 

Delta_2008_class_mahd2_sieve.img Mahalanobis Distance sieved file 

Delta_2008_class_mahd2_clump.img Mahalanobis Distance clumped file 

Delta_2008_class_mahd2_comb.img Combined classes file 

Examine Landsat TM Color Images 
This portion of the exercise will familiarize you with the spectral characteristics of the Landsat 

TM data of the Delta, California, USA. Color composite images will be used as the first step in 

locating and identifying unique areas for use as training sets in classification. 

Start ENVI 

Start ENVI by double-clicking on the ENVI icon. The ENVI main menu appears when the 

program has successfully loaded and executed. 

Open and Display Landsat TM Data 

To open an image file: 

1. Select File → Open Image File on the ENVI main menu. 

Note: On some platforms you must hold the left mouse button down to display the 

submenus from the ENVI main menu. 

An Enter Data Filenames file selection dialog appears. 

2. Navigate to the C:\My Documents\ERS_186\Lab_Data\Multispectral\Landsat\ directory 

and select the file Delta_LandsatTM_2008.img from the list and click OK. 

The Available Bands List dialog appears on your screen. This list allows you to select 
spectral bands for display and processing. 

Note: You have the choice of loading either a gray scale or an RGB color image. 

3. Select the RGB Color radio button in the Available Bands List, and then click on bands 4, 

3, and 2 sequentially with the left mouse button. The bands you have chosen are 

displayed in the appropriate fields in the center of the dialog. 

4. Click on the Load RGB button to load the image into a new display.  A false-color 

infrared (CIR) display should appear. 

Review Image Colors 

Use the displayed color image as a guide to classification. Even in a simple three-band image, 

it‘s easy to see that there are areas that have similar spectral characteristics. Bright red areas 

on the image have high infrared reflectance and low reflectance in the red and green, which is 

characteristic of healthy vegetation, especially that under cultivation. Slightly darker red areas 
typically represent native vegetation; in this area, it tends to occur on the hills and in 
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Figure 6-2: Spectral Plots from 

Canon City TM Data 

wetlands. Urbanization is also readily apparent. The following figure shows the resulting 

Main Image window for these bands. 

 

Figure 6-1: Delta, California Landsat TM Data 

Cursor Location/Value 

Use ENVI‘s Cursor Location/Value dialog to preview image values in the displayed spectral 

bands and the location of the cursor.  

1. Select Tools → Cursor Location/Value from the Main Image window menu bar.  

Alternatively, double-click the left mouse button in the image display to toggle the 

Cursor Location/Value dialog on and off.  Or you can right click in any window of the 

display and choose Cursor Location/Value. 

2. Move the cursor around the image and examine the data values in the dialog for specific 

locations. Also note the relationship between image 

color and data value. 

3. Select File → Cancel in the Cursor Location/Value 

dialog to dismiss it when finished. 

Examine Spectral Plots 

Use ENVI‘s integrated spectral profiling capabilities to 
examine the spectral characteristics of the data. 

1. Choose Tools → Profiles → Z Profile (Spectrum) 

from the Main Image window menu bar to begin 
extracting spectral profiles or right click in any 

display window and choose Z Profile (Spectrum). 

2. Examine the spectra for areas that you previewed 

above using the Cursor/Location Value dialog by 
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clicking the left mouse button in any of the display group windows.  The Spectral Profile 

window will display the spectrum for the pixel you selected. Note the relations between 
image color and spectral shape. Pay attention to the location of the displayed image bands 

in the spectral profile, marked by the red, green, and blue bars in the plot. 

3. Select File → Cancel in the Spectral Profile dialog to dismiss it. 

Unsupervised Classification 
Start ENVI‘s unsupervised classification routines from the ENVI main menu, by choosing 

Classification → Unsupervised → K-Means or IsoData. 

K-Means 

Unsupervised classifications use statistical techniques to group n-dimensional data into 

their natural spectral classes. The K-Means unsupervised classifier uses a cluster analysis 

approach which requires the analyst to select the number of clusters to be located in the 
data.  The classifier arbitrarily locates this number of cluster centers, then iteratively 

repositions them until optimal spectral separability is achieved. 

Choose Classification → Unsupervised → K-Means, use all of the default values, 

choose the Lab_Products output directory, give the name, 

Delta_2008_class_km.img and click OK.  

1. Load the file, Delta_2008_class_km.img. Highlight the band name for this 

classification image in the available bands list, click on the Gray Scale radio button, 

select New Display on the Display button pull-down menu, and then Load Band. 

2. From the Main Image display menu, select Tools → Link → Link Displays and 
click OK in the dialog to link the images. 

3. Compare the K-Means classification result to the color composite image.  You can 

resize the portion of the image using the dynamic overlay by clicking the center 

mouse button and defining a rectangle.  Move the dynamic overlay around the image 
by clicking and dragging with the left mouse button. 

4. Try to indentify the land cover associated with each class and write this down. 

5. When finished, select Tools→ Link → Unlink Display to remove the link and 
dynamic overlay. 

If desired, experiment with different numbers of classes, change thresholds, standard 

deviations, and maximum distance error values to determine their effect on the 
classification.   

IsoData 

IsoData unsupervised classification calculates class means evenly distributed in the data 

space and then iteratively clusters the remaining pixels using minimum distance 
techniques. Each iteration recalculates means and reclassifies pixels with respect to the 

new means. This process continues until the number of pixels in each class changes by 

less than the selected pixel change threshold or the maximum number of iterations is 
reached.  

Choose Classification → Unsupervised → IsoData, use all of the default values, choose 

your output directory, give the name, Delta_2008_class_id.img and click on OK. 
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1. Load the file Delta_2008_class_id.img. Highlight the band name for this 

classification image in the available bands list, click on the Gray Scale radio button, 
select New Display on the Display button pull-down menu, and then Load Band. 

2. In the main image window, select Tools → Link→ Link Displays. Click OK to link 

this image to the false-color CIR and the K-Means classification. 

3. Compare the IsoData classification result to the color composite image using the 

dynamic overlay as you did for the K-Means classification. Change the image that is 

displayed by the dynamic overlay by holding the left mouse button down in an image 
window and simultaneously clicking on the middle mouse button.  

4. Try to identify the land cover associated with each class and write this down. 

5. Compare the IsoData and K-Means classifications.  Note that these two classifiers 

will have assigned different colors to similar spectral classes.  Do class boundaries 
generally agree spatially between the two techniques?  Look at your land cover 

interpretations for the 2 classifications.  Do they split the spectral data into similar 

classes?  

If desired, experiment with different numbers of classes, change thresholds, standard 

deviations, maximum distance error, and class pixel characteristic values to determine 

their effect on the classification. 

You may close your K-Means and IsoData classification images. 

Supervised Classification 
Supervised classifications require that the user select training areas to define each class. 

Pixels are then compared to the training data and assigned to the most appropriate class. 

ENVI provides a broad range of different classification methods, including Parallelepiped, 
Minimum Distance, Mahalanobis Distance, Maximum Likelihood, Spectral Angle Mapper, 

Binary Encoding, and Neural Net. Examine the processing results below, or use the default 

classification parameters for each of these classification methods to generate your own 

classes and compare results. 

To perform your own classifications, in the ENVI main menu select Classification → 

Supervised→ [method], where [method] is one of the supervised classification methods in 

the pull-down menu (Parallelepiped, Minimum Distance, Mahalanobis Distance, Maximum 
Likelihood, Spectral Angle Mapper, Binary Encoding, or Neural Net). Use one of the two 

methods below for selecting training areas, also known as regions of interest (ROIs). 

Select Training Sets Using Regions of Interest (ROI) 

As described in Lab 1, ―Introduction to ENVI‖ and summarized here, ENVI lets you 
easily define regions of interest (ROIs) typically used to extract statistics for 

classification, masking, and other operations. For the purposes of this exercise, you can 

either use predefined ROIs, or create your own. 

Restore Predefined ROIs 

1. Open the ROI Tool dialog by choosing Overlay → Region of Interest in the 
main image window. 

2. In the ROI Tool dialog, choose File → Restore ROIs. 
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3. The Enter ROI Filename dialog opens. Select Delta_classes_2008.roi as 

the input file to restore. 

You can check out these regions by selecting one in the ROI Tool dialog and clicking 

Goto. 

Create Your Own ROIs 

If you are using the predefined ROIs, skip ahead to the Classical Supervised 

Multispectral Classification section. 

1. Select Overlay → Region of Interest from the Main Image window menu bar. 

The ROI Tool dialog for the display group appears. 

2. In the Main Image window draw a polygon that represents the new region of 
interest. To accomplish this, do the following. 

 Click the left mouse button in the Main Image window to establish the first 

point of the ROI polygon. 

 Select further border points in sequence by clicking the left button again, and 

close the polygon by clicking the right mouse button. The middle mouse 
button deletes the most recent point, or (if you have closed the polygon) the 

entire polygon. Fix the polygon by clicking the right mouse button a second 

time. 

 ROIs can also be defined in the Zoom and Scroll windows by choosing the 

appropriate radio button at the top of the ROI Controls dialog. When you 
have finished creating an ROI, its definition is shown in the table of the ROI 

Tool dialog. The definition includes the name, region color, number of pixels 

enclosed, and other ROI properties.  

3. To define a new ROI, click the New Region button. 

 You can enter a name for the region and select the color and fill patterns for 

the region by editing the values in the cells of the table. Define the new ROI 

as described above. 

Classical Supervised Multispectral Classification 

The following methods are described in most remote sensing textbooks and are 

commonly available in today‘s image processing software systems.  

Parallelepiped 

Parallelepiped classification uses a simple decision rule to classify multispectral data. 

The decision boundaries form an n-dimensional parallelepiped in the image data 
space. The dimensions of the parallelepiped are defined based upon a standard 

deviation threshold from the mean of each selected class.  Pixels are assigned to a 

class when they occur within that class‘s parallelepiped.  If they are outside all 
parallelepipeds, they are left unclassified. 

1. Perform a parallelepiped classification (Classification → Supervised→ 

Parallelepiped) on the image Delta_LandsatTM_2008.img  using the 

Delta_classes_2008.roi regions of interest or the ROIs you defined. 

Run the classification using the default parameters. Save your results in the 

Lab_Products folder as Delta_2008_class_pp.img.  You may also output 
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a rules image if you like.  Use the toggle switch to choose whether or not a rules 

image is generated. 

2. Use image linking and the dynamic overlay to compare this classification to the 

color composite image.  Do you see any pixels that are obviously misclassified?  

(e.g., vegetated pixels assigned to the urban class, etc..) 

Minimum Distance 

The minimum distance classification (Classification → Supervised→ Minimum 

Distance) uses the centroids (i.e., the mean spectral values) of each ROI and 

calculates the Euclidean distance from each unknown pixel to the centroid for each 

class. All pixels are classified to the closest ROI class unless the user specifies 

standard deviation or distance thresholds, in which case some pixels may be 
unclassified if they do not meet the selected criteria. 

1. Perform a minimum distance classification of the Landsat scene using the 

Delta_classes_2008.roi regions of interest or the ROIs you defined. 

Run the classification using the default parameters. Save results as 

Delta_2008_class_mind.img.  You may also output a rules image if you 

like.  Use the toggle switch to choose whether or not a rules image is generated. 

2. Use image linking and the dynamic overlay to compare this classification to the 

color composite image and the parallelepiped classification.  Do you see any 

pixels that are obviously misclassified?  How do the parallelepiped and minimum 
distance results differ?  Note especially the Aquatic Vegetation class if you used 

the predefined ROIs. 

Mahalanobis Distance 

The Mahalanobis Distance classification (Classification → Supervised→ 

Mahalanobis Distance) is a direction sensitive distance classifier that uses 
covariance statistics in addition to class means and standard deviations. It is similar 

to the Maximum Likelihood classification but assumes all class covariances are equal 

and therefore is a faster method. All pixels are classified to the closest ROI class 
unless the user specifies a distance threshold, in which case some pixels may be 

unclassified if they do not meet the threshold. 

1. Perform a Mahalanobis distance classification using the 

Delta_classes_2008.roi regions of interest or the ROIs you defined. 

Run the classification using the default parameters. Save results as 

Delta_2008_class_mahd.img.  Choose to output a rules file and name it 
Delta_2008_class_mahdr.img. 

2. Use image linking and the dynamic overlay to compare this classification to the 

color composite image and previous supervised classifications.  Do you see any 

pixels that are obviously misclassified?  How do Mahalanobis results differ from 
the other 2 supervised classifications?  Note especially the Aquatic Vegetation 

class if you used the predefined ROIs. 

3. Load a band from the rule image and link it to the classification.  The values in 
the rule image are the calculated Mahalanobis distances from that pixel to the 

training data for each class.  Display the z-profile for the rule image.  Notice the 

relationship between the relative values of the rule bands and the classification 
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Figure 6-3: Endmember Collection Dialog 

result.  The pixel is assigned to the class for which it has the minimum 

Mahalanobis distance. 

Maximum Likelihood 

Maximum likelihood classification (Classification → Supervised→ Maximum 

Likelihood) assumes that the reflectance values for each class in each band are 

normally distributed and calculates the probability that a given pixel belongs to each 

class. Unless a probability threshold is selected, all pixels are classified. Each pixel is 
assigned to the class for which it has the highest probability of membership (i.e., the 

maximum likelihood). 

1. Perform a maximum likelihood classification using the 

Delta_classes_2008.roi regions of interest or the ROIs you defined. 

Run the classification using the default parameters. Save results as 

Delta_2008_class_ml.img.  You may also output a rules image if you 

like.  Use the toggle switch to choose whether or not a rules image is generated. 

2. Use image linking and the dynamic overlay to compare this classification to the 

color composite image and previous supervised classifications.  Do you see any 
pixels that are obviously misclassified?  How do Mahalanobis results differ from 

the other 2 supervised classifications?  Note especially the Urban class if you 

used the predefined ROIs. 

3. You may now close all of your classification displays. 

The Endmember Collection Dialog 
The Endmember Collection dialog is an alternative method to import training data into 

your classifiers.  It is a standardized means of collecting spectra for supervised 
classification from ASCII files, regions of interest, spectral libraries, and statistics files.  

You do not need to perform any classifications via this pathway as the results would be 

identical to those you have already generated, but the procedure, for future reference, is: 

1. To start the Classification Input File dialog from the 

ENVI main menu, select Spectral → Mapping 

Methods → Endmember Collection. 
This dialog can also be started by choosing 

Classification → Endmember Collection from the 

ENVI main menu. 

2. In the Classification Input File dialog, select 

Delta_LandsatTM_2008.img and click OK. 

3. This brings up the Endmember Collection dialog.  

 
The Endmember Collection dialog appears with the 

Parallelepiped classification method selected by default. The 

available classification and mapping methods are listed by 
choosing Algorithm → [method] from the Endmember 

Collection dialog menu bar, where [method] represents one of 

the methods available, including Parallelepiped, Minimum 

Distance, Manlanahobis Distance, Maximum Likelihood, 
Binary Encoding, and the Spectral Angle Mapper (SAM).   
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Note:  You must select the algorithm BEFORE importing endmembers in order for ENVI to 

calculate the correct statistics. 

4. Close the Endmember Collection dialog. 

Rule Images 
ENVI creates images that show the pixel values used to create the classified image. These 
optional images allow users to evaluate classification results and to reclassify as 

necessary using different thresholds. These are gray scale images; one for each class in 

the classification. The rule image pixel values represent different things for different 

types of classifications, for example: 

Classification Method Rule Image Values 

Parallelepiped Number of bands satisfying the parallelepiped criteria 

Minimum Distance Euclidean distance from the class mean 

Maximum Likelihood Probability of pixel belonging to class (rescaled) 

Mahalanobis Distance Mahalanobis distance from the class mean 

1. For the Mahalanobis Distance classification above, load the classified image and the 

rule image for one class into separate displays. Invert the rule images using Tools → 

Color Mapping → ENVI Color Tables and drag the Stretch Bottom and Stretch 

Top sliders to opposite ends of the dialog. Pixels closer to class means (i.e., those 

with spectra more similar to the training ROI and thus shorter Mahalanobis distances) 
now appear bright.  

2. Link the classification and rule image displays.  Use Z-profiles and the Cursor 

Location/Value tool to determine if better thresholds could be used to obtain more 
spatially coherent classifications.  In particular, identify a better threshold value for 

the Aquatic Vegetation class so that classified pixels include aquatic vegetation, but 

exclude the Pacific Ocean and upland green and nonphotosynthetic vegetation.  To 

do so, find a Mahalanobis distance value is greater than those exhibited by most 
pixels that truly contain aquatic vegetation, but it lower than pixels that are 

erroneously classified as Aquatic Vegetation. 

3. If you find better thresholds, select Classification→ Post Classification → Rule 
Classifier from the ENVI main menu. 

4. Choose the Delta_2008_class_mahdr.img input file as the rule image and 

click OK to bring up the Rule Image Classifier Tool, then enter a threshold to create a 
new classified image.  Click on the radio button to classify by Minimum Value.  This 

lets ENVI know that smaller rule values represent better matches.  

5. Click Quick Apply to have your reclassified image displayed in a new window.   

6. Compare your new classification to the previous classifications.  Since you have set 

thresholds where there were none originally, you should now have some unclassified 

pixels, displayed as black. 

7. You may continue to adjust the rule classifier until you are satisfied with the results.  
Click Save To File when you are happy with the results, and choose the filename 
Delta_2008_class_mahd2.img. 
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Figure 6-4: Sample Class Statistics Report  

 

Post Classification Processing 
Classified images require post-processing to evaluate classification accuracy and to 
generalize classes for export to image-maps and vector GIS. ENVI provides a series of tools 

to satisfy these requirements. 

Class Statistics 

This function allows you to extract statistics from the image used to produce the 

classification. Separate statistics consisting of basic statistics, histograms, and average 

spectra are calculated for each class selected. 

1. Choose Classification→ Post Classification → Class Statistics to start the process 

and select a Classification Image (e.g.: Delta_2008_class_mahd2.img) and 

click OK. 

2. Select the image used to produce the 
classification  

(Delta_LandsatTM_2008. 

img) and click OK. 

3. Click Select All Items and then OK in 

the Class Selection dialog. 

4. Click the Histograms and Covariance 

check boxes in the Compute Statistics 

Parameters dialog to calculate all the 

possible statistics. 

5. Click OK at the bottom of the 

Compute Statistics Parameters dialog. 

The Class Statistics Results dialog 
appears. The top of this window 

displays the mean spectra for each 

class.  Do the mean spectra 

correspond to expected reflectance 
profiles for these land cover classes? 

Summary statistics for each class by 

band are displayed in the Statistics 
Results dialog. You may close this                                                                             

window. 

Confusion Matrix 

ENVI‘s confusion matrix function allows comparison of two classified images (the 
classification and the ―truth‖ image), or a classified image and ROIs. The truth image can 

be another classified image, or an image created from actual ground truth measurements.  

We do not have ground reference data for this scene, so you will be comparing two of 
your classifications to each other.  You will also compare a classification to the training 

ROIs, although this will not provide an unbiased measure of accuracy. 

1. Select Classification → Post Classification → Confusion Matrix → [method], 
where [method] is either Using Ground Truth Image, or Using Ground Truth ROIs. 

2. For the Ground Truth Image Method, compare the Parallelepiped and Maximum 

Likelihood images you previously created by choosing the two files, 
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Delta_2008_class_ml.img and Delta_2008_class_pp.img and 

clicking OK (for the purposes of this exercise, we are using the 

Delta_2008_class_pp.img file as the ground truth). 

3. Use the Match Classes Parameters dialog to pair corresponding classes from the two 

images and click OK.  (If the classes have the same name in each image, ENVI will 
pair them automatically.) 

4. Answer ―No‖ in the Confusion Matrix Parameters where it asks ―Output Error 

Images?‖. 

5. Examine the confusion matrix. For which class do the classifiers agree the most?  On 

which do they disagree the most?  Determine sources of error by comparing the 

classified images to the original reflectance image using dynamic overlays, spectral 
profiles, and Cursor Location/Value. 

6. For the Using Ground Truth ROIs method, select the classified image 

Delta_2008_class_ml.img to be evaluated. 

7. Match the image classes to the ROIs loaded from Delta_classes.roi, and click 

OK to calculate the confusion matrix. 

8. Click OK in the Confusion Matrix Parameters dialog. 

9. Examine the confusion matrix and determine sources of error by comparing the 

classified image to the ROIs in the original reflectance image using spectral profiles, 

and Cursor Location/Value.  According to the confusion matrix, which classes have 
the lowest commission and omission errors?  Is this supported by your inspection of 

the images? 

 

Figure 6-5: Confusion Matrix using a Second Classification Image as Ground Truth 
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Clump and Sieve 

Clump and Sieve provide methods for generalizing classification images. Sieve is usually 
run first to remove the isolated pixels based on a size (number of pixels) threshold, and 

then clump is run to add spatial coherency to existing classes by combining adjacent 

similar classified areas. Illustrate what each of these tools does by performing the 

following operations and comparing the results to your original classification. 

1. To sieve, select Classification→ Post Classification → Sieve Classes, choose 

Delta_2008_class_mahd2.img, choose your output folder, give filename 

Delta_2008_class_mahd2_sieve.img and click OK.   

2. Use the output of the sieve operation as the input for clumping. Choose 

Classification → Post Classification → Clump Classes, choose 

Delta_2008_class_mahd2_sieve.img and click OK. 

3. Output as Delta_2008_class_mahd2_clump.img and click OK in the 

Clump Parameters dialog. 

4. Compare the three images.  Do you see the effect of both sieving and clumping?   

Reiterate if necessary with different thresholds to produce a generalized classification 

image. 

Combine Classes 

The Combine Classes function provides an alternative method for classification 

generalization. Similar classes can be combined into a single more generalized class. 

1. Perform your own combinations as described below. 

2. Select Classification→ Post Classification → Combine Classes.  

3. Select the Delta_2008_class_mahd2.img file in the Combine Classes Input 

File dialog and click OK. 

4. Choose Urban (as the input class) to combine with Unclassified (as the output class), 

click on Add Combination, and then OK in the Combine Classes Parameters dialog. 

Choose ―Yes‖ in response to the question ―Remove Empty Classes?‖.  Output as 

Delta_class_mahd2_comb.img and click OK. 

5. Compare the combined class image to the classified images and the sieved and 

clumped classification image using image linking and dynamic overlays. 

Edit Class Colors 

When a classification image is displayed, you can change the color associated with a 

specific class by editing the class colors. 

1. Select Tools → Color Mapping → Class Color Mapping in the Main Image 
Display window of the classification image. 

2. Click on one of the class names in the Class Color Mapping dialog and change the 

color by dragging the appropriate color sliders or entering the desired data values.  
You may choose from a pulldown menu of color options by clicking on the ―Color‖ 

menu. Changes are applied to the classified image immediately. To make the changes 

permanent, select Options → Save Changes in the dialog.  You can also edit the 
names assigned to classes in this dialog. 
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Classes to Vector Layers 

Execute the function and convert one of the classification images to vector layers which you 
can use in a GIS. 

1. Select Classification→ Post Classification → Classification to Vector and choose the 

generalized image Delta_2008_class_mahd2_clump.img within the Raster to 

Vector Input Band dialog.  (It is wise to output sieved & clumped classifications rather 

than the raw class outputs to vector.  Sieved & clumped maps are more generalized and 

less complex.  This reduces computing time and the complexity of the resulting 

polygons.) 

2. In the Raster to Vector Parameters, you can choose which classes you wish to convert to 

vectors and also whether you would like all classes to be in a single vector file or for a 

separate vector file to be created for each class. 

3. We will not convert our classification results to vectors because it can be very time 

consuming, so click Cancel. 

Classification Keys Using Annotation 

ENVI provides annotation tools to put classification keys on images and in map layouts. The 
classification keys are automatically generated.  

1. Choose Overlay → Annotation from the Main Image window menu bar for one of the 

classified images.  

2. Select Object → Map Key to add a legend to the image. You can edit the key 

characteristics by clicking on the Edit Map Key Items button in the Annotation: Map Key 

dialog and changing the desired characteristics.  You should shorten the class names that 
will be displayed. 

3. Click in the image display to place the key.  In the Annotation dialog, turn on the 

background and choose a background color that will allow your legend to be legible. 

4. Click in the display with the right mouse button to finalize the position of the key. For 
more information about image annotation, please see the ENVI User‘s Guide. 

Complete Your Data Products Spreadsheet 

You have created several data products from the input file 

Delta_LandsatTM_2008.img. You may wish to reorganize your Lab_Products folder 

using subfolders to appropriately group your files, or transfer your files to your appropriate 

personal lab folder(s).  Record this information, including file pathways, in your 

your_name_data_products.xls spreadsheet.  

 

End the ENVI Session 
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Tutorial 7: Change Detection 
The following topics are covered in this tutorial: 

Image Differencing 

Principal Components Analysis 

Post-Classification Change Detection 

Overview of This Tutorial 
This tutorial is designed to introduce you to several common remote sensing change detection 

techniques.   

Files Used in This Tutorial 

Input Path:  C:\My Documents\ERS_186\Lab_Data\Multispectral\Landsat\ 

Output Path:  C:\My Documents\ERS_186\your_folder\lab7 

Input Files Description 

Delta_LandsatTM_2008.img Delta, CA, Landsat Data, 2008 

Delta_LandsatTM_1998.img Delta, CA, Landsat Data, 1998 

Delta_LandsatTM_mahdopt.img 
Optimized 2008 Mahalanobis Distance 

Classification from assignment 3 

Delta_classes_opt.roi ROI of classification training data, 2008 

Output Files Description 

Delta_LandsatTM_2date.img Multidate Landsat image 

Delta_LandsatTM_2date_msk.img 
Mask of overlap between 1998 and 

2008 

Delta_LandsatTM_1998_NDVI.img 1998 NDVI 

Delta_LandsatTM_2008_NDVI.img 2008 NDVI 

Delta_LandsatTM_NDVI_diff.img NDVI difference, 1998-2008 

Delta_LandsatTM_2date_PCA.img Multidate principal components analysis 

Delta_LandsatTM_2date_PCAstats.sta PCA stats 

Delta_LandsatTM_1998_msk.img 1998 edge mask 

Delta_LandsatTM_1998_mahd.img 
Mahalanobis Distance Classification, 

1998 

Change Detection 
Change detection is a major remote sensing application.  A change detection analyzes two or 

more images acquired on different dates to identify regions that have undergone change and 

to interpret the types and causes of change.  Several common methods are: 
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Image differencing – Image differencing change detection subtracts a reflectance band or 

reflectance product of one image date from another.  For example: 

NDVIdiff = NDVIt+1 - NDVIt 

―Change‖ pixels are those with a large difference (positive or negative).  They are typically 

identified by setting thresholds.  For example, pixels with values more than 3 standard 

deviations from the average difference might be ―change‖ pixels.  Image differencing that has 
been generalized to multiband situations is known as Change Vector Analysis (CVA).  In 

these cases, the magnitude of differences indicates whether or not change has occurred and 

the direction of differences in multiband space provides information as to the type of change.  
For example, CVA may be performed using indexes or linear spectral unmixixing (LSU) 

fractions as inputs. 

Principal components analysis (PCA) – Another change detection method is to stack image 
dates into a single file and perform a PCA on the multidate image.  The first few PC bands 

typically represent unchanged areas (since change generally happens over only a small 

portion of a scene).  Higher order PC bands highlight change.  As with the statistical data 

reduction techniques, PCA change detections may be difficult to interpret.  Furthermore, they 
merely identify change but provide no information as to the type of change.  Users must 

interpret the change themselves by inspecting the original images. 

Post-classification change detection – In this method, the two image dates are classified 
independently.  The change detection then determines whether and how the class membership 

of each pixel changed between the image dates.  This technique provides detailed ―from – to‖ 

information about the type of change.  However, it is hampered by the accuracy of the input 
classifications.  The accuracy of a post-classification change detection can never be higher 

than the product of the individual classification accuracies. 

Preparing a Multidate Image 

1. Open the files Delta_LandsatTM_2008.img and 

Delta_LandsatTM_1998.img and load CIR displays of each.  These are Landsat 

Thematic Mapper images of the San Francisco Bay/Sacramento-San Joaquin Delta 
acquired in June 1998 and June 2008.  As you can see, these 2 images have different 

extents.  You will create and apply a mask including just the areas covered by both 

images later in this exercise, to limit our change detection to this region. 

2. Geographically link the two images.  Toggle on the zoom-window crosshairs for each 

display and click around the images to assess the georegistration.  Accurate co-

registration is crucial for a change detection.  If the image dates are sloppily 

registered, areas of false change will be identified where features fail to line up. 

3. Combine the two files into a multidate image.   

Go to Basic Tools → Layer Stacking.  The Layer Stacking Parameters dialog will 

appear. 

4. Click Import File…, choose your files Delta_LandsatTM_2008.img and 

Delta_LandsatTM_1998.img and click OK.   

5. Click Reorder Files and drag 1998 upward so this image is first (if necessary). 

 

6. In the Output File Range section choose the ―Exclusive: range encompasses file 

overlap‖ option. 
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The information on the right half of the dialog has been imported from the input files 

and should be correct. 

7. Save your multi-date image to the Lab_Products folder and name your output file 

Delta_LandsatTM_2date.img. Click OK.  This will take a few minutes for 

ENVI to process. 

8. Load an RGB of the multidate image with 2008 Band 4 in both the red and the 

green and 1998 Band 4 in the blue and geographically link it to the two single date 

images. 

In this multidate composite display, pixels that have brighter NIR reflectance in 2008 

will appear yellow.  Pixels that have brighter NIR reflectance in 1998 will appear 

blue.  Pixels with similar NIR reflectance in the two images will be displayed in 

shades of gray. 

Right click in your multidate image and select the “Pixel Locator” tool, then Click 

around in the linked images to find areas of change.  

Go to the following pixel coordinates, press apply after entering each pair: 
    Sample: 3333, Line: 2301 – Changed water levels in the Los Vaqueros Reservoir 

show up as blue in the multidate image because the reservoir had higher water levels 

in 2008, which is darker in the NIR, than in 1998. 

     Sample: 2081, Line: 3527 – This area of the South Bay show up as yellow in the 
multidate image because it appears to have been developed more in 2008, and 

flooded in 1998, showing brighter NIR in this area in 2008. 

 
Find a few more instances of change and see if you can intuit the cause. 

You will notice that there is a blue fringe along the entire northern edge of the image 

area.  This is due to the fact that the 1998 LandsatTM image extends further north 
than the 2008 image. 

9. Create a mask for the area of overlap from the two image dates:   

Go to Basic Tools → Masking → Build Mask and choose the display number that 

corresponds to your multidate image. 
 

In the Mask Definition dialog choose Options → Selected Areas “Off‖.  Then 

choose Options → Import Data Range.  

Select the input file Delta_LandsatTM_2date.img 
 

Click the up and down arrows in                                   to read                                    
 

Select the LandsatTM_2008 Band 4 and click OK 

In the Input for Data Range Mask dialog,                                                                   

enter -9999 for the Data Min Value and 0 for the Data Max Value and click OK. 

 

Save your mask file in the Lab_Products folder as 

Delta_LandsatTM_2date_msk.img and click Apply. 

10. Apply the mask to constrain the extents to have the same limited area of overlap. 
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Go to Basic Tools → Masking → Apply Mask and choose 

Delta_LandsatTM_2date.img. 

Click Select Mask Band → Mask Band (under 

Delta_LandsatTM_2date_msk.img) 

Save your output file to the Lab_Products folder and name it 

Delta_LandsatTM_2date_masked.img. Click OK. 

Calculating an NDVI Difference Image 

1. Use the masked multidate image you just completed to calculate NDVI for the 1998 and 2008 

image dates, since this file has been resampled to a common geographic extent. 

2. Open Band Math (under Basic Tools) and enter the expression:                                       
(float(b1)-float(b2))/(float(b1)+float(b2)).   

3. Pair b1 to the 1998 band 4 and b2 to the 1998 band 3 and enter the output file name 
Delta_LandsatTM_NDVI_1998.img. 

4. Repeat step 2 using the 2008 bands and save as Delta_LandsatTM_NDVI_2008.img. 

5. Load a multidate composite NDVI display as an RGB by selecting 

Delta_LandsatTM_NDVI_2008 in the red and green displays and 

Delta_LandsatTM_NDVI_1998 in the blue.   

Pixels that have higher NDVI in 2008 will appear yellow.  Pixels that have higher NDVI in 
1998 will appear blue.  Pixels with similar NDVI in the two images will be displayed in 

shades of gray 

6. Calculate an NDVI difference image: 
Use the band math expression b1-b2.  Pair b1 to the 2008 NDVI and b2 to the 1998 NDVI. 

Save the file with the output filename Delta_LandsatTM_NDVI_diff.img. 

7. View your NDVI difference image.  Geographically link it to the CIR displays of each image 
date.  Pixels that have increased vegetation (NDVI2008 > NDVI1998) should appear bright, 

pixels with reduced vegetation should appear dark (NDVI2008 < NDVI1998).  Confirm this 

interpretation with comparisons to the CIRs.   
 

Where in this scene has most of the change in NDVI occurred?  Where has remained 

relatively constant? 

8. Calculate NDVI change statistics.  Go to Basic Tools → Statistics → Compute Statistics.  

Choose the input file Delta_LandsatTM_NDVI_diff.img.  Click OK and Click OK 

again in the Compute Statistics Parameters dialog.   

9. A Statistics Results window will open displaying the minimum, maximum, mean, and 

standard deviations of the NDVI difference image.  Write down these values.  You will need 

them to choose thresholds for identifying changed pixels. 

10. Calculate threshold values of mean ± 2*st.dev.  Load the NDVI difference image into 

Display #1 and create ROIs of positive and negative change using these threshold values.  

Starting in the image window, select Overlay → Region of Interest → Options → Band 

Threshold to ROI → Delta_LandsatTM_NDVI_diff Band Math (b1-b2) and click OK. 

In the Band Threshold to ROI Parameters dialog: 
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For areas that showed an increase inNDVI greater than 2 standard deviations, enter a 

minimum threshold value of -9999 and a maximum threshold of your recorded mean minus a 
value of 2 standard deviation.  

For areas that showed a decrease in NDVI, starting in your ROI Tool box, repeat the steps 

Options → Band Threshold to ROI → Delta_LandsatTM_NDVI_diff Band Math (b1-b2) 

→ OK, except this time enter a value of 2 standard deviations above your recorded mean for 
your minimum threshold value, and 9999 for your maximum threshold value. 

11. Do you think these thresholds do a good job of identifying changed pixels? 

Perform a Multidate PCA 

1. Go to Transform → Principal Components → Forward PC Rotation → Compute New 

Statistics and Rotate. 

2. Choose the input file Delta_LandsatTM_2date_masked.img and click OK. 

3. Save your output stats file as Delta_LandsatTM_2date_PCAstats.sta  and your 

image file as Delta_LandsatTM_2date_PCA.img (in Lab_Products).  Click OK.  

This will take a few minutes. 

4. Open the PC bands individually in one display and geographically link them to CIRs loaded 
in another display (from your masked image bands 4, 3, and 2 sequentially loaded as RGB).  

Try to interpret what each PC band displays.   

 
For example, PC band 1 seems to be highlighting areas that weren‘t vegetated in both images, 

PC band 2 seems to highlight areas that were vegetated in both images, and PC band 3 has 

bright values in areas with a change in vegetation cover.   
 

Look at other PC bands and identify what they‘re telling you.  What other PC bands are 

sensitive to change? 
 

Does the PCA change detection have similar results to the NDVI difference? 

Post-Classification Change Detection 

1. In the CIR display of the 2008 bands (from the masked multidate image file), open the 

refined ROIs you used to improve the Mahalanobis classification in Assignment 3.  (If you 

did not save your ROIs, open the original Delta_classes_2008.roi file found in the 

Multispectral\Landsat folder). 

2. If not already loaded, load a CIR image of the 1998 bands (from the masked multidate image 

file). In the ROI Tool, choose Options → Reconcile ROIs via Map…  Select your ROIs and 
click OK.  

 Choose the destination file as Delta_LandsatTM_2date_masked.img and click OK.   

This will translate your ROIs which were defined relative to the 2008 image to the image 
extent of the multidate composite image.  If not already open, open the ROI tool in the 1998 

display and the ROIs should now be present.  

 Note: You can change the colors of your ROIs by right clicking them in the ROI Tool box. If you 

which to hide specific ROIs, select them individually (on the left border) and click Hide ROIs. 
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3. Click through each of the ROIs over the 1998 CIR display several times using the Goto 

button of the ROI tool to make sure that they still contain the correct classes.  If any have 
changed, delete them by clicking on them with the center mouse button in the active window. 

4. Perform a Mahalanobis Distance classification on the 1998 bands from the 

Delta_LandsatTM_2date_masked.img (selecting the appropriate spectral subset of 

just the 1998 bands).  Save your classification as Delta_LandsatTM_1998_mahd.img.  

Do not output a rule image. 

 

NOTE:  When doing a post-classification change detection, it is important that the identical 

classification procedure be performed on each image date.  Different classifications might have 

different biases, which would falsely identify change. 

5. Load both the 1998 classification you just created and the optimized Mahalanobis 

classification from the 3
rd
 homework assignment.  (If you used the original ROIs, open the 

original Mahalanobis classification from lab 4 instead of the improved one.) 

6. Navigate to Classification → Post Classification → Change Detection Statistics.  Select 

Delta_LandsatTM_1998_mahd.img as the Initial State Image and click OK.  Select 

the 2008 classification as the Final State Image and click OK. 

7. Pair the classes with their counterparts from each image date in the Define Equivalent Classes 

dialog.  (Leave unclassified and masked pixels unpaired.)  Click OK.  In the Change 

Detection Statistics Output toggle ―No‖ for both ―Output Classification Mask Images?‖ 

and ―Save Auto-Coregistered Input Images?‖ and click OK. 

8. A Change Detection Statistics window will open tabulating the amount of change that has 
occurred between each class pair.  Click on the tabs to see this output in terms of pixel 

counts, %, and area in square meters.  Go back to the pixel count display. 

 
The ―Class total‖ row gives the total number of pixels assigned to that class in the 1998 

image within the shared extent.  The ―Row Total‖ column gives the total number of pixels 

assigned to that class in the 2008 image within the shared extent.  (Row Total and Class Total 

columns differ by the number of pixels in the edge pixels of the 1998 image.) 
 

The ―Class Changes‖ column is the number of pixels for a class in 1998 that were no longer 

that class in 2008.  I.e., it is the sum of off-diagonal elements of that column. 
 

The ―Image Difference‖ is the difference between the Class total in 2008 and the Class total 

in 1998 for a class.  It is thus an index of average change across the scene, but not pixel-by-

pixel change.  Image Difference differs from Class Changes because change is occurring in 
both directions throughout the image.  This will tend to balance out over the image, as 

measured by the Image Difference, despite large numbers of individually changing pixels. 

 
 

 

 

9. Click around your classifications using the geographic link and find areas that have changed.  

Are these true changes or were the pixels wrongly classified in one image but correctly 

classified in the other? 

NOTE:  If you choose to look at the change detection matrix in terms of percents, the cells are 

calculated as the % of the pixels classified to the class in the columns in the initial state (the 1998 

image) that were classified to the class in the rows in the final state (the 2008 image).   



 84 

 

Compare the results of the three change detection techniques.  How do the products differ?  What 
are the strengths and weaknesses of each?  Which do you prefer? 

Complete Your Data Products Spreadsheet 

You have created several data products in this tutorial. You may wish to reorganize your 

Lab_Products folder using subfolders to appropriately group your files together, or transfer your 

files to your appropriate personal lab folder(s).  Record this information, including file pathways, 

in your your_name_data_products.xls spreadsheet.  You may wish to reorganize your 

files into subfolders or transfer them to your appropriate personal lab folders. 
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Tutorial 8: Map Composition in ENVI 
The following topics are covered in this tutorial: 

Map Elements 

Customizing Map Layout 

Saving Results 

Overview of This Tutorial 
This tutorial will give you working knowledge of ENVI‘s map composition capabilities. You can 
use ENVI‘s QucikMap utility to generate a basic map template and add more information using 

ENVI‘s annotation capabilities.  

Files Used in This Tutorial 

Input Path:  My Documents\ERS_186\Lab_Data\Multispectral\Landsat,  

           My Documents\ERS_186\Lab_Data\Hyperspectral 

Output Path: My Documents\ERS_186\YourFolder\lab8 

Input Files Description 

Delta_LandsatTM_2008.img SF Bay Delta, CA Landsat TM Mulitspectral data  

Delta_HyMap_2008.img 2008 HyMap flightline 

Output Files Description 

Delta_LandsatTM_2008_map.qm Saved QuickMap Parameters for Above 

Delta_LandsatTM_2008_map.ann Saved annotation result for above 

Delta_LandsatTM_2008_map.grd Saved grid parameters for above 

Delta_LandsatTM_2008_loc.tif Location Image for above 

Map Composition in ENVI  
Map composition should be an efficient process of creating an image-based map from a remote 

sensing image and interactively adding key map components. In ENVI, the map composition 
process usually consists of basic template generation (or restoring a saved template) using the 

QuickMap utility, followed by interactive customization (if required) using ENVI annotation or 

other image overlays.  
 

QuickMap allows you to set the map scale and the output page size and orientation; to select the 

image spatial subset to use for the map; and to add basic map components such as map grids, 

scale bars, map titles, logos, projection information, and other basic map annotation. Other 
custom annotation types include map keys, declination diagrams, arrows, images or plots, and 

additional text. Using annotation or grid line overlays means you can modify QuickMap default 

overlays and place all map elements in a custom manner.  
 

You can save your map composition in a display group and restore it for future modification or 

printing. Using annotation, you can build and save individual templates of common map objects.  



 86 

Open and Display Landsat TM Data  
1. From the ENVI main menu bar, select File → Open Image File. A file selection 

dialog appears. Open and load a true color image (RGB) of 

Delta_LandsatTM_2008.img (from the Multispectral folder) 

Build the QuickMap Template  
1. From the Display group menu bar, select File → QuickMap → New QuickMap. The 

QuickMap Default Layout dialog appears. This dialog allows you modify the output 

page size, page orientation, and map scale.  
2. For this exercise, accept the default values but change the Orientation to Landscape, 

and the Map Scale to 1,000,000. Click OK. A QuickMap Image Selection dialog 

appears.  
3. Use the full image for this exercise. Click and drag the lower-right corner of the red 

box downward so that the whole image is selected. Click OK. The QuickMap 

Parameters dialog appears.  
4. Click inside the Main Title field and type San Francisco Bay-Delta Landsat Map.  

5. Right-click inside the Lower Left Text field and select Load Projection Info to load 

the image map projection information from the ENVI header.  

6. For this exercise, you should leave the Scale Bars, Grid Lines, and North Arrow check 
boxes selected.  

7. Click the Declination Diagram check box to select it.  

 

 
 

Figure 8-1: The QuickMap Parameters Dialog 
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8. Click Save Template at the bottom of the dialog. A Save QuickMap Template to File 

dialog appears.  

9. In the Enter Output Filename field, enter Delta_LandsatTM_2008_map.qm. 

Click OK to save the QuickMap results as a QuickMap template file. You can recall 

this template later and use it with any image of the same pixel size by displaying the 

desired image and selecting File → QuickMap → from Previous Template from the 

Display group menu bar.  
10. Click Apply in the QuickMap Parameter dialog to display the QuickMap results in a 

display group. If desired, you can modify the settings in the QuickMap Parameters 

dialog and click Apply to change the displayed QuickMap. 
11. At this stage, you can output the QuickMap to a printer or a Postscript file. Save or 

print a copy if desired. Otherwise, continue with the next step.  

12. Review the QuickMap results and observe the map grids, scale bars, north arrow, and 
positioning of the default text. 
 

 

Figure 8-2: QuickMap Results of the San Francisco Bay-Delta 

Map Elements  
ENVI offers many options for customizing your map composition. Options include virtual 
borders, text annotation, grid lines, contour lines, plot insets, vector overlays, and classification 
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overlays. You can use the display group (Image window, Scroll window, or Zoom window) to 

perform additional, custom map composition. (If you are working in the Scroll window, you may 
want to enlarge it by dragging one of the corners to resize the display.) The following sections 

describe the different elements and provide general instructions.  

Adding Virtual Borders  

Default display groups contain only the image, with no surrounding blank space. Map 
composition typically requires some map objects to reside outside the image. ENVI provides a 

virtual border capability that allows annotation in the image borders without creating a new 

image. You can add virtual borders to an image in several ways, which are described in the 
following sections.  
 

When you generate a QuickMap, ENVI automatically adds a virtual border to all sides of the 

image to accommodate the QuickMap grid, and it displays a default grid.  

 

1. To change the default border, select Overlay → Grid Lines from the Display group 
menu bar associated with the QuickMap. A Grid Line Parameters dialog appears.  

 

 
 

 

 
 

 

 

 
 

 

 
 

 

 

       Figure 8-3: The Grid Line Parameters Dialog 
 

2. From the Grid Line Parameters dialog menu bar, select Options → Set Display 

Borders. A Display Borders dialog appears.  

3. Enter values as shown in the following figure.  
  

  
 

          Figure 8-4: The Display Borders Dialog 
 

4. Click OK. The new virtual border characteristics are immediately applied to the 

image. If you select File → Save Setup from the Grid Line Parameters dialog menu 

bar, the border information will be saved with the grid and will be restored when you 
restore the grid parameters file later. Save the border information as 
Delta_LandsatTM_2008_map.grd 
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Using the Display Preferences  

1. You can change virtual borders and other display settings using the Display 

Preferences dialog.  

2. From the Display group menu bar associated with the QuickMap, select File → 

Preferences. A Display Parameters dialog appears with a Display Border section 

similar to the above figure.  

3. Enter the desired values and select the desired color for the border.  
4. Click OK. The new borders are immediately applied to the image.  

Using the Annotation Function  

1. You can control virtual borders in the Annotation dialog.  

2. From the Display group menu bar associated with the QuickMap, select Overlay → 

Annotation. An Annotation dialog appears.  
3. From the Annotation dialog menu bar, select Options → Set Display Borders. A 

Display Borders dialog appears.  

4. Enter the desired border characteristics and click OK. The new virtual border 

characteristics are immediately applied to the image. If you save an annotation to a 
file, the border information is also saved and restored when you restore the annotation 

file later.  

Adding Grid Lines  

ENVI supports simultaneous pixel, map coordinate, and geographic (latitude/longitude) grids. A 

100-pixel virtual border (which can be adjusted as described in ―Adding Virtual Borders‖ on page 

6) is automatically appended to the image to accommodate grid labels when grids are applied. To 

add or modify image grids, follow these steps:  
1. From the Display group menu bar associated with the QuickMap, select Overlay → 

Grid Lines. A Grid Line Parameters dialog appears and a default grid is displayed 

with default grid spacings.  
2. In the Grid Spacing field, enter 4000.  

3. To change line and label characteristics for the grid, select Options → Edit Map 

Grid Attributes or Edit Geographic Grid Attributes from the Grid Line Parameters 
dialog menu bar. Alternatively, you can access grid line parameters by clicking 

Additional Properties in the QuickMap Parameters dialog.  

4. Click OK to apply the selected attributes.  

5. In the Grid Line Parameters dialog, click Apply to post the new grid to the displayed 
image.  

6. To save grid parameters for later use, select File → Save Setup from the Grid 

Parameters dialog menu bar and select an output file. 

Delta_LandsatTM_2008_map.grd. This saves a template of the grid 

parameters, which you can recall later and use with another map composition (select 

File → Restore Setup from the Grid Parameters dialog menu bar).  

Working with Annotation  

1. ENVI's annotation utility provides a way to insert and position map objects in an 

ENVI display group for map composition. Several classes of map objects are 

available.  
2. From the Display group menu bar associated with the QuickMap, select Overlay → 

Annotation. An Annotation dialog appears.  
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3. From the Annotation dialog menu bar, select Object and choose the desired annotation 

object.  
4. In the Annotation dialog, select the Image, Scroll, or Zoom radio button to indicate 

where the annotation will appear.  

5. Drag the object to a preferred location, then right-click to lock it in place.  

6. To reselect and modify an existing annotation object, select Object → Selection/Edit 
from the Annotation dialog menu bar. Then select the object by drawing a box around 

it. You can move the selected object by clicking the associated handle and dragging 

the object to a new location. You can delete or duplicate an object by choosing the 
appropriate option from the selected menu. Right-click to relock the annotation in 

place.  

7. Remember to select the Off radio button in the Annotation dialog before attempting 
non-annotation mouse functions in the display group.  

8. Keep the Annotation dialog open for the following exercises.  

Text and Symbol Annotation  

ENVI currently has a wide variety of text fonts and different standard symbol sets. In addition, 

ENVI can use TrueType fonts installed on your system. This provides access to a wide range of 
different text fonts and symbols. You can interactively scale and rotate these fonts and symbols, 

and you can set different colors and thickness.  

ENVI provides some useful symbols (including special north arrows) as a custom TrueType font. 

To modify the font characteristics, click Font and select ENVI Symbols in the Annotation dialog. 
Following are some examples of ENVI Symbols:  

 

Figure 8-5: Examples of some symbols available in ENVI 

Text:  

1. Select Object → Text from the Annotation dialog menu bar.  

2. Click Font and select a font.  
3. Select the font size, color, and orientation using the appropriate buttons and fields in 

the Annotation dialog. For information on adding additional fonts, see ―Using Other 

TrueType Fonts with ENVI‖ in ENVI Help. TrueType fonts provide more flexibility. 
Select one of the TrueType fonts available on your system by clicking Font, selecting 

a True Type option, and selecting the desired font.  

4. Type your text in the empty field in the Annotation dialog.  
5. Drag the text object to a preferred location in the image and right-click to lock it in 

place.  

Symbols:  

1. Select Object → Symbol from the Annotation dialog menu bar.  

2. Select the desired symbol from the table of symbols that appears in the Annotation 
dialog.  

3. Drag the text object to a preferred location in the image and right-click to lock it in 

place.  
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Polygon and Shape Annotation  

You can draw rectangles, squares, ellipses, circles, and free-form polygons in an image. These 

can be an outline only, or filled with a solid color or a pattern. Placement is interactive, with easy 

rotation and scaling.  
 1. Select Object → Rectangle, Ellipse, or Polygon from the Annotation dialog menu bar.  

 2. Enter object parameters as desired in the Annotation dialog.  

 3. Drag the shapes to a preferred location in the image and right-click to lock them in 
place. For polygons, use the left mouse button to define polygon vertices and the right mouse 

button to close the polygon.  

Line and Arrow Annotation  

You can draw polylines (lines) and arrows in an image. You have full control over the color, 

thickness and line type, and the fill and head characteristics for arrows.  

Arrows:  

 1. Select Object → Arrow from the Annotation dialog menu bar.  
 2. Enter object parameters as desired in the Annotation dialog.  

 3. To draw an arrow, click and hold the left mouse button and drag the cursor in the 

image to define the length and orientation of the arrow. Release the left mouse button to complete 
the arrow. You can move it by dragging the red diamond handle. Right-click to lock the arrow in 

place.  

Lines:  

 1. Select Object → Polyline from the Annotation dialog menu bar.  

 2. Enter object parameters as desired in the Annotation dialog.  
3. To draw a free-form line, click and hold the left mouse button as you are drawing. To 

draw a straight line, click repeatedly (without holding the left mouse button) to define the 

vertices. Right-click to complete the line. You can move it by dragging the red diamond 
handle. Right-click again to lock the line in place.  

Scale Bar Annotation  

ENVI automatically generates map scales based on the pixel size of the image in the map 

composition. Units include feet, miles, meters, or kilometers. You can place map scales 

individually, or in groups. You can configure the number of major and minor divisions, and the 
font and character size.  

 1. Select Object → Scale Bar from the Annotation dialog menu bar.  

 2. Enter object parameters as desired in the Annotation dialog.  

 3. Click once in the image to show the scale bar. Move it to a preferred location by 
dragging the red diamond handle. Right-click to lock the scale bar in place.  

  

Declination Diagrams  

ENVI generates declination diagrams based on your preferences. You can specify the size of the 

diagram and enter azimuths for true north, grid north, and magnetic north in decimal degrees.  

 1. Select Object → Declination from the Annotation dialog menu bar.  

 2. Enter object parameters as desired in the Annotation dialog.  
 3. Click once in the image to show the declination diagram. Move it to a preferred 

location by dragging the red diamond handle. Right-click to lock the diagram.  
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Map Key Annotation  

Map keys are automatically generated for classification images and vector layers, but you can 
manually add them for all other images. Following is an example of a map key:  

 
1. Select Object → Map Key from the Annotation dialog menu bar.  

2. Click Edit Map Key Items to add, delete, or modify individual map key items. 
3. Click once in the image to show the map key. Move it to a preferred location by  

dragging the red diamond handle. Right-click to lock the map key in place.  

4. If you want a border and title for the map key, you must add these separately as 
polygon and text annotations, respectively:  

 

Color Ramp Annotation  

You can create gray scale ramps and color bars for gray scale and color-coded images, 
respectively. This option is not available with RGB images.  

 1. Select Object → Color Ramp from the Annotation dialog menu bar.  

 

 2. In the Annotation dialog, enter minimum and maximum values and intervals as 
desired. Also set vertical or horizontal orientation.  

 

 3. Click once in the image to show the color ramp. Move it to a preferred location by 
dragging the red diamond handle. Right-click to lock the color ramp in place.  

 

Image Insets as Annotation  

While mosaicking provides one way to inset an image into another, you can also inset images 

while composing and annotating maps. Your image must be in byte data in order for this to work. 
1. Ensure that the image to be inset is listed in the Available Bands List.  

2. Select Object → Image from the Annotation dialog menu bar.  

3. Click Select New Image. An Annotation Image Input Bands dialog appears.  

4. Select the image from the Available Bands List in the Annotation Image Input Bands 
dialog and perform optional spatial subsetting. Click OK.  

5. Click once in the image to show the inset. Drag the green diamond handle to resize the 

inset as desired. Right-click to lock the inset in place.  
 

Because 8-bit displays cannot easily assign a new color table to the inset image, ENVI only 

shows a gray scale image in the display group. If your display has 24-bit color, a color image will 

be displayed.  
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Plot Insets as Annotation  

You can easily inset ENVI plots into an image during the map composition/annotation process. 
These vector plots maintain their vector character (meaning they will not be rasterized) when 

output to the printer or to a Postscript file. They will not appear when output to an image.  

You must have a plot window open, such as an X Profile, Y Profile, Z Profile, spectral plot, or 

arbitrary profile.  
1. Select Object → Plot from the Annotation dialog menu bar.  

2. Click Select New Plot. A Select Plot Window dialog appears.  

3. Select the plot and enter the desired dimensions to set the plot size. Click OK.  
4. Click once in the image to show the plot. Right-click to lock the plot in place.  

Because 8-bit displays cannot easily assign a new color table to the inset plot, ENVI only shows a 

representation of the plot in the display group. The actual plot is placed when the image is output 

directly to the printer or to a Postscript file, and the annotation is burned in. Again, this option 
does not produce a vector plot when output to ―Image.‖  

Overlaying Classification Images  
ENVI classification images can be used as overlays during map composition. First, classify the 

image (see ENVI Help for procedures) or open an existing ENVI classification image. Once the 
classified image is listed in the Available Bands List, then you can use it as an overlay.  

1. From the Display group menu bar associated with the map composition, select 

Overlay → Classification. A file selection dialog appears.  
2. Select an ENVI classification image and click OK. An Interactive Class Tool dialog 

appears.  

3. Turn on specific classes to appear in the map composition by selecting the 
corresponding On check boxes. The selected classes will appear in the appropriate 

color as an overlay on the image.  

4. You can change class colors and names by selecting Options → Edit class 

colors/names from the Interactive Class Tool dialog menu bar.  

Overlaying Contour Lines  
You can contour Z values of images and overlay the contour lines as vectors on an image 

background. Digital elevation models (DEMs) work best. Add contours to a map composition as 

follows:  
1. From the Display group menu bar associated with the map composition, select 

Overlay → Contour Lines. A Contour Band Choice dialog appears.  

2. Select the desired image to contour and click OK. A Contour Plot dialog appears.  

3. To use the default contour values, click Apply. Otherwise, you can add new contour 
levels, edit contours, and change colors and line types using the Contour Plot dialog. 

See ENVI Help for details.  

Incorporating Regions of Interest  
You can incorporate Regions of interest (ROIs) into ENVI map compositions. Generate ROIs by 

drawing them, by thresholding specific image bands, by utilizing 2D or n-D scatter plots, or by 
performing vector-to-raster conversions. See ENVI Help for details. Display an ROI in a map 

composition as follows:  

1. From the Display group menu bar associated with the map composition, select 
Overlay → Region of Interest. An ROI Tool dialog appears, listing any existing 

ROIs having the same dimensions as the displayed image. These ROIs appear in the 

image.  

2. Add or modify ROIs as desired. See ENVI Help for further details.  
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Overlaying Vector Layers  
ENVI can import shapefiles, MapInfo files, Microstation DGN files, DXF files, ArcInfo 
interchange files, USGS DLG files, or ENVI vector files (.evf).  

1. From the Display group menu bar associated with the map composition, select 

Overlay → Vectors. A Vector Parameters dialog appears.  
2. From the Vector Parameters dialog menu bar, select File → Open Vector File. A file 

selection dialog appears.  

3. Select a file and click Open. An Import Vector Files Parameters dialog appears.  

4. Select the appropriate map projection, datum, and units for the vector layer.  
5. Click OK. ENVI converts the input vectors into an ENVI vector format (.evf).  

6. Load the vectors into the map composition by clicking Apply in the Vector 

Parameters dialog.  
7. In the Vector Parameters dialog, adjust the vector attributes to obtain the desired 

colors, thickness, and line types. See the Vector Overlay and GIS Analysis tutorial or 

see ENVI Help for additional information.  

Customize the Map Layout  

This section uses several map elements described in the previous sections to demonstrate some of 

ENVI‘s custom map composition capabilities.  
 

The QuickMap you created earlier for your Lab Assignment will be used in the following 

exercises. If you already closed Delta_LandsatTM_2008.img, redisplay it as a true color 

image.  

1. Load the QuickMap Template  

2. Once the image is displayed, follow these steps to load the previously saved 

QuickMap template and to add individual map components:  

3. From the Display group menu bar, select File → QuickMap → from Previous 

Template. The Enter QuickMapTemplate Filename dialog appears.  

4. Navigate to your output directory, select Delta_LandsatTM_2008map.qm, and 

click Open. A QuickMap Parameters dialog appears.  
5. Click Apply to generate the QuickMap image. The Load To: Current Display button is 

selected by default, so the QuickMap parameters are applied to the display group from 

which you started QuickMap.  
6. Restore saved grid parameters by selecting Overlay → Grid Lines from the Display 

group menu bar associated with the QuickMap. A Grid Line Parameters dialog 

appears.  

7. From the Grid Line Parameters dialog menu bar, select File → Restore Setup. A file 
selection dialog appears.  

8. Navigate to your output directory and select the saved grid parameters file 

Delta_LandsatTM_2008_map.grd Click Open, followed by Apply.  
9. Modify some of the grid line parameters and make them aesthetically pleasing and 

appropriate, click Apply to show your changes on the image. Be sure to save any 

changes by selecting File → Save Setup from the Grid Line Parameters dialog menu 

bar.  
10. Create some map annotation. Select Overlay → Annotation from the Display group 

menu bar associated with the QuickMap. The Annotation dialog appears.  
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11. Create a scale bar, and an object (your choice) indicating where 

Delta_HyMap_2008.img is in the LandsatTM scene. Create text that indicates 

what this object is referring to. 

12. Click and drag the handles to move the annotation objects. Modify some parameters 

for the selected objects. Right-click the objects to lock them in place. Be sure to save 
any changes by selecting File → Save Annotation from the Annotation dialog menu 

bar. See ENVI Help for further details.  

Save the Results  
You can save a map composition for future modification as a display group, or with the map 

composition "burned in" to an image.  

Saving for Future Modification  

This is the most flexible option.  
1. From the Display group menu bar associated with the map composition, select File → 

Save as Display Group.  

2. Enter an output filename and click OK.  
3. To restore this map composition, select File → Restore Display Group from the 

ENVI main menu bar.  

Saving as a “Burned-in” Image  

1. From the Display group menu bar associated with the map composition, select File → 

Save Image As → Postscript File. An ENVI QuickMap Print Option dialog appears.  

2. Select Standard Printing and click OK to output a Postscript file. An Output Display 

to Postscript File dialog appears. Change the page size and scaling parameters as 
desired. This option provides additional control, but it may produce a map that does 

not fit well with the originally selected QuickMap scale.  

3. Select Output QuickMap to Postscript, select an output filename, and click OK to 
output a Postscript file with the specified QuickMap page size and scaling. If your 

additional annotation enlarged the image so it will not fit in the specified page size, 

ENVI asks if you want to output to multiple pages. If so, click Yes, and ENVI 

automatically creates multiple Postscript files.  

Saving as an Image File  

You can save your map composition as an image file. Output formats include ENVI (binary) 

image, BMP, HDF, JPEG, PICT, PNG, SRF, TIFF/GeoTIFF, and XWD, as well as common 
image processing system formats such as ERDAS (.lan), ERMAPPER, PCI, and ArcView Raster.  

1. From the Display group menu bar associated with the map composition, select File → 

Save Image As → Image File.  

2. Set the resolution, output file type, and other parameters as described in ENVI Help; 
enter an output filename; and click OK.  

Printing  

You can also select direct printing of the ENVI map composition, in which case, the map 
composition will be printed directly to your printer using system software drivers.  

In all of the output options listed above, graphics and map composition objects are burned 

into the image on output.  
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Tutorial 9: Wildfire Detection Exercise  
The following topics are covered in this tutorial: 

Exploration of Fire Imagery  

 Flames 

 Smoke 

 Influence of temperature on emitted radiance 

Band Math for Calculating Fire Indexes 

 Index of potassium emission 

 Index of atmospheric CO2 absorption 

Overview of This Tutorial 
This tutorial is designed to give you hands on experience analyzing hyperspectral imagery of 

wildfires. 

Files Used in this Tutorial 

Input Path:   C:\My Documents\ERS_186\Lab_Data\Hyperspectral\Fire\ 

Output Path:  C:\My Documents\ERS_186\your_folder\lab9 

Input Files Description 

AVIRIS_simi_fire_geo_img_crop_masked.img Simi Fire, CA, AVIRIS data 

Output Files Description 

AVIRIS_simi_fire_Kindex.img Index of potassium emission 

AVIRIS_simi_fire_CO2index.img 
Index of atmospheric CO2 

absorption 

Examine AVIRIS Imagery of the Simi Fire 
Airborne Visible/Infrared Imaging Spectrometer (AVIRIS) image data of the Simi Fire in 

Southern California was acquired on October 27, 2003.  The Simi Fire was part of a large 

complex of seven wildfires throughout Southern California in October 2003 that was promoted 
by high fuel load, low fuel moisture, and Santa Ana winds.  From ignition on October 25, 2003 to 

containment on November 3, 2003, the Simi Fire burned 315 structures and 44,000 ha in the 

Santa Susana Mountains and cost approximately $10 million to contain (Dennison et al. 2006). 

1. Start ENVI and open the image file 
AVIRIS_simi_fire_geo_img_crop_masked.img. 

2. Load the image file to a true-color RGB display. 

 

Observe that smoke from the fire is readily obvious and obscures the underlying 
ground cover.  Flames are visible only in the areas burning most brightly that are 

not covered by smoke.  There is little contrast between vegetated areas and 

charred areas. 
3. Load a false-color CIR display of the image. 
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Smoke plumes are still obvious, but flames stand out more and vegetation is 

more clearly distinguished in this display. 
 

4. Load gray-scale displays of individual bands in the VIS through NIR to 

determine the wavelength at which smoke penetration begins to occur.  (No need 

to inspect all of them, every 5
th
 band should suffice.) 

 

What spectral regions penetrate the smoke?  Why is the ability to penetrate 

smoke dependent on wavelength? 
 

5. Now load a false-color RGB display using the 1682, 1107, and 655 nm channels 

of the AVIRIS scene (displayed as red, green, and blue, respectively). 
 

In this display, vegetated areas appear green and burned areas appear dark gray.  

Smoke appears bright blue due to high reflectance in the 655 nm channel.  Fire 

varies from red (cooler fires) to yellow (hotter fires).  Now that smoke is not 
completely obscuring the display, a much greater burn area is visible.  You 

should be able to see both flaming and smoldering fires. 

 
6. Display the spectral (Z) profile (right clicking the image) and inspect reflected 

radiance of pixels that a) have been burned, b) contain green vegetation, and c) 

that are currently burning in the imagery.  Note that this scene is of radiance data.  
It has not been corrected to reflectance (can you think why not?).  The shape of 

non-burning spectra will be dominated by the solar emission spectrum and 

influenced by land-cover and atmospheric 

absorptions. 
 

7. In your false-color RGB, find a pixel of 

vegetation covered by smoke and view its 
spectrum.  In the Spectral Profile plot, 

choose Options → New Window: with 

Plots.   

 
Now navigate to a nearby pixel of green 

vegetation that is not obscured by smoke.  

Right click in the Spectral Profile plot and 
select Plot Key.  Left-click on the name of 

spectrum in the plot key, drag it into the 

new plot window with your smoky vegetation, and release the mouse button.  

Now both spectra are plotted in the same plot window.  You can change the 
colors and names of these spectra in Edit → Data Parameters.   

 

Can you see the influence of the smoke on the vegetation spectrum?  How does 
this relate to what you learned about the penetration of smoke by different 

wavelengths in step 3? 

 

8. Create another new plot window, this time leaving it blank to start with.  
Navigate to burning pixels and collect a sample of burning spectra in your new 

plot window using the same drag and drop technique as before. 

Figure 9-1: Spectral Profile of Smoky 
Vegetation & Clear Vegetation  
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How does fire temperature influence the spectral profile?  Is this caused by 
reflected radiation or emitted radiation?   

 

Display spectra burning at different temperatures in the same plot window and 

color-code them by temperature: 
 

For example, in the plot above the black spectrum is not burning.  All other 

spectra are of pixels that are on fire.  Spectra are colored so that cooler colors 
represent cooler pixels.  As fire temperature increases, radiance in the SWIR 

increases.  As pixels become even hotter and more dominated by fire, the 

AVIRIS sensor is saturated.  Even saturated pixels provide some indication of 
fire temperature, however.  Hotter pixels saturate more wavelengths.  For 

example, the orange spectrum above saturates only in the SWIR 2 region, the red 

spectrum saturates both SWIR 1 and SWIR 2, the magenta spectrum saturates 

into the NIR, and the maroon spectrum saturates throughout the NIR. 
 

Continue to click around your image and investigate the effects of smoke and 

burning on radiance spectra.  Using sophisticated unmixing techniques (which 
you will learn in a few weeks), it is possible to model the fire temperature of each 

pixel, but here we will assess temperature only qualitatively. 

 
9. You can now close the true-color, false-color CIR, and any gray-scale displays 

you have open. 

Calculate Hyperspectral Indexes to Detect Fire 

Hyperspectral sensors such as AVIRIS and HyMap are also known as imaging spectrometers.  

That is, they detect the full reflectance spectra of materials and are sensitive to narrow-band 

Figure 9-2: Spectral Profile of several different pixels. Notice the saturation of the 
sensor at high temperatures. 
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spectral features, just as a lab spectrometer is.  Here we will use two narrow spectral features (one 

emission and one absorption) to detect burning pixels.  We will calculate indexes based on these 
features using ENVI‘s Band Math capabilities. 

Potassium emission 

Flaming combustion thermally excites potassium (K) at relatively low excitation energies; the 

excited potassium then emits at the NIR wavelengths 766.5 and 769.9 nm.  Potassium is an 

essential mineral nutrient to plants and is present at detectable levels in soils and plants.  

Potassium emission can be detected in hyperspectral data and can be used to identify actively 
burning pixels (Vodacek et al. 2002). 

1. Load a false-color RGB of band 45 (769 nm) in red and band 46 (779 nm) in both blue and 

green.  These are the bands that we will use in our K emission index.  Pixels that are not 

undergoing flaming combustion will appear in shades of gray.  Flaming pixels will display as 
red to bright white.  (You may need to adjust the display using a predefined stretch or 

interactive stretching in Enhance.) 

2. Inspect the spectral profile of flaming and non-flaming pixels.  Focus on the region of the K 
emission around 770 nm.  Zoom into this spectral region either by drawing a box around it in 

the Spectral Profile window while holding down the center mouse button or by adjusting the 

axis ranges in Options → Plot Parameters.  Plot flaming and non-flaming spectra in the 

same window.  Can you see the K emission feature? 
3. Calculate the K emission index using band math (Basic Tools → Band Math in the ENVI 

main menu), enter the expression: float(b1)/float(b2) and press OK. 

 
In the Variables to Bands Pairing Dialog define band 1 to correspond with AVIRIS band 45 

(769 nm) and band 2 to correspond with AVIRIS band 46 (779 nm).  Enter the output 

filename AVIRIS_simi_fire_Kindex.img , save it to the correct directory, and click OK. 
 

4. Load the K emission index to a new display and link it to the false-color RGB of bands 45 

and 46 and also the false-color RGB of the 1682, 1107, and 655 nm bands.  You may need to 

adjust the display using a predefined stretch or interactive stretching in Enhance (a good 
approach would be to place the zoom window to contain flaming pixels and select Enhance 

→ [Zoom] Linear 2%).   

Figure 9-3: Spectral profile of flaming and smoldering pixels. Note the potassium emission. 
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Figure 9-4: Spectral Profile of burning and not-burning 
pixels. Note the absorption feature at 2000nm  

Do you see how the K emission index highlights burning pixels, which should appear bright 

white?  Toggle on the cursor location/value.  What range of K index values do flaming, 
smoldering, smoky, and not burning pixels exhibit?   

Atmospheric CO2 Absorption 

This method of fire detection takes advantage of atmospheric absorptions.  Reflected radiance 

travels through the atmosphere twice (i.e., once on its way from the sun to the ground and once 
again from the ground to the sensor) while emitted radiance, such as from fires, travels through 

the atmosphere only once (i.e., from the ground to the sensor).  Burning pixels should therefore 

have shallower atmospheric absorption features, including the CO2 absorption at 2000 nm, than 
pixels that are not burning and are dominated by reflected radiance (Dennison 2006). 

1. Load a false-color RGB of band 173 (2000 nm) in red and bands 171 (1980 nm) and 177 

(2041 nm) in blue and green.  These are the bands that we will use in our CO2 absorption 

index.  Pixels that are not burning will appear in shades of gray.  Burning pixels will display 
as red to bright white.  (You may need to adjust the display using a predefined stretch or 

interactive stretching in Enhance.) 

2. Inspect the spectral profile of burning 
and non-burning pixels.  Focus on the 

region of the atmospheric CO2 

absorption around 2000 nm.  Zoom into 
this spectral region either by drawing a 

box around it in the Spectral Profile 

window while holding down the center 

mouse button or by adjusting the axis 
ranges in Options → Plot Parameters.  

Plot burning and non-burning spectra in 

the same window.  Can you see the CO2 
absorption feature? 

 

Note that the CO2 absorption appears 
deeper in burning pixels, but relative to 

the amount of total radiation, it is a 

smaller absorption.  One of the benefits 

of calculating indexes is that they 
normalize for the amount of radiation and provide a less biased estimate of absorption. 

 

3. Calculate the CO2 absorption index using band math (Basic Tools → Band Math in the 
ENVI main menu), enter the expression: float(b1)/(0.666*float(b2)+0.334*float(b3)) and 

press OK.   

 

In the Variables to Bands Pairing Dialog define band 1 to correspond with AVIRIS band 173 
(2000 nm), band 2 to correspond with AVIRIS band 171 (1980 nm), and band 3 to 

correspond with AVIRIS band 177 (2041 nm).  Enter the output filename 

AVIRIS_simi_fire_CO2index.img, save it to the correct directory, and click OK. 

 

(Note that our index is formulated such that pixels with less absorption by CO2 will have 

higher index values.) 
 

4. Load the CO2 absorption index to a new display and link it to the K emission index and also 

the false-color RGB of the 1682, 1107, and 655 nm bands.  You may need to adjust the 
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display using a predefined stretch or interactive stretching.   

 
Do you see how the CO2 absorption index highlights burning pixels, which should appear 

bright white?  Toggle on the cursor location/value.  What range of CO2 index values do 

flaming, smoldering, smoky, and not burning pixels exhibit? 

 
Compare the false-color RGB, K emission index, and CO2 absorption index.  What are the 

strengths and weaknesses of each?  Is one able to detect fires that the others cannot and vice 

versa?  How are each of them influenced by sensor saturation by the brightest fires? 
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Tutorial 10.1: Spectral Mapping Methods 
The following topics are covered in this tutorial: 

Spectral Libraries 

Spectral Angle Mapper 

Overview of This Tutorial 
As you have discovered, hyperspectral data provides a great deal of information about your 

target. Data reduction techniques such as band indexes and continuum removal can highlight 
specific, narrow absorption features that can provide physiological measurements, or even 

quantify the amount of target material in a given pixel. We can also use the spectral shape, or the 

color of a pixel to classify an image. Spectral Angle Mapper (SAM) is an automated algorithm in 
ENVI that compares image spectra to reference spectra (endmembers) from ASCII files, ROIs, or 

spectral libraries. It calculates the angular distance between each spectrum in the image and 

endmember in n-dimensions, where n is the number of bands in the image. Two images result: the 
first is a classification image which shows the best SAM match for each pixel, and the second is a 

rule image for each endmember showing the actual angular distance in radians between the image 

spectrum and the endmember. The rule images can be used for subsequent classifications using 

different thresholds to decide which pixels are included in the SAM classification image. This 
tutorial goes through the building of spectral libraries, the process of classifying hyperspectral 

images based on methods that are sensitive to spectral shape, and introduces decision trees in 

ENVI. Decision trees in ENVI are a type of multistage classifier that can be used to implement 
decision rules including statistical rules, data reduction techniques, and classification results. It is 

made up of a series of binary decisions that are used to determine the correct category for each 

pixel; each decision divides the data into one of two possible classes or groups or classes.  

Files Used in This Tutorial 

Input Path:  My Documents\ERS_186\Lab_Data\hyperspectral 

Output Path: My Documents\ERS_186\YourFolder\lab10 

Input Files Description 

Delta_HyMap_2008.img Delta, CA, HyMap Data 

yourname_homework1_2008.roi 

Region of interests with 6 land cover 

classes created and submitted for lab 

assignment #1. 

Output Files Description 

Delta_HyMap_2008_spec_lib.sli Spectral Library created from ROIs 

Delta_Hymap_2006_sam.img Spectral Angle Mapper Class file 

Delta_Hymap_2006_samr.img Spectral Angle Mapper Rule file 

Spectral Libraries 
Spectral Libraries are used to build and maintain personalized libraries of material spectra, and to 

access several public-domain spectral libraries. ENVI provides spectral libraries developed at the 
Jet Propulsion Laboratory for three different grain sizes of approximately 160 "pure" minerals 
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from 0.4 to 2.5 mm. ENVI also provides public-domain U.S. Geological Survey (USGS) spectral 

libraries with nearly 500 spectra of well-characterized minerals and a few vegetation spectra, 
from a range of 0.4 to 2.5 mm. Spectral libraries from Johns Hopkins University contain spectra 

for materials from 0.4 to 14 mm. The IGCP 264 spectral libraries were collected as part of IGCP 

Project 264 during 1990. They consist of five libraries measured on five different spectrometers 

for 26 well-characterized samples. Spectral libraries of vegetation spectra were provided by Chris 
Elvidge, measured from 0.4 to 2.5 mm.  

 

ENVI spectral libraries are stored in ENVI's image format, with each line of the image 
corresponding to an individual spectrum and each sample of the image corresponding to an 

individual spectral measurement at a specific wavelength (see ENVI Spectral Libraries). You can 

display and enhance ENVI spectral libraries. 

Building Spectral Libraries  

Use the Spectral Library Builder to create ENVI spectral libraries from a variety of spectra 

sources, including ASCII files, spectral files produced by field handheld spectrometers, other 

spectral libraries, ROI means, and spectral profiles and plots.  

1. Open Delta_HyMap_2008.img (from the Hyperspectral folder) and load it in CIR. 

Overlay the 2008 region of interest (ROI) file you created for your first lab assignment.  

2. From the ENVI  main menu bar, select Spectral  Spectral Libraries  Spectral 

Library Builder. The Spectral Library Builder dialog appears. In the Input Spectral 

Wavelength From: select the Data File… radio button. 

3. In the File Containing Output Wavelength dialog, select Delta_HyMap_2008.img 

and click OK. 

4. In the Spectral Library Builder window, click Import  from ROI/EVF from input file. 

In the Input File of Associated ROI/EVF menu, select Delta_HyMap_2008.img and 

click OK. This will detect the ROI associated with your input file above.  

5. In the Select Regions for Stats Calculation window, click Select All Items and then click 

OK. ENVI will calculate the mean reflectance of the pixels in each of your polygons for 
each land cover type. This may take a few minutes. 

6. When the Stats Calculation is complete, all six landcover types will appear in the Spectral 

Library Builder window. Click Select All and then click Plot. Your endmembers, or 
training data, will be displayed in an ENVI Spectral Plot window.  

 

Figure 10-1: Three of the six land-cover class endmembers 
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7. Save your spectral library. Click  File  Save Spectra as  Spectral library file.  

8. In the Output Spectral Library window, select Z plot range 0-5000, x-axis Title 
Wavelength y-axis title Value,  Reflectance Scale Factor 10,000, Wavelength Units 

Micrometers. Save your spectral library as Delta_HyMap_2008_spec_lib.sli in 

your folder. Click OK. 

Spectral Angle Mapper Classification 
The Spectral Angle Mapper (SAM) is an automated method for comparing image spectra to 

individual spectra or a spectral library (Boardman, unpublished data; CSES, 1992; Kruse et al., 
1993a). SAM assumes that the data have been reduced to apparent reflectance (true reflectance 

multiplied by some unknown gain factor controlled by topography and shadows). The algorithm 

determines the similarity between two spectra by calculating the ―spectral angle‖ between them, 
treating them as vectors in a space with dimensionality equal to the number of bands (nb). A 

simplified explanation of this can be given by considering a reference spectrum and an unknown 

spectrum from two-band data. The two different materials will be represented in the two-

dimensional scatter plot by a point for each given illumination, or as a line (vector) for all 
possible illuminations.  

Because it uses only the ―direction‖ of the spectra, and not their ―length,‖ the method is 

insensitive to the unknown gain factor, and all possible illuminations are treated equally. Poorly 
illuminated pixels will fall closer to the origin. The ―color‖ of a material is defined by the 

direction of its unit vector. Notice that the angle between the vectors is the same regardless of the 

length. The length of the vector relates only to how fully the pixel is illuminated. 

 

Figure 10-2: Two-Dimensional Example of the Spectral Angle Mapper 

The SAM algorithm generalizes this geometric interpretation to nb-dimensional space. SAM 
determines the similarity of an unknown spectrum t to a reference spectrum r. 

For each reference spectrum chosen in the analysis of a hyperspectral image, the spectral angle α 

is determined for every image spectrum (pixel). This value, in radians, is assigned to the 

corresponding pixel in the output SAM rule image, one output image for each reference spectrum. 
The derived spectral angle rule maps form a new data cube with the number of bands equal to the 

number of reference spectra used in the mapping. Gray-level thresholding is typically used to 

empirically determine those areas that most closely match the reference spectrum while retaining 
spatial coherence. 
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The SAM algorithm implemented in ENVI takes as input a number of ―training classes‖ or 

reference spectra from ASCII files, ROIs, or spectral libraries. It calculates the angular distance 
between each spectrum in the image and the reference spectra or ―endmembers‖ in n-dimensions. 

The result is a classification image showing the best SAM match at each pixel and a ―rule‖ image 

for each endmember showing the actual angular distance in radians between each spectrum in the 

image and the reference spectrum. Darker pixels in the rule images represent smaller spectral 
angles, and thus spectra that are more similar to the reference spectrum. The rule images can be 

used for subsequent classifications using different thresholds to decide which pixels are included 

in the SAM classification image. 

Create the SAM classification 

1. Click Spectral  Mapping Methods  Spectral Angle Mapper. In the Classification 

Input File dialog, select Delta_HyMap_2008.img. Click OK. 

2. The Endmember Collection: SAM dialog window will appear. Click Import from 

Spectral Library.  Select  Delta_HyMap_2008_spec_lib.sli. Click Select All 

Items and then click OK. 

3. In the Endmember Collection: SAM window your 6 landcover types will appear. To view 

them, click Select All, and the click Plot. 

4. To apply the training data to the SAM classification, click Select All, and then click 
Apply. The Spectral Angle Mapper Parameters dialog appears. Set the Maximum Angle 

(radians) to 0.10 , enter output file names for both the classification image 

Delta_Hymap_2008_sam.img and rule image Delta_Hymap_2008_samr.img  

in the Spectral Angle Mapper Parameters dialog, and click OK. 

Evaluate the SAM image 

1. Load the SAM classification image. The classification image is one band with coded 

values for each class. When opened, the classified image will appear in the Available 
Bands List dialog. 

2. In the Available Bands List dialog, ensure that the Gray Scale radio button is selected. 

3. Click Display→ New Display, select the SAM classification image, then click Load 
Band. The classes will automatically be color coded. 

Note: The number of pixels displayed as a specific class is a function of the threshold 

used to generate the classification. Just because a given pixel is classified as a specific 

land cover doesn‘t make it so. SAM is a similarity measure, not an identifier. 

4. Load the SAM rule image.  The rule image has one band for each endmember classified, 
with the pixel values representing the spectral angle in radians. Lower spectral angles 

(darker pixels) represent better spectral matches to the endmember spectrum. When 

opened, one band for each endmember will appear in the Available Bands List dialog. 

5. In the Available Bands List dialog, ensure that the Gray Scale radio button is selected. 
Select Display → New Display, select the band labeled Water and click Load Band.  

6. Evaluate the image with respect to the SAM classification image. 

7. In the image window displaying the SAM rule band, select Tools → Color Mapping→ 

ENVI Color Tables. 
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8. Use the Stretch Bottom and Stretch Top sliders to adjust the SAM rule thresholds to 

highlight those pixels with the greatest similarity to the selected endmember.   

9. Pull the Stretch Bottom slider all the way to the right and the Stretch Top slider all the 

way to the left.  Now pixels most similar to the endmember appear bright. 

10. Move the Stretch Bottom slider gradually to the left to reduce the number of highlighted 

pixels and show only the best SAM matches in white. You can use a rule image color 
composite or image animation if desired to compare individual rule images. 

11. Repeat the process with each SAM rule image. Select File → Cancel when finished to 

close the ENVI Color Tables dialog. 

12. Select Window → Close All Display Windows from the ENVI main menu to close all 

open displays. 

Generate new SAM Classified Images Using Rule Classifier 

Try generating new classified images based on different thresholds in the rule images. 

1. Display the individual bands of the SAM rule image and choose a threshold for the 

classification by browsing using the Cursor Location/Value dialog.  

2. Now select Classification → Post Classification→ Rule Classifier. 

3. In the Rule Image Classifier dialog, select a rule file and click OK. 

4. In the Rule Image Classifier Tool dialog, select ―Minimum Value‖ in the Classify by 

field, and enter the SAM threshold you decided on in step 1 (for instance, maybe 0.6 is a 
better threshold for Clear Water‖). All of the pixels with values lower than the minimum 

will be classified. Lower thresholds result in fewer pixels being classified. 

5. Click either Quick Apply or Save to File to begin the processing. After a short wait, the 
new classification image will appear. 

6. Compare with previous classifications and observe the differences. 

Consider the following questions: 

What ambiguities exist in the SAM classification based on the two different class results and 
input spectra? Are there many areas that were not classified? Can you speculate why? 

What factors could affect how well SAM matches the endmember spectra? 

How could you determine which thresholds represent a true map of selected endmembers?  
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Tutorial 10.2: Spectral Mixture Analysis 
The following topics are covered in this tutorial: 

Linear Spectral Unmixing 

Overview of This Tutorial 
Spectral Angle Mapper is an effective classification method, but only woks with 

spectrally pure pixels. If a pixel is mixed, it is unlikely that the SAM classifier will successfully 

identify the pixel. In the environment, natural surfaces are rarely composed of a single, uniform 
material. When materials with different spectral properties are represented in an image with a 

single pixel, spectral mixing occurs. If the scale of the mixing is macroscopic, or the materials are 

not interacting, the mixing is assumed to be linear. That is, each photon strikes only one material, 
so the signals the sensors receive are added together (a linear process). 

Sometimes instead of classifying an image into land cover types you want to know the 

proportion of plant cover or bare earth in each pixel or some other general information (like 
paved roads) about the environment.  This can be done by determining the fractional composition 

of these general categories of materials in each pixel. In order to decompose a pixel into its 

constituent parts, a simple linear model can be used to describe the liner combination of the pure 

spectra of the materials located in the pixel, weighted by their fractional abundance. A spectral 
library composed of endmembers of pure pixels is the input for linear spectral unmixing (LSU). 

The ideal spectral library contains endmembers that when linearly combined can form all other 

spectra in your image. Known endmembers are often drawn from the image data (such as your 
ROIs), or drawn from a library of pure materials. A matrix is created from the endmembers, 

inverted, and multiplied by the observed spectra to obtain least-squares estimates of the unknown 

endmember abundance fractions. The fraction estimate for each endmember is derived from the 

best fit from the estimate from all bands (that is the fraction of endmember 1in the pixel  is the 
same fraction in all bands). Constraints can be placed on the solutions to give positive fractions 

that sum to 1. If you do not use this constraint and you find the computed fractions are much 

greater than 1 or less than 0, this tells you that your endmember is not the best choice for your 
image since we know that in the real world, these things can‘t be outside the physical range (0-1). 

Shadows and shade are accounted for in one of two ways: implicitly (allowing the fractions to 

sum to 1 or less), or explicitly by including a shadow endmember (requiring fractions to sum to 1).  

Files Used in This Tutorial 

Input Path:  MyDocuments\ERS_186\Lab_Data\hyperspectral 

  MyDocuments\ERS_186\Lab_Data\Multispectral\Landsat 

Output Path: MyDocuments\ERS_186\YourFolder\lab10 

Input Files Description 

Delta_HyMap_2008.img Delta, CA, HyMap Data from 2008 

Delta_HyMap_2008_mnf.img 
Minimum Noise Fraction HyMap 

image from 2008 

Delta_HyMap_2008_lsu_library.sli 
Spectral library created from image 

spectra for HyMap 2008 image 

Delta_LandsatTM_2008.img 
SF Bay-Delta Landsat TM image 
from 2008 
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Output Files Description 

Delta_HyMap_2008_lsu.img LSU fraction image of HyMap data 

Delta_LandsatTM_2008_subset.img 
Landsat TM image spatially subset to 

the extent of Delta_HyMap_12.img 

Delta_LandsatTM_2008_subset_lsu LSU fraction image of Landsat data 

Linear Spectral Unmixing 

Linear Spectral Unmixing on Hymap data 

1. To perform linear spectral unmixing in ENVI select Spectral → Mapping Methods → 

Linear Spectral Unmixing and choose the Delta_HyMap_2008.img as the input file. 

The Click OK. 

2. In the Endmember Collection:Unmixing window menu bar, select Import→ from Spectral 

Library. Choose Delta_HyMap_2008_lsu_library.sli and then click OK.  Note 

you can also use ROIS, .evf files, and other data sources as your endmembers. Select all 
items from the Input Spectral Library and click OK.  Select All endmembers listed and Plot 

them. Examine the endmembers. How many are there? What are they? Do they look like pure 

spectra to you? De-select the  shadow endmember (in this case an artificially created 
spectrum with reflectance at all bands = 0), and click Apply. Toggle the constraint button to 

No. What the sum constraint does is apply a unit weight (usually many times more than the 

variance of the image) that is added to the system of simultaneous equations in the unmixing 

inversion process. Larger weights in relation to the variance of the data cause the unmixing to 
honor the unit-sum constraint more closely. To strictly honor the constraint, the weight 

should be many more times the spectral variance of the data. Supply an output filename 

Delta_Hymap_2008_lsu.img, and click OK. 

When complete, the linear spectral unmixing image will appear in the Available Bands List.  

Notice that there is a band for each endmember that you provided.  The values of this image 

are the proportions of a given pixel that are estimated to be filled with a given target material.  

3. Display these images from the Available Bands List, and the RMS (error) image generated 

during the analysis. Bright values in the fraction images represent high abundances; the 

Cursor Location / Value function can be used to examine the actual values.  Z profiles can be 
used to compare the abundances estimated for different endmembers.  For instance, if you‘re 

pretty sure a pixel is composed of mostly vegetation, hopefully the vegetation endmember 

will have received the greatest fraction. 

4. Choose three good unmixing result images (veg, water, and npv or soil) and create a RGB 
color composite of them. Link this image to a CIR display of the image. 

5. Use spatial and spectral clues to evaluate the results of the unmixing. 

6. Explain the colors of the fractional endmembers in terms of mixing. Notice the occurrence of 
non-primary colors (not R,G,B). Are all of the fractions feasible? Note areas where 

unreasonable results were obtained (e.g. fractions greater than one or less than zero).  
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7. Load the RMS Error band into a new, single band display. Examine the RMS Error image 

and look for areas with high errors (bright areas in the image). Are there other endmembers 
that could be used for iterative unmixing? How do you reconcile these results if the RMS 

Error image does not have any high errors, yet there are negative abundances or abundances 

greater than 1.0?  

Linear Spectral Unmixing on Landsat TM data 

When a pixel size is increased, the likelihood of having more than one land cover type present in 

a pixel also increases. Without spectral mixture analysis the classification of each pixel is limited 

to a membership to only one thematic class, and the result is that you lose the ability to represent 
combinations of land covers at spatial scales below your sensor resolution. 

1. Resize the Landsat TM image to the spatial extent of the HyMap image. Click on Basic 

Tools Resize Data (Spatial/Spectral). In the Resize Data Input File window, navigate 

to and open Delta_LandsatTM_2008.img. Click on Spatial Subset and in the 

Select Spatial Subset Window, click on Subset Using File. 

2. In the Subset by File Input File window, select Delta_HyMap_2008.img. Click OK. 

In the Select Spatial Subset window click OK. In the Resize Data Input File click OK. 

3. Supply an output file name Delta_LandsatTM_2008_subset.img in the Resize 

Data Parameters dialog. Click OK. 

4. Apply Linear Spectral Unmixing to the file following the steps above. Your Unmixing 

Input file is Delta_LandsatTM_2008_subset.img. Do not select any bad bands. 

The spectral library file used will be the same from before 

Delta_HyMap_2008_lsu_library.sli. Select all of the endmembers except for 

shadow. DO NOT apply a sum-unit constraint. Supply an output file name 

Delta_LandsatTM_2008_subset_lsu.img. 

5. Create a RGB color composite of the three bands. Link this image to a CIR display of the 

image. Use spatial and spectral clues to evaluate the results of the unmixing. Load the 
RMS Error band into a new, single band display. Examine the RMS Error image and look 

for areas with high errors (bright areas in the image). How do the fraction values compare 

to the HyMap fractions? How does the RMS error of the Landsat unmixing result 
compare to the HyMap unmixing result? What affect would using fewer endmembers 

have on the mixing result? What about all of the endmembers? 

Note – refining your LSU: In order to improve your unmixing, you can extract spectra from 

regions with high RMS error. Use these as new endmembers to replace old ones or possibly add 

a new one if it is spectrally distinct and repeat the unmixing. If you get too many endmembers 
that look similar to each other, the algorithm will make mistakes in the unmixing. So it is best to 

keep the total number less than 6. 

When the RMS image doesn't have any more high errors, and all of the fraction values range 

from zero to one (or not much outside), then the unmixing is completed. This iterative method is 
much more accurate than trying to artificially constrain the mixing, and even after extensive 

iteration, also effectively reduces the computation time by several orders of magnitude 

compared to the constrained method. Optionally, if you are confident that you have all of the 
endmembers, run the unmixing again and click on Apply a unit sum constraint, click OK, 

select a filename to save the file, look at the results and compare to a unconstrained LSU. 
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Locating Endmembers in a Spectral Data Cloud  

When pixel data are plotted in a scatter plot that uses image bands as plot axes, the spectrally 
purest pixels always occur in the corners of the data cloud, while spectrally mixed pixels always 

occur on the inside of the data cloud.  

Consider two pixels, where one is in a park with uniform grass, and the other is in a lake. Now, 

consider another pixel that consists of 50 percent each of grass and lake. This pixel will plot 
exactly between the previous two pixels. Now, if a pixel is 10 percent filled with grass and 90 

percent filled with lake, the pixel should plot much closer to the pixel containing 100 percent 

lake. This is shown in the following figure. 

 

Figure 10-3: 
Scatter Plot 

Showing Pure 
Pixels and Mixing 

Endmembers 

Now consider a third pixel that is 100 

percent filled with sand. This pixel 
creates a third corner to the data cloud. Any 

pixel that contains a mixture of sand, 

water, and grass, will fall inside the triangle 
defined by connecting the three pure pixels 

together: 

 

Figure 10-4: Pure 
Pixels Defining the 

Corners of the 
Scatter Plot 

Any pixel that contains only two of the three 
materials falls on the edge of the triangle, but only the pure pixels fall in the corners of the 

triangle. In this example, the data cloud forms a triangle. This example considers only a 2D 

scatter plot with three endmembers, but even in scatter plots using any number of dimensions 
with data containing any number of endmembers, pure pixels always plot in the corners of the 

data cloud, and mixed pixels will fall within the shape defined by these corners.  
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Create ROIs from spectral library 

1. Open a true-color display of Delta_HyMap_2008.img in Display #1 and bands 2, 

3, and 4 of  Delta_HyMap_2008_mnf.img as RGB image in Display #2. Geographically 

link the two displays. 

2. Open Delta_HyMap_2008_lsu_library.sli  in your spectral library viewer. Each of 

the endmembers in Delta_HyMap_2008_lsu_library.sli except for ―shadow‖ has an x 

and y location. Use the pixel locator to find those locations in your true color HyMap image and 

your MNF image. Turn the cross hairs on in the Zoom window. 

 

3. Create an ROI at each of the pixel locations, and name each ROI the corresponding 

class represented by the endmemnber (e.g. ―soil‖, ―non-photosynthetic vegetation‖, 

―water‖).  In Display #1 go to Overlay → Regions of Interest… and toggle the ROI 

radio button to “Off”.  Once you have navigated to the corresponding pixel location of 

the endmember, in the ROI Tool dialog, select ROI Type → Point. Toggle the radio 

button to "Zoom” and click on that pixel in the zoom window. You will have created one 

ROI. Change the ROI Name to the corresponding class name. Repeat this for all 

endmembers, creating a new ROI for each endmember. 

 

4. In the MNF image (Display #2), go to Tools→2D Scatter Plots and create a scatter 

plot with MNF band 1 and MNF band 3.  

 

5. In the ROI Tool dialog, Toggle the Image on, and Go To your first ROI. Hold your 

right mouse button down over the ROI in the Zoom window.  In the scatter plot, the 

corresponding pixel, and pixels highly similar to that one will be highlighted in red. 

Repeat this for all of the ROIs. Where are the endmembers in the data cloud? Are they at 

the edges or the center?  

 

6.  In the Scatter Plot window, go to Options → Change Bands… and plot two different 

MNF bands. Highlight the endmembers and look to see where they fall in the data cloud. 

Do this for several combinations of the first 10 MNF bands. What can you conclude 

about the appropriateness of the endmembers used for the linear spectral unmixing? Were 

they spectrally pure? Do the positions of the endmembers explain some of the non-

sensical results abundance image? How could you use the data cloud to improve your 

spectral unmixing results?  
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Tutorial 11: LiDAR 
 

The following topics are covered in this tutorial: 

Overview of This Tutorial 

Exploration of lidar data  

 Ground model 

 Top-of-canopy model 

 Determining object heights 

Hyperspectral-lidar data fusion 

 Using lidar-derived heights to interpret classification results 

 Including lidar data in hyperspectral classifications 

 

Overview of This Tutorial 
This tutorial is designed to introduce you to standard lidar data products. 

 

Files Used in this Tutorial 

 

Input Path:   My Documents\ERS_186\Lab_Data\Hyperspectral\, My 

Documents\ERS_186\Lab_Data\LiDAR\ 

Output Path: My Documents\ERS_186\your_folder\lab11 

 

Input Files Description 

Delta_Hymap_12.img Hyperspectral data of Delta, CA 

Delta_Hymap_12_mnf.img MNF transform of above 

Delta_Hymap_12_ROIs.roi Regions of interest for above file 

Delta_12_fusion_mask.img Mask to exclude no-data regions  

Delta_12_bareearth_lidar_geo.img Lidar-derived digital ground model 

Delta_12_firstreturn_lidar_geo.img Lidar-derived top-of-canopy model 

Output Files Description 

Delta_12_bareearth_watermask.img Mask file to exclude water pixels 

Delta_12_lidar_heights.img Object heights estimated from lidar data 

Delta_12_mnf_class.img Classification of MNF image 

Delta_12_fusion.img Data fusion of MNF and lidar data 

Delta_12_fusion_class.img Classification using MNF and lidar data 
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Examine gridded LiDAR products 

 
LiDAR (light detection and ranging) is a form of active remote sensing.  The sensor emits a pulse 

of EMR and measures the time it takes for that pulse to reflect off the surface and return to the 
sensor, allowing the elevation of objects to be determined.  Lidar sensors provide either full-

waveform or discrete return data.  Full-waveform sensors record the intensity of pulse returns 

over all heights present, creating a complete vertical profile of the land cover.  They typically 

have large footprints.  Discrete return sensors bin returns into two or more classes; the most 
common are first returns, which are the first reflected signals received by a sensor from a 

footprint (i.e., signals reflected off of the top of trees), and last returns, or the last reflected signals 

received from a footprint (i.e., signals reflected from the ground).  Lidar data is usually analyzed 
as the raw point clouds, which requires specialized software such as Terrascan.  These points can 

be classified, interpolated, and gridded to produce surface models such as digital elevation 

models or top-of-canopy models.  We will be exploring gridded lidar products today, since these 

data can be processed in ENVI.   

 

1. Open the file Delta_12_bareearth_lidar_geo.img.  This is a digital ground model 

derived from discrete-return lidar data.  The value at each pixel is the elevation in meters.  

Explore this image using the Cursor Location/Value tool and various stretches or color tables. 
 
Note:  The elevation of water-covered areas was not modeled; these pixels contain the default 

value ‗************************‘.  This is interfering with the histogram stretch applied 
when displaying this data.  Try centering your image or zoom windows in areas that contain 

no water and then choosing Enhance → [Image] Linear 2% or Enhance → [Zoom] Linear 

2% to produce a more meaningful display. 
 

2. Calculate statistics for this file (under Basic Tools) to determine the highest, lowest, and 

mean elevations in the scene.  Where do pixels with these elevations occur?   
 

You will first need to create a mask to exclude all the ************************ values. 

 

Open the ROI tool and choose Options → Band Threshold to ROI.  Select the ground 
model file and click OK.  Enter ―************************‖ as both the min and max 

values (you can copy that text from this tutorial and paste it into the Band Threshold to ROI 

Parameters dialog) and click OK. 
 

Go to Basic Tools → Masking → Build Mask and choose the correct display for your mask 

to be associated with.  Choose Options → Selected areas “off”.  Then define your mask by 
going to Options → Import ROIs, select the ROI you just created and click OK.  Save your 

mask as Delta_12_bareearth_watermask.img.   

 
Now calculate your statistics (Basic Tools → Statistics → Compute Statistics → Select 

Mask Band) while applying this mask band.  Click OK three times. 
 

3. Open the file Delta_12_firstreturn_lidar_geo.img and load it into a new display.  
This is a top-of-canopy model derived from the lidar first returns.  The value at each pixel is 

the elevation in meters.  Link this display to your ground model.  Explore it using the Cursor 

Location/Value tool and various stretches or color tables.  Notice that trees and buildings are 
evident in the canopy model but have been removed from the ground model. 
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4. Calculate statistics for this file to determine the highest, lowest, and mean elevations of the 

top of objects in the scene.  How do these values compare to those for the ground model? 

 

5. Open the file Delta_Hymap_12.img, load a CIR to a new display, and geographically link 

it to the lidar displays.  Explore the hyperspectral and lidar data together. 

 

6. Calculate the height of objects using the band math (Basic Tools → Band Math) function 
―b1-b2‖.  You should subtract the ground model (set as b2) from the top-of-canopy model 

(set as b1).  Save this file as Delta_12_lidar_heights.img.  Display your results and 

geographically link it to the other displays.  Compute statistics for this file to determine the 

minimum, maximum, and mean object heights.  You will need to apply the bare earth 

watermask band again when you calculate statistics. 
 

Compare hyperspectral and data-fusion classifications 

 

1. Open the files Delta_Hymap_12_mnf.img and Delta_12_fusion_mask.img. 

 

2. Create a data fusion file with both the MNF bands and the lidar heights:  Go to Basic 

Tools → Layer Stacking.  Click the ―Import File…‖ button and choose the file 

Delta_Hymap_12_mnf with a spectral subset of the first 5 MNF bands only.  Repeat this 

process to import  Delta_12_lidar_heights.img.  Make sure the radio button for 

―Exclusive: range encompasses file overlap‖ is selected.  Leave all the other entries as they 

are, enter the output file name Delta_12_fusion.img, and click OK. 

 

3. Load a display with your fusion image and restore the ROI file 

Delta_12_fusion_ROIs.roi. 

 

4. Perform a maximum likelihood classification on the input file Delta_12_fusion using a 

spectral subset of just the first 5 MNF bands and applying the mask band 

Delta_12_fusion_mask.img.  (If this mask is not available for you, it means you haven‘t 

opened it yet or you did not select the ―Exclusive‖ option when you created your fused file.) 

 

Train your classification with the ROIs you restored.  Do not output a rule image.  Save your 

classification as Delta_12_mnf_class.img. 

 
5. View the output classification file.  Note where it performs well and where it performs 

poorly.  What classes are especially poor? 

 

6. Determine the average object height for each class.  Go to Classification → Post 

Classification → Class Statistics.  Choose your classification file, 

Delta_12_mnf_class.img; click OK.  Now choose your Statistics Input File, 

Delta_12_fusion.img and spectrally subset it to the lidar heights band.  Click ―Select 

Mask Band‖ and choose the mask band Delta_12_fusion_mask.img.  Click OK.  In the 

Class Selection window, choose all classes but ―Unclassified‖ and ―Masked Pixels‖ and click 
OK.  Click OK once more in the Compute Statistics Parameters dialog. 
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7. The Class Statistics Results window will appear, displaying a plot with the class means in the 

top, and in the bottom the number of pixels classified to each class and the basic stats for an 
individual class.  Write down the min, max, mean and standard deviation of heights for each 

class.  To change the class that is displayed, click on the pulldown menu underneath the 

toolbar of the statistics results window that is labeled as ―Stats for XXX‖, where XXX is the 

class that is displayed. 
 

Do these heights make sense for these classes? 

 

8. Now we will repeat the classification including the lidar height data with the MNF bands as a 

classification input. 

 

Perform a maximum likelihood classification on the file Delta_12_fusion.img, but this 

time using all bands.  Again, use the mask file Delta_12_fusion_mask.img.  Select all 

ROIs.  Do not output a rules image.  Give your output classification file the name 

Delta_12_fusion_class.img. 

 

9. View the output classification file.  Link it to the classification created with spectral data 

only.  Note where the classifier performs poorly and where it performs well.  Does including 
the lidar height data improve your classification?  Have the problem classes from the original 

spectral classification been improved? 

 

10. Repeat steps 6 and 7 to determine the min, max, mean and standard devation of class heights 

for the data fusion classification.  Do these heights make sense for these classes?  Are they 

more reasonable than the mean and max class heights from the classification using only 
spectral data? 

 

11. Compare the two classifications using a confusion matrix to see which classes were changed 

the most by inclusion of the lidar information.  Go to Classification → Post Classification 

→ Confusion Matrix → Using Ground Truth Image.   
 

Choose Delta_12_mnf_class.img as your Classification Input Image, click OK, and 

Delta_12_fusion_class.img as your Ground Truth Input File, click OK.  ENVI should 

automatically pair all your classes since they are named the same.  Click OK.   
 

Select ―No‖ for ―Output Error Images?‖ and click OK.   

 

A confusion matrix displaying the classes from the fusion classification in the columns and 
from the spectral-only classification in the rows should appear.  Inspect this confusion matrix.  

Which classes were relatively uninfluenced by the inclusion of structural (lidar) data?  Which 

classes lost many pixels when structural information was included?  What were those pixels 
classified as instead?  Which classes gained many pixels when structural information was 

included?  What classes had those pixels been classified as? 

 

 


